• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Hitting enter changes font

New Here ,
Jan 05, 2023 Jan 05, 2023

Copy link to clipboard

Copied

I'll insert a link so you can see it. font change on enter 

When I press enter in my text box the font changes from Frutiger (already set as the default font) to minion pro. I checked find/replace fonts and there is no minion anywhere in the document. If I undo, press delete a bunch then it works the next time, but it's not like I'm deleting font information below because there is none.

 

How can I stop this from happening? When I paste content, I want it to be the same font/style as above, not to always have to delete it/press backsapce a whole bunch before it realizes I want the same font.

TOPICS
Type

Views

124

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Jan 05, 2023 Jan 05, 2023

I see the font changes when you press enter before you even paste the text in, so it has nothing to do with what you are pasting or how you are pasting it. If you are using a style sheet, my guess would be that you have a Next Style set up which is using Minion. This means when you press enter to go to a new line, it changes the style to the next style specified. You'll want to change it to "same style".

Likes

Translate

Translate
Community Expert ,
Jan 05, 2023 Jan 05, 2023

Copy link to clipboard

Copied

Hi @amandag28212880:

 

When you work with hidden characters visible, you can tell if you have picked up the hard return marker or not when you're assigning formatting. If you fully select the line above, including the ¶ before assigning the formatting, then InDesign will carry the formatting to the next paragraph. Watch the type size in the Control panel (top left of your screen capture) at the end of the click after you click but before you press Enter—it shows you 12 pt type. (Not clear why the Character panel doesn't.)

 

Also you don't need to use imgur to post pictures here. There is a an insert image button on the toolbar. It looks like a mountain with a full moon.

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 05, 2023 Jan 05, 2023

Copy link to clipboard

Copied

I agree with Barb. When working with type, it's a good practice to always turn on Hidden Characters so you can view the hard returns which, as she says, can carry a different format that the rest of the text on the line.

 

The easiest way to turn on Hidden Characters is from the menu at the bottom of the tools;

 

Screenshot 2023-01-05 at 12.31.14 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 05, 2023 Jan 05, 2023

Copy link to clipboard

Copied

Okay I can see how it has # instead of the ¶. After I click enter there it changes the font, how do I stop that in the dicument overall instead of having to backspace or delete before pressing enter? Is it because I'm pasting text into it?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 27, 2023 Jan 27, 2023

Copy link to clipboard

Copied

LATEST

Hi @amandag28212880,

 

Hope you're doing well!

 

We would like to follow up on your issue. Are you able to resolve the issue by following our expert advice? Please feel free to update the discussion if you need further assistance from us.

 

We would be happy to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 05, 2023 Jan 05, 2023

Copy link to clipboard

Copied

Hi @amandag28212880:

 

I can see the new type size after you press Enter but before you paste. If the issue is in the existing formatting which both Steve and I thought it was, then click in the story, select all and either assign the paragraph style if you're using one or set the formatting manually. Then go ahead with the paste.

 

You can control whether content retains formatting when you paste or adapts to the existing formatting. One way to get the content to paste without formatting is to use Edit > Paste without Formatting

 

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 05, 2023 Jan 05, 2023

Copy link to clipboard

Copied

Pasting content has a number of quirks. Unless you are careful to avoid it, pasted text will bring in its own formatting, which can pollute your style lineup and cause the frustrating "phantom changes" you're seeing.

 

The very simplest way to avoid this 'pollution' is to paste without formatting. Instread of just hitting Ctrl-V, right-click at the point of insertion, and from the context menu, click (surprise!) Paste Without Formatting. Only the text content will be pasted, absorbing its style from that of the insertion point. (You can also use Ctrl-Shift-V, but you might use the menu for a while until you're comfortable with how it works.)

 

You can make this a default, and set some other options, in the Preferences | Clipboard Handling menu.

 

There are more layers to importing and pasting text and getting styles to stay stable and predictable, but that's the big step #1.

 


| Word & InDesign to Kindle & EPUB: a Pro Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 05, 2023 Jan 05, 2023

Copy link to clipboard

Copied

I see the font changes when you press enter before you even paste the text in, so it has nothing to do with what you are pasting or how you are pasting it. If you are using a style sheet, my guess would be that you have a Next Style set up which is using Minion. This means when you press enter to go to a new line, it changes the style to the next style specified. You'll want to change it to "same style".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines