• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

How do I get Punjabi text to display properly?

Community Beginner ,
Oct 09, 2022 Oct 09, 2022

Copy link to clipboard

Copied

Hey all; I'm migrating a book from English to Punjabi. (I don't read Punjabi or any Indic language) The translator provided me with a PDF and a word doc and I'm basically just to cut and paste it paragraph by paragraph but for some reason when I paste the text into InDesign it looks different.

Here's an example  - the bottom text is the PDF that the translator provided, the top is my InDesign doc. (Actually a brand new doc as I was worried the leftover styles from the English were maybe the issue); I've circled a few of the glyphs that look wrong/different but its peppered all through the text.

 

I've run the Indic Prefernces .js script, and set the default composer to "Adobe World-Ready paragraph Composer" in the Advanced Type Paragraphs. I'm using Arial Unicode MS font (Because that's what the translator suggested though I also tried Gurmukhi to no avail) and set the character to Punjabi (India) - I'm on Adobe's Creative Cloud and pulling my hair out.  Any Punjabi InDesign experts have any insights what I can do or what's going on? Cheers in advance.

TOPICS
Bug , How to , Performance , Scripting , Type

Views

5.9K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 10, 2022 Oct 10, 2022

Copy link to clipboard

Copied

Try Adobe Devanagari availble on Adobe Fonts

 

https://fonts.adobe.com/fonts/adobe-devanagari

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 11, 2022 Oct 11, 2022

Copy link to clipboard

Copied

I did as well but nada.  inDesign just doesn't seem to work with Punjabi.  I need a solution for this client though.  

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 11, 2022 Oct 11, 2022

Copy link to clipboard

Copied

Yeh I did a bit of research but can't find too much on this. 

 

I'll find out more and hopefully someone can help you out. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 12, 2022 Oct 12, 2022

Copy link to clipboard

Copied

Update: I have also asked for someone from Adobe to help, but they have not responded yet. I'll keep asking!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2022 Nov 20, 2022

Copy link to clipboard

Copied

DEVNAGRI IS NOT PUNJABI  - DEVNAGRI IS A SCRIPT FOR HINDI LANGUAGE, AND GURMUKHI IS THE RIGHT SCRIPT  FOR PUNJABI

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 21, 2022 Nov 21, 2022

Copy link to clipboard

Copied

No need to shout!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 18, 2022 Oct 18, 2022

Copy link to clipboard

Copied

Hello again, @Pomodu. I received this message today from Adobe:

 

It seems like a copy paste issue. The MAX update ID 18.0 consists of Copy Paste Enhancements, plz ask the user to try again with the new version later today.

 

After the new release is installed, please come back to let us know if the new version solves your issue. If not, would it be possible for you to share a sample file showing the problem so we can better analyze this for you?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 18, 2022 Oct 18, 2022

Copy link to clipboard

Copied

I have a real hard time letting this advice go uncommented-upon. This is not a clipboard issue. The only new clipboard features I see in the new product announcement are related to copying between Illustrator and InDesign - although maybe one of the other regulars who are paying closer attention to new features can correct me if I'm wrong. 

 

Also, updating to the latest release right before trying to do deliver a product to a client is, in my own humble opinion, a dangerous strategy. Maybe it's my decades of being a Mac user talking here, but I never install any software update the day it comes out, and I never try to put the x.0 release into production if I can possibly avoid it. Almost every single time, for every single app, there's going to be an x.0.1 release within a day or three that patches something nasty.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 18, 2022 Oct 18, 2022

Copy link to clipboard

Copied

Understood, @Joel Cherney. I've asked the Adobe employee to come back to this post and further explain.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 18, 2022 Oct 18, 2022

Copy link to clipboard

Copied

Hi @Joel Cherney,

 

Thank you for your valuable input. In addition to the points already discussed here, I'd like to add that in the latest version of InDesign, Copy-Paste workflow enhancement is not only between InDesign & Illustrator but other Adobe CC apps like Photoshop and Acrobat. For more information, please check this discussion

 

Regards

Rishabh

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 18, 2022 Oct 18, 2022

Copy link to clipboard

Copied

Complex script text like Punjabi won't render correctly if you haven't turned the World-Ready Composer on. The way I'd do it would be to place the translator's Word document, so I'd get all the Punjabi text all at once in one story. That may or may not work for you, I dunno. Then, I'd go to Type and select Apply World-Ready Composers. That applies the WRC to all of the text in your document.

 

You do say that you've turned the WRC on, but there are plenty of ways that you could have clicked on Type-Apply World-Ready Composers and have it not apply to your text. For example, that tool doesn't change your paragraph style settings. If you copy your Punjabi paragraph to the clipboard, then draw a new text frame, then the paragraph style applied won't have the WRC turned on (unless you edited the style yourself, manually).

 

Lastly: you can check to see if the WRC is on for a given paragraph yourself. Select all glyphs in a paragraph with the Text tool, then go to Type -> Justification (or whack Control-Alt-Shift-J, on Windows, the Mac shortcut is Option-Command-Shift-J) and look at the dropdown. I feel 99.44% certain that the sample paragraphs in your posted screenshots have the Composer set to Adobe Paragraph Composer; that's just what it looks like on Punjabi when the WRC is not turned on.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 18, 2022 Oct 18, 2022

Copy link to clipboard

Copied

Hi @Pomodu ,

 

Sorry to hear about the trouble. Could you please share a few more details like:

 

  1. The version of InDesign & OS.
  2. The font details used on the original file?
  3. Is this happening on any other application as well?
  4. Will it be possible for you to share the word document for testing? If yes, you can DM me by clicking on my name.

 

Regards

Rishabh

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 03, 2023 Apr 03, 2023

Copy link to clipboard

Copied

Hi there, 

Curious if you found a solution that worked. I am working on a multi lingual set of documents and the Punjabi set has turned into a nightmare. I'm in the exact same situation where I need to find a solution for my client. I have tried all of the Gurmukhi fonts available through Adobe to no avail. I'm going to try AWC tonight but if you found a solution I would love to hear it. Thanks so much in advance.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 03, 2023 Apr 03, 2023

Copy link to clipboard

Copied

I have tried all of the Gurmukhi fonts available through Adobe to no avail.

 

Can you post a screenshot of it not working? Can you tell us anything about how the text got to you, and how you're working with it? Were you supplied with Word docs or IDML or XML, or something else?

 

As far as the sentence of yours that I quoted above, there's not that many possibilities regarding what could be going wrong.

 

Either

1) You haven't turned on the World-Ready Composer

or

2) You have something written in in a pre-Unicode font

 

If it's number 2, that'd be clear from the screenshot, because most of the common pre-Unicode encodings for Indic languages are pretty obvious when you look at 'em without the correct fonts installed. If the text is rendering more or less like Gurmuhki, but there are missing marks or ligatures that aren't working correctly, then it's almost certainly going to be InDesign language settings, particularly the World-Ready Composer. 

 

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 04, 2023 Apr 04, 2023

Copy link to clipboard

Copied

Hi Joel, Thanks for getting back to me. The text came to me via a word document (font says Callibri) and then corrections via mark-up comments in the PDF I generated. I've turned on the World-Ready Composer and switched to a different Gurmuhki font which has corrected most of the issues. One character combo ਕ੍ਰ still is apprearing differently. See attached here Screen Shot 2023-04-04 at 8.32.15 pm.png, the little ligature or descender is centered instead of attached to the bottom right. I'm hoping that is stylistic and still legible but I don't know the language so unsure. I've turned ligatures off and on but it didn't make a difference. If you have any ideas, I would be incredibly grateful. Thanks again!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 04, 2023 Apr 04, 2023

Copy link to clipboard

Copied

Thank you for posting an interesting question! My apologies for the length of my response. If you won't read it, the short version is "Use the font Nirmala UI". 

 

A corollary of Murphy's Law states that, if I claim that your question has to have an answer of either "number 1" or "number 2", then the answer will invariably be "number three." We might need an actual Punjabi type nerd in here to tell us if my conclusions are correct, but I am confident that I can get us 90% of the way there. 

 

So: we can see the glyph in question in live text, in your post. If anyone out there isn't sure that their Gurmukhi glyph is rendering correctly, we can all go paste it into the Unicode Text Rendering Reference System:

 

ka halant ra.png

Says right there that the font Lohit renders the composite glyph correctly. Lohit is a Red Hat font, so it's available from the Fedora Project. I had to dig for a bit - I found some dead links - but you can download it from here if you have the right decompression tools installed to unpack a Linux tarball.  

 

I installed Lohit Punjabi from that package, as well as a few other Gurmukhi-supporting fonts, and then made a comparison image for our benefit. In doing so, I think I have found broad incompatabilities between these fonts and the font rendering engines in InDesign. Watch what happens to the Lohit Punjabi in the first text frame when I resize the frame:

lohit.gif

Both variants can be found inside Lohit (or at least both variants can be built from combining bits), when I'm browsing it via the Glyphs menu.

 

When you say it's rendering correctly in Word, then I'm willing to bet that it's not in Calibri, but actually in the Microsoft-provided font "Nirmala UI" which appears in my demo above. If you have some complex-script keyboards installed in Windows, then your MS Word Fonts dialog will show you this:

 

nirmala.png

 

To go on: if something is buggy on the Internet, chances are that people are talking about it. And lo, they are! I found this bug report on GitHub for the Noto Sans Gurmukhi font, discussin the very issue you're facing. That bug was closed and split into three separate discussions, the first of which has this interesting comment from a font developer:

 

"This may be by design. Some typesetting systems were unable to physically connect the subscripts to the base letter in the way normally done in manuscript and in handset metal type, so the subscript sat below the letter with a small gap like this. Notably, Linotype Gurmukhi followed this in the transition from hot metal to early digital typesetting, so Punjabi readers were familiar with it from newspapers."

 

So, I think that this is probably okay with either rendering. We aren't Punjabi type nerds, so we don't know for sure, but that's my guess. This kind of thing happens all the time; a given writing system couldn't be reproduced with mid-20th-century typesetting technologies (check out "hot metal typesetting" if you're curious and haven't read about it before). So, people – typesetters, people reading newspapers, etc.  became accustomed to workarounds. Those workarounds wind up getting preserved in digital type; it's a "survival", a practice that used to be a perfectly reasonable hacky workaround that is no longer necessary, but we keep doing it because That's The Way We've Always Done It. 

 

However, I doubt that your reviewer feels that way. So in your shoes, I would just use Nirmala UI as my Gurmukhi font, to keep the reviewer from dinging me for incorrect rendering. I probably wouldn't try to start a disagreement about typesetting with my reviewer (depending, of course, on how salty I felt that day). I will see if we can't get someone who actually knows to review my post to see how close to the mark I came. Once that is done, I will go file a bug report over at indesign.uservoice.com.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 25, 2024 May 25, 2024

Copy link to clipboard

Copied

I've figured it out after weeks of struggling.

 

I checked and unchecked so many different options in all my settings and finally came across this in the Paragraph tab.  Select "Middle Eastern and South Asian Every Line Composer" and it fixes all the wonky jumbled characters.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 25, 2024 May 25, 2024

Copy link to clipboard

Copied

LATEST

That's how to get these fonts to render more-or-less correctly in Illustrator, but you've posted your solution in the InDesign forum. You're not wrong, though!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines