• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

How do I merge all InDesign Interface panels and windows back into one window?

Community Beginner ,
May 14, 2022 May 14, 2022

Copy link to clipboard

Copied

My InDesign interface is in pieces. All workspace panels, the home panel and the "advanced" panel are all floating separate from the document window. It is very hard to move InDesign from one sceen to another, because I have to move five different panels/windows to work with it. I don't have to do this with any other app. Does anyone know how to merge them back into one window like Photoshop/Illustrator/every other adobe program? This just happened and it's very frustrating. Anyone out there know how to help?

 

Thanks,

Sue

TOPICS
How to

Views

240

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , May 15, 2022 May 15, 2022

Hi James,

I figured it out. Its an issue with having an external monitor. 

Here's the fix..

1. Go to InDesign/Preferences/Interface .. uncheck "Open Documents as Tabs"

2. Unplug your external monitor.

3. Quit InDesign and Open Indesign again. 

InDesign's Application Frame comes back and you can plug your monitor back in.

 

I hope they fix that glitch. It took me 4 hrs to figure that out. 

 

Thanks,

Sue

 

Likes

Translate

Translate
Community Expert ,
May 14, 2022 May 14, 2022

Copy link to clipboard

Copied

Go to Window | Workspace and select the standard layouts until you find the one you prefer.

 

The more advanced approach is to break out all the panels you like, arrange and size them as you prefer, and then save that workspace as [Sue] or whatever, so you can call it back when you mess up the layout. Or develop two or three workspace layouts for different tasks and workflows. It's a very, very flexible and useful feature.

 


| Word & InDesign to Kindle & EPUB: a Pro Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 14, 2022 May 14, 2022

Copy link to clipboard

Copied

Hi James,

I tried all of the "Workspace" styles, but that does not bring all the panels together into one window. It just changes out the panels to match what tools you would need for what type of project you are working on. My problem is more simple. I just want to have all parts and pieces of my InDesign workspace in one window that I can drag around my monitor in one mouse click. I just want InDesign to look like Photoshop, Illustrator, Dreamweaver, etc.  I don't know what happened. It was fine last week and now I can't get the different panels to connect to each other. 

 

Thanks,

Sue

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 14, 2022 May 14, 2022

Copy link to clipboard

Copied

I thought at least one of the default options pulled all the palettes back into the docked mode — when I click Advanced, for example, everything collapses into one docked panel set (on the right edge). That sounds like what you wanted/started with.

 

All the palettes are drag/drop/magnetic. Grab them by the top bar and drag them to where you want — tiled next to another palette group, merged into a palette set (becomes a tab in that group) or docked on one edge of the ID window (from where you can fly them in and out with the little double arrow icon). A blue line shows you where the merge will happen if you let go of the drag.

 

If things really won't dock/stick/merge, you may have corrupted preferences. Reset your preferences and see if that fixes things. (Can't recall the key combo right offhand, it's in here somewhere.)

 


| Word & InDesign to Kindle & EPUB: a Pro Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 15, 2022 May 15, 2022

Copy link to clipboard

Copied

Hi James,

So I reset my InDesign preferences (press Shift+Option+Command+Control, start InDesign), but it still isn't showing a normal interface with all panels connected in one window. 

I seem to be in a "full-screen" mode, but pressing ESC or CMD L of F11 (or any other keyboard combos that have been recommended) doesn't bring me out of it.
Basically, I have no Application Frame. The top bar with the red, yellow, and green dots on it is missing and I can't figure out how to get it back.

 

Thanks, Sue

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 15, 2022 May 15, 2022

Copy link to clipboard

Copied

Hi James,

I figured it out. Its an issue with having an external monitor. 

Here's the fix..

1. Go to InDesign/Preferences/Interface .. uncheck "Open Documents as Tabs"

2. Unplug your external monitor.

3. Quit InDesign and Open Indesign again. 

InDesign's Application Frame comes back and you can plug your monitor back in.

 

I hope they fix that glitch. It took me 4 hrs to figure that out. 

 

Thanks,

Sue

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 15, 2022 May 15, 2022

Copy link to clipboard

Copied

And I posted the below simultaneously. Yep, switching to and back from external monitors can cause exactly this kind of "keyhole" effect.

 

Didn't ask enough questions about your hardware setup to narrow this down more quickly. 😛

 


| Word & InDesign to Kindle & EPUB: a Pro Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 15, 2022 May 15, 2022

Copy link to clipboard

Copied

Well, I'm mystified, and I am not sure how much of the problem is technical (something actually wrong with your system) and how much is... semantic? as in not quite grasping what you're trying to communicate.

 

Clicking on the Advanced workspace should give you something looking a lot like this, with the whole window and the palettes grouped/collapsed on the right border:

JamesGiffordNitroPress_0-1652649869971.png

 

 

If you don't have the top bar and edges of the app, there is a rare(ish) problem where an app window exceeds the size of the display and takes the top menus and control buttons off the screen; in some cases it can be very frustrating to fix. Under Windows, I can use Alt+Tab to select any open app, then Alt+Space to open a menu that includes the option "Move." If I click that, I can use the arrow keys to move the oversized app window around until I can grab a corner and scale it down, or click Maximize to make it full screen (with controls) size. Not absolutely sure what the corresponding keys are on a Mac, but that's the approach I'd take.

 

This situation is often caused by switching to an external monitor with a larger area than a laptop screen, and the app gets sized to the bigger plot and does not downsize once it's no longer available. Not sure if you've done any monitor-changing or the like.

 

If it's not that (an app window stuck in "oversized" mode), I am not at all sure what the problem and resolution might be.

...then I think someone is going to have to sit right at your keyboard to work this out.

 

 


| Word & InDesign to Kindle & EPUB: a Pro Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 15, 2022 May 15, 2022

Copy link to clipboard

Copied

Hi James,

I've used an external monitor with my laptops for decades and yes, there is often an issue with an application frame ending up too large for the laptop monitor when disconnecting the external monitor and all your applications have to regroup onto your laptop's monitor. This was not the case. InDesign was leaving out the Application Frame completely and only allowing a strange full-screen mode on my laptop monitor. It's an InDesign glitch. I finally, after two days of searching, found someone who had figured it out.  

 

Thanks for your time and attention,

Sue

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 15, 2022 May 15, 2022

Copy link to clipboard

Copied

LATEST

It happens with nearly all apps on the right (wrong?) combination of OS, system, monitor sizes and drivers. Not every combination has the hooks to "know" the physical screen size has changed and that things like the window/app frame controls aren't accessible.

 

The nearly universal solution is (1) to recognize that's what's happening and (2) use the keyboard "move" feature to push the app window down so you can grab a corner and/or access the window buttons. Sometimes even the forced-reset you used won't work if the app insists that there ain't no problem. 🙂

 


| Word & InDesign to Kindle & EPUB: a Pro Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 14, 2022 May 14, 2022

Copy link to clipboard

Copied

You can reset back to the original setup of your current workspace by choosing Window > Workspace > Reset [your workspace name].

 

If you don't like your current workspace, choose another in Window > Workspace. After choosing a workspace you can reset it to how it was originally saved by choosing Window > Workspace > Reset [your workspace name].


— Adobe Certified Expert & Instructor at Noble Desktop | Web Developer, Designer, InDesign Scriptor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines