ID won't retain all .doc formatting, adding spacing after every line

Community Beginner ,
Sep 16, 2022 Sep 16, 2022

Copy link to clipboard

Copied

This has never been an issue until now. I use Microsoft Word when formatting, and I save the files as .doc files. Even if I save it as a .docx file, the issue persists.

I go to File, Place in InDesign, select my document, and click Place. The document keeps most of its formatting, but my Times font is automatically changed to Cambria, so I have to manually change it every time. Why would it not just keep Times since it's already in the program?

But more maddening is that now, all of a sudden, a bunch of extra space is being added after every single line. Deleting to the previous line and pressing Enter/Return does nothing. It's like the entire thing is default to double-space, and the only way I can fix it is to go to the Paragraph bar and change the Space After box to 0. I've never had to do this before. Is there a way to default that Space After box to 0? It's never done this to me before, but now it won't stop.

I'm using the latest version of Mac OS Monterey on a brand new computer with an M1 chip, as well as the latest version of all Adobe programs.

TOPICS
Bug , How to , Import and export

Views

215

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Sep 19, 2022 Sep 19, 2022

Your last screenshot shows that you have setup your paragraph style with 0.1389 inches in the space after field. If the text is aligned on the baseline grid, it produces this gap. That's completely normal.

If you don't want spaces between paragraphs, why don't you simply modify the paragraph style setttings and remove the space after?

Likes

Translate

Translate
Community Expert , Sep 19, 2022 Sep 19, 2022

What @jmlevy means is this:

JamesGiffordNitroPress_0-1663616022527.png

That's defining space after the paragraph, whether it's embedded in the style definition or done by override. I can't see a style name, so can't determine if there's a + override marker on it.

 

I think you just need to fix your style, removing the space after.

 

Likes

Translate

Translate
Community Expert ,
Sep 16, 2022 Sep 16, 2022

Copy link to clipboard

Copied

Import from Word is usually reliable, but can be glitchy.

 

The first thing to keep in mind is that you should use managed styles in Word, with no spot override formatting, and then have matching styles in InDesign. Don't count on ID to import every aspect of a Word style faultlessly. The two styles can be night and day; InDesign will apply its defined style simply by name-matching, not by any characteristic of the Word style. So the takeaway there is that you can be casual with your Word styles and set them up to be easy to write and edit, and then completely change them to your layout style on import.

 

What I think might be happening here is that you are importing, say, "Body Text" style to a style of that name in ID that has these different characteristics. So make sure the ID style is exactly what you want it to be, and that's how text with that style name will be formatted on import.

 

It can help to use the Import Options menu when you place the file. When you select the file for placing, check the Show Import Options box at the bottom. This will let you do a number of things including reviewing and managing the way styles are mapped between the two docs.

 

Further questions welcome. It's a fussy process but you have to manage it, not just let the two programs slug it out.

 

|| Word & InDesign to Kindle (& EPUB): a Professional Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

I've used the Import Options menu, and everything is set to the way it should be, yet things are still not importing properly. The biggest issue is the Space After feature. This has never been an issue until now. My question is, can I set the default Space After to 0 so that I don't have to go back and forth between Character and Paragraph sections in ID every time I import a Word document?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

Can you show us a screen capture of the document that shows the problem, please. Make sure non-pring characters are turned on.

Also show us the paragraph style name assigned to that text and the style defintion dialog for that style.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

And  your import options are showing a conflict with two style defintions. In such cases it's probably safer to use the Word definitions rather than the InDesign defintions as you've specified if you really want to preserve all word formatting. You can always edit the styles after import.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

Here are photos of what's happening. As you can see in the Word document, everything is set to single-space, Times. Going to File, Place in ID, I have all formatting options set to be preserved. This is what I get. All text changed to Cambria, double-spaces after every paragraph. And I've tried it on a few documents, all with the same result.

Screen Shot 2022-09-19 at 2.03.13 PM.pngScreen Shot 2022-09-19 at 2.03.31 PM.pngScreen Shot 2022-09-19 at 2.04.19 PM.pngScreen Shot 2022-09-19 at 2.06.49 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

Your last screenshot shows that you have setup your paragraph style with 0.1389 inches in the space after field. If the text is aligned on the baseline grid, it produces this gap. That's completely normal.

If you don't want spaces between paragraphs, why don't you simply modify the paragraph style setttings and remove the space after?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

That's my problem - I don't want that Space After to be 0.1389 inches. I want it to be 0 by default.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

Then your clean, unmodified style has to be zero. I am getting the impression that you're doing everything but globally correcting the style definition. Everything else will be temporary, ready to revert to the definition with each use.

 

|| Word & InDesign to Kindle (& EPUB): a Professional Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

What @jmlevy means is this:

JamesGiffordNitroPress_0-1663616022527.png

That's defining space after the paragraph, whether it's embedded in the style definition or done by override. I can't see a style name, so can't determine if there's a + override marker on it.

 

I think you just need to fix your style, removing the space after.

 

|| Word & InDesign to Kindle (& EPUB): a Professional Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

This may have been asked above, but I don't see an answer.

 

Is the unmodified/un-overridden body text style set to Times and no spacing? Can you create a clean doc, write a short paragraph or two, apply the body style (and make sure there are no + overrides in place!), and show the result?

 

That is, and it may seem obvious, is the ID body style behaving when used completely on its own and showing the faults only on imported Word content? (Be extremely alert to any overrides on both paragraph and character styles.)

 

|| Word & InDesign to Kindle (& EPUB): a Professional Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

Yes, the original Word document is set to no spacing. And creating a brand new document with no modifications produces the exact same issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

This is almost certainly the style I mentioned earlier that has the conflict and that your options set to use the InDesign style defintion instead of the incoming Word defintion.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 20, 2022 Sep 20, 2022

Copy link to clipboard

Copied

Okay, but my Import Options don't give me a choice to use the Word formatting. It only gives me three options: 

1. Use InDesign Style Definition
2. Redefine InDesign Style
3. Auto Rename

I see the yellow ! with the conflicts, but it appears there's no way to resolve them.

Screen Shot 2022-09-20 at 8.10.15 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 20, 2022 Sep 20, 2022

Copy link to clipboard

Copied

If you have style conflicts, it is because the Word style and the InDesign style have the same name but have different attributes. If you choose “Redefine inDesign style”, it will be updated according the Word settings. So, if you are sure that the Word styles settings are OK, choose this option. If tou are not sure, choose Autorename: a new style will be created with the Word settings and you will be able to choose which one you actually want to use.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 20, 2022 Sep 20, 2022

Copy link to clipboard

Copied

AHA! That did it! That's what I was looking for!!! I didn't know what Redefine InDesign Style was - I was afraid that would mess literally everything up LOL! Okay, that seems to have fixed the issue! Thank you!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 20, 2022 Sep 20, 2022

Copy link to clipboard

Copied

This thread has touched on several ways to resolve the problem, all beginning with "what is the existing ID style?" — possibly the most fundamental aspect of the issue.

 

😐

 

|| Word & InDesign to Kindle (& EPUB): a Professional Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 20, 2022 Sep 20, 2022

Copy link to clipboard

Copied

Whenever I create a new document, the Space After box is set to 0. The issue happened when a Word .doc was imported - it automatically created .1398 or whatever After Spacing.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 21, 2022 Sep 21, 2022

Copy link to clipboard

Copied

  • Is there any paragraph styles in this InDesign document? Check them.
  • Do you use one of them?
  • Check the settings of the [Basic paragraph style]
  • Check the Word paragraph style settings

Can you post a screenshot of your InDesign document with the text cursor positioned in one paragraph AND the paragraph styles panel?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 21, 2022 Sep 21, 2022

Copy link to clipboard

Copied

It says [Normal+], and the + is probably from me telling it to change the Redefine InDesign Style option in Import Options. Here is what it looks like:

Screen Shot 2022-09-21 at 8.09.32 AM.pngScreen Shot 2022-09-21 at 8.10.02 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 21, 2022 Sep 21, 2022

Copy link to clipboard

Copied

On which paragraph is applied the [Normal] paragraph style? In your text, you have 6 different formattings:

  • Left aligned ital
  • Centered underlined caps
  • Left aligned bold 
  • Right aligned bold
  • Left aligned caps without underline
  • Justified 

So, you should have at least 6 different InDesign paragraph styles. You can set up a style correspondance between Word styles and InDesign styles in the import options. But, IMHO, it would be easier to import the text as an unformatted text, then apply  the InDesign styles, and if you use the next style feature, you can do this in a single click.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 22, 2022 Sep 22, 2022

Copy link to clipboard

Copied

They all say [Normal] regardless of where I click. But changing it to Redefine InDesign Style seems to have fixed the issue, so I'll take it! 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 22, 2022 Sep 22, 2022

Copy link to clipboard

Copied

They all say [Normal] regardless of where I click.

So it means that you did not make any style correspondance and that you don't use styles. You really should…

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 20, 2022 Sep 20, 2022

Copy link to clipboard

Copied

I'm sorry, but I haven't seen a specific answer to this: does the InDesign document style, unmodified and with no overrides, before any Word import, have bottom spacing set?

 

And when the spacing shows up, is it on paragraphs with a style override (StyleName+ ... with the + flag)?

 

|| Word & InDesign to Kindle (& EPUB): a Professional Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

If you have a clean, empty ID document using these styles, and enter a few paragraphs of content (either typed in or from a completely unformatted source like Notepad), and you apply the styles that should have a space after setting... is the spacing correct?

 

|| Word & InDesign to Kindle (& EPUB): a Professional Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines