• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

InDesign: Adjusting 'space after' for only last line of bulleted list (using paragraph style)

Community Beginner ,
Dec 07, 2018 Dec 07, 2018

Copy link to clipboard

Copied

I have created a paragraph style for a bullet list. However, I want the "space after" amount for the last bullet in the list to be different by default than the "space after" amount for the rest of the bullets within the list. For instance, in a list of five items, I want bullets 1-4 to have a space after of "0.0625 in," but for the fifth (and final) bullet in the list, I want it to be "0.1389 in."

I've set the "space after" in my paragraph style to "0.0625 in" -- but I don't want to have to manually go back to every list to change the final line to the greater spacing I desire. Is there a way to customize a paragraph style in such a way?

Views

6.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Dec 07, 2018 Dec 07, 2018

Hi Kristin:

In v 13 or earlier, define the bullets normally with desired space between the bullets:

Screen Shot 2018-12-07 at 12.17.39 PM.png

Then select the bullets, and set the Span to Span All:

Screen Shot 2018-12-07 at 12.19.26 PM.png

Then Alt/Opt click on the icon in front of Span All to open the Span Columns dialog box. You can define space for both before and after the spanned bullets:Screen Shot 2018-12-07 at 12.19.55 PM.png

If you are using paragraph styles, you can use Redefine Styles to update all of the bullet lists in your document.

~Barb

Likes

Translate

Translate
Community Expert ,
Dec 07, 2018 Dec 07, 2018

Copy link to clipboard

Copied

Hi Kristen:

There is a new feature that addresses this specific issue in CC 2019 (v 14) and a work-around that is effective for a 1-column layout in earlier versions. Which version are you using?

We can explain the one that will work for you once you let us know your version.

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 07, 2018 Dec 07, 2018

Copy link to clipboard

Copied

Thank you! I'm on CC 2018, so still v13, I believe.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 07, 2018 Dec 07, 2018

Copy link to clipboard

Copied

Hi Kristin:

In v 13 or earlier, define the bullets normally with desired space between the bullets:

Screen Shot 2018-12-07 at 12.17.39 PM.png

Then select the bullets, and set the Span to Span All:

Screen Shot 2018-12-07 at 12.19.26 PM.png

Then Alt/Opt click on the icon in front of Span All to open the Span Columns dialog box. You can define space for both before and after the spanned bullets:Screen Shot 2018-12-07 at 12.19.55 PM.png

If you are using paragraph styles, you can use Redefine Styles to update all of the bullet lists in your document.

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 29, 2019 May 29, 2019

Copy link to clipboard

Copied

Hi Barb, do you mind sharing the other method? Looking to accomplish the same thing in v14.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 29, 2019 May 29, 2019

Copy link to clipboard

Copied

Hi Joel:

In version 14, it is way easier.

In the first screen shot, all of the text has the space after turned on to add space below all of the selected paragraph. Bullets are activated for the selected text.

Screen Shot 2019-05-29 at 4.30.23 PM.png

Activated bullets for the selected text. To leave the space above and below the list intact, but simultaneously remove the space between bullets set Space Between Paragraphs using the Same Style to 0 (or whatever value you like.)

Screen Shot 2019-05-29 at 4.30.34 PM.png

If you are using styles, redefine your bullet style.

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 29, 2019 May 29, 2019

Copy link to clipboard

Copied

Thanks, exactly what I needed!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 29, 2019 May 29, 2019

Copy link to clipboard

Copied

Terrific. Happy to help, Joel.

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 08, 2020 May 08, 2020

Copy link to clipboard

Copied

Loved learning this little gem.  Can't tell you how many docs I've created and manually adjusted the last item in a list.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 07, 2018 Dec 07, 2018

Copy link to clipboard

Copied

Thank you! That worked!

I realized I also then had to make sure my footnotes were set to "span across columns," too, so that they continue to format correctly.


Thanks again for the fast help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 07, 2018 Dec 07, 2018

Copy link to clipboard

Copied

Great! Glad I could help.

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jul 23, 2020 Jul 23, 2020

Copy link to clipboard

Copied

Barb, you are really smart and know a massive amount about InDesign, and you have solved problems for me in the past. This variant of the above may be insoluble without InDesign changing, but…

 

How to you get the spacing to come out right for multiple levels of bullets without manually adjusting the spacing? If there were an option "Space Between Paragraphs Based on Same Style" that might work, so that you could adjust the spacing between more than one level of bullet, that would work, but it doesn't exist.

 

I tried making a new style "Bullets with Sub-Bullets" which worked when every Bullet had Sub-Bullets, but if the previous paragraph didn't have Sub-Bullets and had a paragraph style of Bullet, I got this:

 

Bullet-with-Sub-Bullet-failure.jpg

 

There is also a problem that, if you have a bulleted list right above a heading that is formatted with Space Above (as most recommend as a best practice) then you get more space between the end of the bulleted list and the subsequent heading than you really need.

Thanks for any thoughts.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Dec 15, 2022 Dec 15, 2022

Copy link to clipboard

Copied

I always use use at least 3x ParaStyles for lists:

 

List_1st_line

List_middle

List_last_line

 

And if necessary - extra variants for 1st/last if extra spacing is needed.

 

ID-Tasker - most powerful tool ever created for InDesign

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 15, 2022 Dec 15, 2022

Copy link to clipboard

Copied

I do the same... but primarily because it allows a great deal of fine control for EPUB/Kindle export. Readers have very crude bullet/number list spacing unless you override it.

 

ID, though — If your only goal is that spacing control... the three settings for one style handle it much more simply.

 


| Word & InDesign to Kindle & EPUB: a Pro Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 23, 2020 Jul 23, 2020

Copy link to clipboard

Copied

Hi Keith:

 

You are absolutely right. In your situation, I would return to using the Span trick I explained at the top of this post.

 

~Barb 

 

span1.gif

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jul 23, 2020 Jul 23, 2020

Copy link to clipboard

Copied

Unfortunately, all the documents in which I'm trying to deal with this have two columns per page, so can't use the Span spacing. 😞

I suspect the best might be to have my Bullet paragraph style with no extra spacing after, and then a Bullet with Space After style with Space After of one pica (my grid spacing) for the last bullet in a series.

 

I went through all my documents and, as appropriate, tagged end-of-list Bullet and Bullet-Indent-1 styled paragraphs with Bullet-with-Space-After and Bullet-Indenti-1-with-Space-After styles. Seemed to be pretty easy and no unexpected side effects. You can simply not apply the to the end of a list prior to a heading and that gets rid of the problem with too much white space between the end of the list and the following heading. I think I would recommend it, even if you don't have two columns.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2022 Dec 15, 2022

Copy link to clipboard

Copied

I am dealing with this and it is definetely not working! I need help!! I hate how bullets work on Indesign!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 15, 2022 Dec 15, 2022

Copy link to clipboard

Copied

Bullets in ID are one of its most powerful features. Unless Barb jumps in again, let's walk you through it.

 

What exactly are you trying to accomplish, and what's not working?

 

If it's vertical spacing, here's a summary of all the above:

  1. Set space above to the space you want between a prior paragraph and the first bullet.
  2. Set space below to the space you want between the last bullet and the following paragraph.

 

Now your individual bullets are probably too widely spaced. So:

3. Set Space In-Between to the value you want in between each successive bullet. All inter-bullet spaces will collapse (or, if you set it that way, expand) to this value, leaving only the starting top spacing and the ending bottom spacing at the original.

 

Is that it?

 


| Word & InDesign to Kindle & EPUB: a Pro Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2022 Dec 15, 2022

Copy link to clipboard

Copied

I am trying to have a bulleted list. The bullet creates an indent to the first line but anything after is not indented. I already check all the serttings -0.20 +.20 whatever... I even created a new doc with no parragraph styles and for a minute it worked on the defaults, but as soon as I choose the typeface FUTURA PT everything gets messed up. I really think the typeface is the problem. it is part of typekit.

I currently have a document using that typeface of Sh** and since it is a digital presentation I am changing the size of the typeface in a lot of slides so I have many "parragraph style+" If I change any setting on the style it messes up with my whole presentation, I tried multiple things and nothing is working. What can I do appart from replacing my whole presentation with a different typeface. Tabs are not working either.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2022 Dec 15, 2022

Copy link to clipboard

Copied

Just to be clear, I went to check my parragraph style and the spaces below and above or whatever are set at 18 points and -18 points. But I still have indented bullets with non indented text.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2022 Dec 15, 2022

Copy link to clipboard

Copied

I am trying to figure this out, so I created a new document, I added some random text using futura pt. I added bullets to it, they looked good and the created a style. It was working but then I changed the size of the type and everything got messed up. I tried it again and this time it worked. I think it is a program glitch. my file is still not working, I will need to recreate everything unless you have an answer for me. I also wonder if the text I am using has a different style set on word and somehow it is making the indesign to freak out.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 15, 2022 Dec 15, 2022

Copy link to clipboard

Copied

ID uses a more complex spacing system than, say, Word, which is not as intuitive but allows all kinds of fine control. If  you want a bullet something like this:

  • A fully indented bullet and paragraph where the text aligns at the inner end of the bullet space duplicating this text to make enough of it; A fully indented bullet and paragraph where the text aligns at the inner end of the bullet space duplicating this text to make enough of it

 

Then the spacing control you need to adjust is this (top control bar)

JamesGiffordNitroPress_0-1671144196984.png

 

Basically, you indent the text with the left-spacing, then "outdent" the bullet with a negative value that's less than the indent.

 

There are other aspects including a defined or automatic tab stop at the indent point. Experiment with these settings, and the ones in Bullet and Numbering  defintion for the paragraph style:

JamesGiffordNitroPress_1-1671144299448.png

 

...to see all the positioning options you have.

 

ETA: the defaults you get when you first apply "bullets" to a style are fairly crude. They are almost never usable without adjustment of the indent spacing and tab settings. That's probably why they messed up when you changd font size, etc.

 


| Word & InDesign to Kindle & EPUB: a Pro Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2022 Dec 15, 2022

Copy link to clipboard

Copied

Those options are not working look:

Screen Shot 2022-12-15 at 3.54.53 PM.png

Screen Shot 2022-12-15 at 3.54.39 PM.png

Screen Shot 2022-12-15 at 3.55.09 PM.png

Screen Shot 2022-12-15 at 3.54.23 PM.png

    

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 15, 2022 Dec 15, 2022

Copy link to clipboard

Copied

Are those paragraphs with the bullet list feature enabled, or a typed in "bullet - space - text"? Two very different things and just typing in the elements doesn't produce a formatted bullet list. You don't type the bullets in; the style applies them.

 

  1. Create a few short lines of text.
  2. Select them all.
  3. Create a new style for them.
  4. Edit that style and go to Bullets & Numbering.
  5. In the drop-down list List Type, select Bullets.
  6. Save the style.

JamesGiffordNitroPress_0-1671145789024.png

 

You'll now have an automatically bulleted list, and all of the above information about spacing will apply and work.

 


| Word & InDesign to Kindle & EPUB: a Pro Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2022 Dec 15, 2022

Copy link to clipboard

Copied

These are bullets from the type menu /bulleted & numbered list/ apply bullets/ option. As you can see nothing I do fix the space on the spaces between the bullets or the indentation on the line below. you know? I am giving up, I already created a new document with freash styles, It seems to be working, I will redo my 20 pages, If you work for Adobe know that there are still a lot of things not working, earlier this week my ID didn't want to export a PDF not even after unistalled/Installed proces turning everything off kinda thing, I have so much work yet I need to be re creating stuff because this thing decides not to work. I have over 7 years experience using adobe and InDesign SUUUUCKS!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines