Indesign CC 2019 - missing Workspaces

Community Beginner ,
Oct 17, 2018 Oct 17, 2018

Copy link to clipboard

Copied

Hello! I have recently updated to both Mojave and Indesign CC 2019. Every time I start/open a new document, my saved Workspace disappears and I need to reset it every time. Is there a way to fix this??

Views

11.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Nov 15, 2018 Nov 15, 2018

My workspace was gone also. Uninstalled and reinstalled InDesign CC 2019 and they were back.

Likes

Translate

Translate
Community Expert ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

Try setting it up with no document open. When you have it set up as you like quit the program. When you relaunch it should now be part of your InDesign preference file. If it works then make a copy of your preference file and save it for any future times when you may have to replace your preferences,

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

Thank you Bill! This worked.

Hot tip if anyone is using this as the solution - if all you see with no documents open is the recent documents startup window, simply drop down the Window menu and select a workspace, this will bring the workspace in view.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 21, 2018 Oct 21, 2018

Copy link to clipboard

Copied

Unfortunately, the issue is continuing... As mentioned above, when I open a document/create a new document, my saved workspace palettes to the right (not the toolbar) are not visible. The only way to get them back is to click on the workspace drop down and reset.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 21, 2018 Oct 21, 2018

Copy link to clipboard

Copied

Do you have Application Frames turned on? (Window > Application Frames). I highly recommend that you do because InDesign handles that generally much better than turned off.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 01, 2022 Jul 01, 2022

Copy link to clipboard

Copied

LATEST

Its 2022 and iD is still opening up with no workspace selected.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

What do you mean by "disappears". Do you mean it's no longer the active workspace or is it totally missing from the Workspace menu?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

By disappears, I mean that it is not present - the toolbar is there, but the workspace palettes are not.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

Hi Retts85 ,

did you migrate old settings when installing InDesign CC 2019?

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

Having the same issue. Trying Bill's solution. Works for one document. After I close, back to missing palettes. Turning off Show Start Workspace when No Documents are Open doesn't fix the issue.

Steve, I am running Application Frames.

Uwe, I did migrate old settings when installing CC2019.

I've set up a key command to reset workspace and that works, just more of a pain. Resetting will hold for 

Running Mac OS Mojave 10.14. Indesign 14.0

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

Thanks all, still having the issue, as Dave (above) I am running application frames, and old settings were migrated.

Good tip on setting up a key command to reset workspace.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

What's odd is that it only showed up today. I've been using CC2019 since its release (and previously in beta) and wasn't having the issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

Currently having the same problem.

Have tried all recommended solutions apart from the key command.

I was initially running Indesign 14.0 on High Sierra, i don't think the problem was there. Then overnight i updated OS to Mojave 10.14.

After updating the OS i noticed that my custom workspace wasn't even in the drop down list. I had to find and add it back to the necessary folder. Now the custom workspace is always in the list but the problem of having to reselect it is persisting whenever InDesign is re-opened.

Side note, I'm loving the new Properties panel.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 08, 2018 Nov 08, 2018

Copy link to clipboard

Copied

Hi All,

We are extremely sorry about the inconvenience caused. I would request if you can go to this location Users/[user]/Library/Preferences/Adobe InDesign/Version 14.0/en_US/Workspaces and check if you see the name of your custom workspace there?

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 08, 2018 Nov 08, 2018

Copy link to clipboard

Copied

Yes. Workspace is there. The issues seems to lie with the new Properties & PDF comments panels & OS X Mojave.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 08, 2018 Nov 08, 2018

Copy link to clipboard

Copied

Hi Dave,

Please Copy-Paste it(Workspace XML) to Desktop for backup and try these steps:

  • Close InDesign.
  • Remove Preferences InDesign folders manually
  • ~/Library/Caches
  • ~/Library/Preferences
  • Delete Adobe InDesign and com.adobe.indesign
  • Restore Read/Write permissions on Folders that contain Adobe folders: https://indd.adobe.com/view/d6f78247-7e41-4982-b380-68c0d465fd91
  • Then launch InDesign from Creative Cloud Desktop App and Close again
  • It will create InDesign folders again, then copy-paste workspace again in ~/Library/Preferences/Adobe InDesign/Version 14.0/en_US/Workspaces(Make sure when you paste it InDesign and other Adobe applications are closed)
  • Launch InDesign from Creative Cloud Desktop App

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 08, 2018 Nov 08, 2018

Copy link to clipboard

Copied

I have already uninstalled CC2019 and reinstalled, not copying over any previous settings. The problem still persisted. What is different about what you're recommending?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 08, 2018 Nov 08, 2018

Copy link to clipboard

Copied

Hi,

I am just thinking about the probability of permission error on InDesign preferences folders. As you have already tried, reinstalling and resetting preferences, one possible issue could be permissions.

I am not sure if that is the issue or not because I could not look into your system. If you want you can try these steps or contact our support team for One to One support at Contact Customer Care. They will be able to look into your system and resolve the issue.

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 08, 2018 Nov 08, 2018

Copy link to clipboard

Copied

Srishti

Do you know that this isn't an issue for all Mojave users? I've seen others post it, so I assumed it was broader than my personal machine. The fact that it's associated with the 2 new panels in ID led me to think it wasn't a personal issue. I've run into permissions issues that prevented me from launching the app with other versions, so I know how to work around those. I'm just curious if Adobe isn't encountering this issue as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 08, 2018 Nov 08, 2018

Copy link to clipboard

Copied

Srishti

Just went through your entire process. No luck. I saved a workspace with the Properties Panel & PDF Comments panel enabled. If I open a file with that workspace activated, none of the palettes are visible. I saved a workspace without the 2 new panels enabled. Open a file with that workspace activated, no problems.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 06, 2018 Nov 06, 2018

Copy link to clipboard

Copied

I think this issues is caused by a conflict with Mojave and the Properties panel. I saved a workspace without the new Properties panel and now the issue is gone.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 10, 2019 Jan 10, 2019

Copy link to clipboard

Copied

This worked for me...

Saving it from the Meny/Window/Workspace/Save as new...
Then close all open documents and press save and restart InDesign.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2018 Nov 11, 2018

Copy link to clipboard

Copied

I am also having the same issue from what it sounds like?

Using inDesign 2019, running only Sierra, 10.12.6.

When I open inDesign, my Links panel does not appear even though it is saved in my custom Workspace. If I reset my workspace it appears again. When I then open a file and work on it, Save and Close, the Links panel again disappears on closing the file.

I have tried deleting all my preference files in ~/Library but this didn't help.

Initially I thought it was the new PDF Comments Panel as I had that on the same group but removing it from the group didn't solve the problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 15, 2018 Nov 15, 2018

Copy link to clipboard

Copied

My workspace was gone also. Uninstalled and reinstalled InDesign CC 2019 and they were back.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 01, 2018 Dec 01, 2018

Copy link to clipboard

Copied

You are kidding? O.o What the hack is so f complicated in syncing settings correctly within updates? Every other program does ...  since Win 7 I think. Why not at Adobe 😕

And to not be only destructive:

@Staff: Why doesn't Adobe renew the "sync" option which was in the older versions (2015 I think) or create a possibility to store workspaces and options within the CC libraries?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines