• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Indesign created 4000+ pages when "placing" my novel with formatting

Community Beginner ,
Nov 08, 2022 Nov 08, 2022

Copy link to clipboard

Copied

Hi everyone, 

 

I've encountered a strange problem when importing my novel into Indesign. It's spreading the document over 4000 pages (where some of the pages only have a single word, a single line, or a single paragraph). It's almost like the spacing is spread out 10x during the import. 

 

My manuscript is 132,000 words in 10pt, so it should be around 400-450 pages. I set the size of the document to 5.5 x 8.25, adjusted the margins accordingly, and then tried placing the document onto the top left corner (I'm just following the steps of a Skillshare course). But when it processes the text it's extremely spaced out over 4000+ pages instead of being reasonbly spaced as I would expect.

 

When I import without any formatting selected it places normally and looks great! But that removes at italics that are hidden within the story text, so I can't really do that without having to manually find italics and correct them in post (which would be an absolute nightmare). 

 

It must be something to do with the doc x formatting that is causing Indesign to spread it out over a massive amount of pages. I need to import everything with italics and have the proper spacing, but I just have no idea how. 

 

I've run into this issue on literally step number one, so I'm pretty discouraged in trying to format my novel with Indesign. If anyone has any ideas I'd greatly appreciate it! 

TOPICS
EPUB , How to , Import and export , InCopy workflow , Scripting

Views

178

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 3 Correct answers

Community Expert , Nov 08, 2022 Nov 08, 2022

It sounds like a Keep fault, but I am not sure how it would have been transferred from Word to ID as they don't manage 'keep with next' etc. in quite the same way.

 

That is, if you have all of your body text set to "keep with next" or "keep with previous" or even "keep all lines together," ID goes nuts trying to comply when there are too many lines and paragraphs so connected.

 

Back in Word, make sure your body text style does not have ANY "keep with" settings, and try again.

 

Happy to answer

...

Likes

Translate

Translate
Community Expert , Nov 08, 2022 Nov 08, 2022

Hi @Jens27032826roju:

 

Click on the first page with the Type tool and choose Edit > Select All. Change your Keep Options as shown below. The text will come back into view. 

 

~Barb

 

2022-11-08_18-47-24.png

Likes

Translate

Translate
Community Expert , Nov 08, 2022 Nov 08, 2022

Check the keep options in your paragraph style. Haven eye on the no break function as well. 

Likes

Translate

Translate
Community Expert ,
Nov 08, 2022 Nov 08, 2022

Copy link to clipboard

Copied

It sounds like a Keep fault, but I am not sure how it would have been transferred from Word to ID as they don't manage 'keep with next' etc. in quite the same way.

 

That is, if you have all of your body text set to "keep with next" or "keep with previous" or even "keep all lines together," ID goes nuts trying to comply when there are too many lines and paragraphs so connected.

 

Back in Word, make sure your body text style does not have ANY "keep with" settings, and try again.

 

Happy to answer more questions if you continue to have problems. Word import can be very simple and straightforward, or very glitchy, and there are some "good practices" to apply to the Word doc before import that can make the work in ID easier.

 


| Word & InDesign to Kindle & EPUB: a Pro Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 08, 2022 Nov 08, 2022

Copy link to clipboard

Copied

I think part of the problem might be that I'm trying to import on MacOS, and Idesign doesn't allow you to import straight from Pages. Instead I've exported as a doc x and then used "file" "place" to import the document. 

 

I'm not sure how to check the "keep with" settings since I'm not creating my doc x directly within Microsoft Word. 

 

Maybe an issue is arising during the export of a docx within Pages? If so, I'm not sure how to get around that since I only have one editing software. 

 

I've attached a sample page of the exported doc x manuscript. I tried importing just this short section and it created 271 mostly blank pages. 

 

I set "preserve styles" during the import, and I'm shift clicking on the upper left of the text box to place the text within Indesign. Not sure if it's partly the method I'm using, but the fact that the import without formatting selected works perfectly does support waht you're saying, that there's some strange formatting issue going on with the original file. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 09, 2022 Nov 09, 2022

Copy link to clipboard

Copied

Hi James, 

 

Thank you so much for the help! It was solved by selecting "keep lines together." 

 

I appreciate your suggestions! I'm really grateful there are people like you out there that are willing to help others troubleshoot issues like this. I never would have figured it out on my own, and I probably would have given up on designing my novel myself because of this issue. 

 

Thanks again, 

 

Jens 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Nov 10, 2022 Nov 10, 2022

Copy link to clipboard

Copied

I think you mean DESELECTING?

Selecting would completely hide your text as this amount of text wouldn't be able to fit in any TextFrame.

 

Can automate anything - as long as it doesn't require A.I.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Nov 08, 2022 Nov 08, 2022

Copy link to clipboard

Copied

Are you using File / Place (Ctrl+D) or copy&paste directly from Word? 

 

But without seeing an example of the original text no one will help you 😞 can you share few pages of the docx - don't share INDD as you won't be able to share only part of it.

 

Can automate anything - as long as it doesn't require A.I.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2022 Nov 08, 2022

Copy link to clipboard

Copied

Could be any number of things. Page breaks or other odd characters in the manuscript; funky paragraph style settings; etc. Please share a sample doc/indd template

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 08, 2022 Nov 08, 2022

Copy link to clipboard

Copied

I've attached some dummy text down below! It does the exact same thing with this document as it did with my novel. I suspect it has to do with converting a Pages document (where I've written my manuscript) to a doc x file. 

 

Not sure what to do about it though, other than maybe trying Microsoft Word. I'm not keen on buying more software just to check this issue though! If there's a workaround for Mac that would obviously be ideal. 

 

I appreciate any insight you could give me! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2022 Nov 08, 2022

Copy link to clipboard

Copied

Just to add to what everyone has said, I suggest, after trying other suggestions given, you save a Word doc with just a page or two of your novel and import that and see if that behaves better. Ideally choose a section of novel that you are happy to share here or maybe try filling Word document with dummy text. Or at least show screen shots in Indesign with Show Invisibles on.

- Mark

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 08, 2022 Nov 08, 2022

Copy link to clipboard

Copied

Hey Mark, 

 

I've attached some example dummy text down below. I exported it from Pages as a doc x, and them imported into Indesign using the "place" function. It created hundred of blank pages with just this short example set of pages. 

 

Not sure what I'm doing wrong! I appreciate any insight you could give me on how to get around this issue. 

 

Jens 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2022 Nov 08, 2022

Copy link to clipboard

Copied

Check the keep options in your paragraph style. Haven eye on the no break function as well. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2022 Nov 08, 2022

Copy link to clipboard

Copied

Hi @Jens27032826roju, I tested your test file and had the same result as you. As so many have suggested it is because of strange Keep Settings. @Barb Binder gives the exact settings you want. It's weird that Pages gave such a mangled .docx file but not that surprising. It may not be the only weirdness so keep an eye out. (By the way, the Keep settings on MacOS is command-option-K after selecting the text.) 

- Mark

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 08, 2022 Nov 08, 2022

Copy link to clipboard

Copied

I've also attached a screenshot with "show hidden characters" selected.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2022 Nov 08, 2022

Copy link to clipboard

Copied

@Jens27032826roju, it looks like you've set a primary text frame on your parent/master page, correct?

If so, it could be a contributing factor.

 

My theory is that it's something being built into the Word.docx file when exported from Pages. Pages is a freebie from Apple, so a) InDesign is not likely to accommodate its automatic import into a layout, and b) Pages itself probably isn't making a compliant .docx file (which is a Microsoft file format specification).

 

As @brianp311 said, it could be anything in the .docx file or an InDesign paragraph style that is causing this.

 

Bevi Chagnon | PubCom | Designer & Technologist for Accessible Documents
| Books & Classes | Accessible InDesign | Accessible PDFs | Accessible MS Office |

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2022 Nov 08, 2022

Copy link to clipboard

Copied

Hi @Jens27032826roju:

 

Click on the first page with the Type tool and choose Edit > Select All. Change your Keep Options as shown below. The text will come back into view. 

 

~Barb

 

2022-11-08_18-47-24.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 09, 2022 Nov 09, 2022

Copy link to clipboard

Copied

Hi Barb,

 

Thank you so much for the help! And everyone else who posted suggestions! That solved the issue entirely. 

 

I was getting rather frustrate and discouraged by the problem, so I appreciate you finding me a way around it! 

 

On to designing my novel 🙂 

 

Jens 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 10, 2022 Nov 10, 2022

Copy link to clipboard

Copied

LATEST

Hi Jens:

 

We are always happy to help!

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 08, 2022 Nov 08, 2022

Copy link to clipboard

Copied

Hi Jen,
I took your docx file and save it as a doc file (word 97-2004). Placed it in Indesign by holding down Shift-key and clicking on the first page. Got 6 pages with the doc format, not the 250+ with the docx. You can also try Barb's method. Good luck with your book!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines