Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Indesign does not recognize the document fonts folder after Mac OS Monterey update

Community Beginner ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

After updating to Mac OS Monterey, I am still having issues with Indesign 17 and have found no solutions. I tried using Indesign 16.4 but it has the same issues. Indesign does not recognize the adjacent document fonts folder (see screenshot). I am also having issues with Indesign immediately recognizing the links folder. This is happening on every Indesign document. Can someone please help or has anyone experienced the same? THANKS

TOPICS
Bug, Performance

Views

19.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Oct 28, 2021 Oct 28, 2021
Thanks again for the reply. I found a work around if you just put the fonts from the document fonts folder into the applications font folder. Path is highlighted. Fonts come up the same version. This is a major flaw and needs to be addressed if Indesign no longer will recognize the adjecent fonts folder and autoactivate the fonts.  

Likes

Translate

Translate
Adobe Community Professional ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

Are you working in a local folder or a network share? If local, is a cloud based folder for Onedrive / Dropbox or similar? If so, turn of any smart sync feature.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

Thanks for the reply. The document and document fonts folder are local, sitting right on my desktop in the same folder (see screenshot). Indesign is no longer recognizing or doesn't have the security clearance to open the adjecent document fonts folder and autoactivate the fonts like it has in the past.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

Hi Mud City,

you already posted this or a similar case in this thread:

 

Indesign fonts Issue with Mac OS Monterey update
Mud City, Oct 26, 2021

https://community.adobe.com/t5/indesign-discussions/indesign-fonts-issue-with-mac-os-monterey-update...

 

The news here is that you provided a screenshot.

Thanks for that! I post it here inline for better visibility:

 

Screen Shot 2021-10-28 at 7.58.41 AM.png

 

I'm on Windows 10 and cannot see that issue on my machine. So yes, it could be something with your new system.

Other question: Could it be that the fonts are already installed on your system?

 

And: Could you please show the following panel when the document is open:

Type > Find Fonts… where the used fonts in the document are listed.

Select one of the listed styles and check the More Info .

Please post a screenshot of the Info of one of the missing font styles.

 

Thanks,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

Thanks again for replying. Here is requested screenshot

Screen Shot 2021-10-28 at 9.01.06 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

Thanks!

Hm. Nothing unusual to see, I think.

 

Next you could try:

Move the folder with the InDesign document, the Links folder and the Document fonts folder to your user's Desktop.

 

If this will not help:

[1] Quit InDesign

[2] Rename the Document fonts folder so that InDesign cannot access the font files.

[3] Install the fonts in your system.

This should work to keep you going.

 

But please do also this:

[4] Open the document.

Check if the Info of the font style is showing the exact same version number.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

Thanks again for the reply. I found a work around if you just put the fonts from the document fonts folder into the applications font folder. Path is highlighted. Fonts come up the same version. This is a major flaw and needs to be addressed if Indesign no longer will recognize the adjecent fonts folder and autoactivate the fonts.

 

Path.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

Hi there,

 

Glad to see that the issue is fixed for now, but to get this fixed permanently we would need a few more details. Is the issue related to a specific document or fonts? If yes, could you please share the document with us? You can upload packaged folder to the Creative Cloud (https://helpx.adobe.com/in/creative-cloud/help/share.html) and share the download link.

 

Also, please make sure that InDesign has Full Disk Access and let us know if that helps resolving the issue.

SrishtiBali_1-1635457390177.png

 

 

Regards,

Srishti 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 16, 2021 Nov 16, 2021

Copy link to clipboard

Copied

LATEST

I'm even having issues with all my adobe fonts in Pages which all worked perfectly before the update!  Horrible.

One screenshot shows what it looks like on screen, the other shows that even adjusting the kerning does not help to make things look better. It's all completely flawed.  PLEASE FIX. It worked fine before the update.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

Try resetting your preferences:
The easiest way to reset everything is to delete the InDesign preferences: as soon as InDesign starts to boot hold down Shift, Alt, Ctrl (and Apple/Cmd if working on a Macintosh). A dialog will appear asking to delete the InDesign Preferences, select 'Yes' on this dialog.
Further info and instructions here if needed:
https://helpx.adobe.com/in/indesign/kb/indesign-preferences-support-file-locations.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

Thanks for the reply. Unfortunately this did not work. Same issues

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

" I found a work around if you just put the fonts from the document fonts folder into the applications font folder."

 

Hi Mud City,

so you tried to move the whole folder with the InDesign document, the Links and Document fonts folders to your Desktop and still InDesign could not detect the fonts in the Document fonts folder?

 

Well, that's a bug then. A major one.

Let's see if other Mac OS Monterey users can confirm the issue.

 

If so I'd suggest you do a bug report at InDesign UserVoice:

https://indesign.uservoice.com/forums/601180-adobe-indesign-bugs

 

Also include a link to this discussion here in the report and post back the link of your report in this thread so that others reading here will be able to vote for fixing the bug.

 

Thanks,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 26, 2021 Oct 26, 2021

Copy link to clipboard

Copied

I updated to Monterey and apparently InDesign no longer will recognize your adjacent Document Fonts folder and autoactivate those fonts when you open your file. It will also say you don't have those fonts open even if you do on your system. Anyone else experiencing this, or is it just me?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 26, 2021 Oct 26, 2021

Copy link to clipboard

Copied

What version of InDesign are you running? Does this happen with one InDesign file or have you tested it on others?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 26, 2021 Oct 26, 2021

Copy link to clipboard

Copied

Also, are you running a M1 processor Mac or Intel Mac?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Thank you for your questions. Yes, I've tested on many Indesign docs and all the same bug. I am on a Macbook Pro with Intel and I just updated to Indesign 17.0

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

I tried reverting back to Indesign 16.4 and it has the same bug. Must be the new OS

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

What kind of fonts are stored in the Document fonts folder?

Are they perhaps PostScript Type 1 fonts?

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Thanks for the reply. I was thinking the same thing since Adobe is phasing out Type 1 fonts. No, they are all .otf fonts. I'm a graphic designer and have been working with fonts for 20+ years. Just when you thought font issues were finally going away..... BOOM

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 29, 2021 Oct 29, 2021

Copy link to clipboard

Copied

Mud City said:

"InDesign no longer will recognize your adjacent Document Fonts folder and autoactivate those fonts when you open your file. It will also say you don't have those fonts open even if you do on your system."

 

Well, the point is this:

 

Even if InDesign cannot load the fonts like in your case*, obviously the fonts were recognized ( my theory ) .

And that will block any other fonts installed elsewhere that have the same properties. The Document fonts folder has the highest priority in recognizing fonts. Next comes the Fonts folder in InDesign's application folder. Only then come fonts installed with a mutual folder for all Creative Cloud apps in your User and finally come the fonts installed in your system.

 

A different picture could be seen if you work with a font management software that auto-activates fonts.

 

*The reason why InDesign could not load the fonts successfully is still unclear.

Perhaps you have to allow special access to font files with Mac OS Monterey? Don't know, I'm on Windows 10. But this assumption was the reason why I asked you to move the whole folder to your User's Desktop. That's usually the place where you do not have permission issues at all.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines