Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


InDesign doesn't replace missing glyphs but Photoshop does..

New Here ,
Aug 07, 2021 Aug 07, 2021

Copy link to clipboard

Copied

Hello!

I am using a font that apparently doesn't have German umlauts (äöü). In Photoshop I guess they were automatically replaced with another font and looked normal. In InDesign they are just dots. Is there a way to replace them the same way Photoshop does it? That would save me sooo much time. Or maybe someone here knows how Photoshop does it and how I can figure out which font it uses for the replacement?
Thank you!

TOPICS
Bug, Feature request, How to, Import and export, Print, Type

Views

113

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Community Professional , Aug 07, 2021 Aug 07, 2021
Check the InDesign preferences for missing glphy protection

Likes

Translate

Translate
Adobe Community Professional , Aug 09, 2021 Aug 09, 2021
Hi Raphael, did you download the font file from Dafont? If you check the character map there you see that a lot of glyphs are missing: Contact the font maker to get a full version. Regards, Uwe Laubender ( ACP )

Likes

Translate

Translate
Adobe Community Professional ,
Aug 07, 2021 Aug 07, 2021

Copy link to clipboard

Copied

Check the InDesign preferences for missing glphy protection

EugeneTyson_0-1628355969492.png

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 07, 2021 Aug 07, 2021

Copy link to clipboard

Copied

In the screen shot it looks as if the feont is missing, not just the umlauts. Are you sure it's installed?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 08, 2021 Aug 08, 2021

Copy link to clipboard

Copied

Agree with Peter, likely a missing font. Check the font or simply switch to another font and see if the umlats show up. Minion, for example, is installed with ID, I think, and has a pretty full set of glyphs.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 09, 2021 Aug 09, 2021

Copy link to clipboard

Copied

When I change to another font all the umlauts are there.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 09, 2021 Aug 09, 2021

Copy link to clipboard

Copied

Hmm. I installed it three times. And also uploaded it to my creative cloud. I can use the font in Word (without umlauts) and in Photoshop (showing the umlauts as they should be). So I don't understand why Illustrator is saying that it isn't there.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 08, 2021 Aug 08, 2021

Copy link to clipboard

Copied

You may wonder why people say "missing font" with such certainty. See https://haizdesign.com/indesign/indesign-color-highlighting/

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 09, 2021 Aug 09, 2021

Copy link to clipboard

Copied

Ah thanks. Yeah I guess it shows that the umlauts are missing. But in Photoshop they are there.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 08, 2021 Aug 08, 2021

Copy link to clipboard

Copied

Can you show PS and ID with an insertion point in the text and the Character panel (Window menu) showing in both applications so we can see the typeface actually used? You might also select one of the glyphs in both applications with the Glyphs panel showing so we can see if it's the same glyph.

 


@raphaelar15619474 wrote:

Is there a way to replace them the same way Photoshop does it?



Photoshop does not have Find/Change for glyphs like InDesign does, but you may not need to use that here. We don't know yet.

 

~ Jane

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 09, 2021 Aug 09, 2021

Copy link to clipboard

Copied

Hello Jane!
Did you mean it like that? English is not my first language.

In Photoshop all the glyphs of the font are there. In InDesign there are just dots.
Thanks for helping!

-Raphi

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 09, 2021 Aug 09, 2021

Copy link to clipboard

Copied

In InDesign

 

The font is named QTFrank - with the weight inserted as [Medium]

When there are square brackets around a word like [Medium] for the fonts - that means the font is not installed.

Photoshop has substituted the font - so you're not seeing QTFrank Medium - I don't think so anyway.

 

I posted as screen shot of the preferences in the very first reply - have you tried these settings?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 09, 2021 Aug 09, 2021

Copy link to clipboard

Copied

Hi! Yes. The preferences are exactly like in your picture.
So you mean this whole time I thought I was using QT Frank in Photoshop and LibreOffice etc. I was actually using a different one? haha. How would I find out which font I really used?
Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 03, 2021 Sep 03, 2021

Copy link to clipboard

Copied

LATEST

@raphaelar15619474 wrote:

So you mean this whole time I thought I was using QT Frank in Photoshop and LibreOffice etc.


 

According to your screenshot, you have QTFrank. It's the Medium type style of QTFrank that you are missing. What are your other choices for type styles?

 

85D0142C-5824-456E-8749-C1776A176B31.jpeg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 09, 2021 Aug 09, 2021

Copy link to clipboard

Copied

Hi Raphael,

did you download the font file from Dafont?

If you check the character map there you see that a lot of glyphs are missing:

 

CharacterMap-Dafont.PNG

 

Contact the font maker to get a full version.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines