• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

InDesign Font list jumps to the top during scroll through preview

Explorer ,
Jul 14, 2017 Jul 14, 2017

Copy link to clipboard

Copied

For as long as I can remember, pre InDesign even, I and every designer I know sets some type and scrolls through the font list looking at the live preview on the canvas to pick fonts, compare fonts, find and match fonts, etc. Only since CC have I noticed that scrolling through my font list every 10 or 15 the list jumps me back to the top of the list making this function frustratingly impossible and killing a previously more efficient process. If this is the cost of TypeKit, get rid of it. Disabling it did not help.

Does anyone know what is happening or why it is happening. i found a lot of threads for PS, IL, etc on this subject but few relevant and recent to CC threads on the subject... i need this to change AND SOON! HELP!

Views

4.6K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Sep 05, 2017 Sep 05, 2017

It looks like "Missing Glyph Protection"was the culprit. Disabling it seems to have fixed the issue. i will close the program and reopen and confirm it is still hapenning, but as soon as I turned that off I could scroll all the way through no issues.

Votes

Translate

Translate
Community Expert ,
Jul 14, 2017 Jul 14, 2017

Copy link to clipboard

Copied

Version of InDesign? Operating system?

I have to say that on my two Macintosh computers using the current version of InDesign CC 2017 (or earlier) I have never had this happen.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 17, 2017 Jul 17, 2017

Copy link to clipboard

Copied

Indesign CC 12.1.0.56 x64 Build
Windows 10 Current

I could probably record a video of it. Not sure where I could host said video, though.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 24, 2017 Jul 24, 2017

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 15, 2017 Aug 15, 2017

Copy link to clipboard

Copied

bump for answers

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 15, 2017 Aug 15, 2017

Copy link to clipboard

Copied

Have you tried restoring your InDesign preferences? Instructions here:

Trash, Replace, Reset, or Restore the application Preferences

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 15, 2017 Aug 15, 2017

Copy link to clipboard

Copied

I have not, but this is a brand new install on a brand new computer

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 17, 2017 Aug 17, 2017

Copy link to clipboard

Copied

This did not affect this issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 24, 2017 Aug 24, 2017

Copy link to clipboard

Copied

I restored the preferences and it did not affect the issue. This is really hurting productivity.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 25, 2017 Aug 25, 2017

Copy link to clipboard

Copied

Hi iflo,

If I get your query, you are getting the same set of fonts again and again repeatedly?

If that's the case, first of all, please open the list and check are other fonts visible there?

font list.png

If yes, then please try resetting preferences manually by following the below-mentioned steps.

  • Close all Adobe applications.
  • Go to location C:\Users\user\AppData\Roaming\Adobe and C:\Users\user\Local\Roaming\Adobe and delete InDesign folders.(This will remove all the existing settings from InDesign and will launch application with default settings)
  • Launch application from Creative Cloud.

If still does not work check in safe mode. For details click here : https://support.microsoft.com/en-in/help/12376/windows-10-start-your-pc-in-safe-mode

Please do update discussion with your observations.

Regards

Srishti

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 29, 2017 Aug 29, 2017

Copy link to clipboard

Copied

No, My query is that despite having fonts installed and seeing them in the menu, when I place some text and then scroll through them to preview them (a common practice) I can only get through about 10-15 or so before indesign errors and jumps back to the top of the list. I can pick any font in the list to start from and within 10-15 it will error back to the top and start cycling through from there only to error out back to the top of the list again.

Yes, my fonts are all visible in that menu and they can be selected and previewed. I can scroll through from any font and preview but within 10-15 it will error out back to the top of the list.

The below is what i was suggested to try above and did do and it did not affect the behavior. I didnt think it would though as the font menu functionality is not really a user customizable function of the program in a way that, from a coding standpoint, would cause an effect like this. Which is frustrating because then I had to reset all of our preferences.

I will try safe mode after working hours today as during working hours I just dont have the time to pull it down and test it.

srishtib8795206  wrote

If yes, then please try resetting preferences manually by following the below-mentioned steps.

  • Close all Adobe applications.
  • Go to location C:\Users\user\AppData\Roaming\Adobe and C:\Users\user\Local\Roaming\Adobe and delete InDesign folders.(This will remove all the existing settings from InDesign and will launch application with default settings)
  • Launch application from Creative Cloud.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 05, 2017 Sep 05, 2017

Copy link to clipboard

Copied

Hiya iflo,

Go to Edit ---> Preferences ---> Type and put a 0 in Number of Recent Fonts to Display

That should do it!

Cheers,

Jeff

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 05, 2017 Sep 05, 2017

Copy link to clipboard

Copied

Indeed, I hated recent fonts so I already had this turned off. This is something I had to reset from losing my preferences from one of the above suggestions. I did try turning off the previews in the font menu since I never use that anyway to see if it made a difference. I prefer to see a font preview in the text i am setting hence the scroll through. This did not fix the issue.

I have deduced this from looking at where the fonts always seem to error and jump back to the top. It is any font with what i am calling "non-standard" fonts like a couple of barcode fonts we have, and like this:
233.jpg

I can only surmise that somewhere InDesign is set to jump back to the top on a font with nonstandard characters. That it considers this an error. Which seems silly, and I know for a fact this was not an issue in earlier versions of the software, especially pre CC. However, I can still choose this font and set type with it if I hand select it and I am not "scrolling through". That makes it even more silly. I've looked through the preferences but I dont see a setting pertaining to this.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 05, 2017 Sep 05, 2017

Copy link to clipboard

Copied

It looks like "Missing Glyph Protection"was the culprit. Disabling it seems to have fixed the issue. i will close the program and reopen and confirm it is still hapenning, but as soon as I turned that off I could scroll all the way through no issues.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 29, 2017 Sep 29, 2017

Copy link to clipboard

Copied

Thank you. This was driving me CRAZY for about a year ever since CC. Great detective work iflo, I noticed too that it skipped when I got to certain fonts. I underestimated how important this live scrolling was to my design process, I don't know how i was living without it. I actually learned about this feature relatively late in my design career and I've noticed many designers don't even know about it. Thanks again!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 15, 2019 Feb 15, 2019

Copy link to clipboard

Copied


This is still happening to me but I DON'T have Missing Glyph Protection enabled! I'm scrolling down to about 'G' before it jumps back to the top. I have the most up-to-date InDesign installed on Mojave 10.14.2

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 18, 2019 Feb 18, 2019

Copy link to clipboard

Copied

I also don't have Missing Glyph Protection enabled, and yet my fonts (and the other designers in my department) are also experiencing the same frustration.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 18, 2019 Feb 18, 2019

Copy link to clipboard

Copied

This is a known (and new) issue with InDesign CC 2019, and it appears to have something to do with the new Adobe Fonts features. According to the relevant bug report on UserVoice, Typekit (or Adobe Fonts) or Fonts menu collapses while browsing through the list of fonts, it is currently ‘under review’. This usually means that a fix is forthcoming, although when remains uncertain.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 01, 2019 Aug 01, 2019

Copy link to clipboard

Copied

How'd you turn off Missing Glyph Protection?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 02, 2019 Aug 02, 2019

Copy link to clipboard

Copied

Missing Glyph Protection is found in Advanced Type preferences. I think it's off by default.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 04, 2019 Aug 04, 2019

Copy link to clipboard

Copied

Thanks so much Steve!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 03, 2023 Sep 03, 2023

Copy link to clipboard

Copied

LATEST

Thank you for doing gods work!!!! I have been suffering with this promblem for years!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines