Indesign importing linked excel table, adding extra columns beyond range

Community Beginner ,
Jul 30, 2018 Jul 30, 2018

Copy link to clipboard

Copied

Hello Adobe world,

I am hoping that you guys can help me out. I am working in an Indesign file, we have some pricing tables for a client that they update the excel pricing sheet, and then we are setting up their sales sheets that get professionally printed with the linked data from excel.

One of the tabs (possible more, but my brain is dead from trying to figure this out) when I go to import the range of data A1:F10, it keeps importing that data, and then there was 4 additional columns of blank cells. It is like Indesign is importing A1:J10, but that is not what I am asking to import from that particular worksheet.

What I have tried so far:

  1. I have completely copied and pasted the content into a newly created tab in excel, along with stripped all formatting for new worksheet, i have also deleted the extra columns in excel just incase any hidden characters where in a random cell.
  2. I have also tried to import using other table styles we have setup, and tried to import using no table style.
  3. I DO NOT have checked/selected the import option "Import hidden Cells Not Saved in View", and there are no hidden columns in this excel worksheet.

I do not know how it is bypassing the range I am selecting, but i am hoping that someone out that has something very simple that I am just over looking. I know that we can delete these columns once we import but we are updating these quite frequently and when we refresh the link, the 4 extra columns come back.

Here is a link to the excel file, Dropbox - Price Sheet07_18.xlsx

Any help would be greatly appreciated!

Views

1.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jul 31, 2018 Jul 31, 2018
The last line (*Include 35PSF- 140MPH ...) has some inline tabs entered in the text. These are being read as additional columns.

Likes

Translate

Translate
Adobe Community Professional ,
Jul 30, 2018 Jul 30, 2018

Copy link to clipboard

Copied

A couple of things to try.

1. Name the range and use the named range

2. Save the file as XLS

If that doesn’t work, please tell us what version of InDesign, what version of Excel and what operating system you’re on.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 31, 2018 Jul 31, 2018

Copy link to clipboard

Copied

I tried both of these options this morning and both still gave me the same results.

I am using the following versions:

InDesign CC 13.1

Excel 16.15 (180709)

MacOS High Sierra 10.13.6

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 31, 2018 Jul 31, 2018

Copy link to clipboard

Copied

Hi,

just imported your xlsx file with all formatting:

For "Leg Height" InDesign sees formatted contents A1:F11. So I get one additional row.

For "Leg Height 2" InDesign sees formatted contents A1:F10. No additional row or column.

InDesign CC 2018.1 on Windows 10 (1803)

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 31, 2018 Jul 31, 2018

Copy link to clipboard

Copied

The last line (*Include 35PSF- 140MPH ...) has some inline tabs entered in the text. These are being read as additional columns.

David Creamer
Adobe Certified Instructor, Adobe Certified Professional, and Adobe Certified Expert (since 1995)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 31, 2018 Jul 31, 2018

Copy link to clipboard

Copied

IDEAS-Training  wrote

…These are being read as additional columns.

Hi,

not with "Leg Height":

PlacedTable-LegHeight.PNG

With "Leg Height 2" this is true:

( Hm. What's the difference here? I used the same import options. )

PlacedTable-LegHeight2.PNG

Note 1: I had to change the width of all columns to avoid overset text.

Note 2: My German InDesign uses , instead of . for the decimals.

I would have to change that. Also the applied language, that automatically is German instead of US English.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 31, 2018 Jul 31, 2018

Copy link to clipboard

Copied

I get the extra columns in both sheets. The only difference is the merge of the last row on the first sheet:

Having text-based tabs in Excel is very strange. Among other things I am noticing in Excel (365, Windows 10), I suspect Excel file corruption. Why we are getting different results is strange...

David Creamer
Adobe Certified Instructor, Adobe Certified Professional, and Adobe Certified Expert (since 1995)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 31, 2018 Jul 31, 2018

Copy link to clipboard

Copied

Hi IDEAS-Training ,

here my import options from my German InDesign CC 2018.1 version 13.1.0.76:

EDIT:

Formatted Table

PlacedTable-LegHeight-ImportOptions.PNG

PlacedTable-LegHeight2-ImportOptions.PNG

You have WordsFlow installed. Maybe that's the difference?

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 31, 2018 Jul 31, 2018

Copy link to clipboard

Copied

Removing WordsFlow made no difference.

David Creamer
Adobe Certified Instructor, Adobe Certified Professional, and Adobe Certified Expert (since 1995)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 31, 2018 Jul 31, 2018

Copy link to clipboard

Copied

I did not notice this, I figured it was something simple. Thanks so much for your help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 28, 2021 Dec 28, 2021

Copy link to clipboard

Copied

LATEST

OMG this was the answer! It's been driving me crazy thank you so much! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines