• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

InDesign unnessarily highlighting text

Explorer ,
Jul 22, 2022 Jul 22, 2022

Copy link to clipboard

Copied

Within my Compostion preferences, I have H&J Violations, Custom Tracking/Kerning, and Substituted Fonts checked.

 

As you can see on the left page, it's highlighting my custom kerning and H&J violations. On the right page, everything is highlighted in green. Now I can't see any of my composition preferences on that page. And it's always random text; there's no rhyme or reason to it. (It doesn't help to turn off my preferences.)

 

For me, this has been a problem in InDesign for years. It doesn't matter if I'm working on a Mac or PC. Is there a solution that I'm missing? It's incredibly frustrating!

 

InDesign-highlighted-text.png

TOPICS
Bug , Performance , Type

Views

3.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Aug 01, 2022 Aug 01, 2022

Hi @mhollopeter ,

looked into your document.

The main reason for marking the text in green is one thing:

 

There are style overrides with tracking

 

So remove all style overrides and you'll get rid of the green marks.

 

The "light yellow" marking will not go away here and there, because that's because of your justification and hyphenation settings. Settings you cannot avoid and I think, you should not avoid at all.

 

With style overrides:

220801-1-BeforeRemovingAllStyleOverrides.PNG

 

Without style overrides:

 

220801-2-AfterRemovingAllStyleOverrides.PNG

 

Of course you can turn i

...

Votes

Translate

Translate
Community Beginner , Dec 06, 2023 Dec 06, 2023

You are a genius! I have searched high and low for a solution on files I get from other people. THIS FIXED IT!! Thank you!!!!!

Votes

Translate

Translate
Adobe Employee ,
Jul 22, 2022 Jul 22, 2022

Copy link to clipboard

Copied

Hi @mhollopeter ,

 

Thanks for reaching out. I found this similar discussion on the community which you can refer to here https://community.adobe.com/t5/indesign-discussions/yellow-highlighted-text-indesign/m-p/10884385#M1... 

Let us know if this helps or if you need any further assistance.

 

Regards

Rishabh

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 22, 2022 Jul 22, 2022

Copy link to clipboard

Copied

Thanks, but that doesn't solve my problem. It's not conditional text, and as I indicated, the left page is working perfectly. All of that highlighted text suddenly appeared; it wasn't there when I imported the text. The highlighting will appear randomly: sometimes just a paragraph or whole swaths of text. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 22, 2022 Jul 22, 2022

Copy link to clipboard

Copied

I believe what is happening to you is that in your paragraph and character styles panels you have the "Style Override Highlighter" chosen as an option. When this feature is enabled any text that has overidden the applied style will be highlighted. To get rid of it select the style in the panel and click on the [a+] icon. To ensure that it is off for the Basic Paragraph style for all new documents do this with no documents open and then quit the program. When you relaunch InDesign it will become the default for all new documents. By the way you can tell if this feature is active when you see a dark tint around the icon in the style panels.

Screen Shot 2022-07-22 at 8.48.32 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 25, 2022 Jul 25, 2022

Copy link to clipboard

Copied

Thank you very much for the reply, but that's not it either. (Although I was unaware of the "Style Override Highlighter" these many years!) I'm attaching another spread that shows random paragraphs highlighted in green. A line of text has been tracked, but then the whole paragraph is highlighted in green. And as I mentioned before, sometimes whole swaths of text are highlighted in green even though there has been no manipulation of the text. Very strange.highlighted-text.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 06, 2023 Dec 06, 2023

Copy link to clipboard

Copied

LATEST

You are a genius! I have searched high and low for a solution on files I get from other people. THIS FIXED IT!! Thank you!!!!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Jul 25, 2022 Jul 25, 2022

Copy link to clipboard

Copied

Is indd -> idml -> indd conversion not helps to resolve a problem?

 

Remember, never say you can't do something in InDesign, it's always just a question of finding the right workaround to get the job done. © David Blatner

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 27, 2022 Jul 27, 2022

Copy link to clipboard

Copied

Probably. But I shouldn't need a workaround, right?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Jul 28, 2022 Jul 28, 2022

Copy link to clipboard

Copied

Are you do and what? Don't re-ask it, do it!

 

Remember, never say you can't do something in InDesign, it's always just a question of finding the right workaround to get the job done. © David Blatner

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 26, 2022 Jul 26, 2022

Copy link to clipboard

Copied

@mhollopeter , check your preferences!

 

There are some options you can turn on/off in:

Preferences > Composition > Highlight

E.g. Custom Tracking/Kerning and Substituted Glyphs.

 

NOTE: All options in Composition are document preferences and can vary from document to document.

 

Regards,
Uwe Laubender
( Adobe Community Professional )

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 27, 2022 Jul 27, 2022

Copy link to clipboard

Copied

Yeah, I'm aware of that, but I want to see H&J violations and Custom Tracking/Kerning. My issue is that InDesign is highlighting text that doesn't meet these criteria.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 27, 2022 Jul 27, 2022

Copy link to clipboard

Copied

@mhollopeter said: "but I want to see H&J violations and Custom Tracking/Kerning. My issue is that InDesign is highlighting text that doesn't meet these criteria."

 

Ok. Now that's your issue.

Could you provide a sample document?

One page would be sufficient to see into the case.

 

Thanks,
Uwe Laubender
( Adobe Community Professional )

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 01, 2022 Aug 01, 2022

Copy link to clipboard

Copied

OPRE.PNG

I've attached the page indicated. In paragraphs 26 and 29, one line of text has been tracked to fix a loose line. While only that line should appear highlighted in green, the whole paragraph is highlighted in green. And as I've said before, sometimes whole paragraphs or random lines of text will be highlighted in green, even though the text has not been manipulated.

 

Unfortunately, this site is not allowing me to attach the Goudy font, so that might affect your results.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 01, 2022 Aug 01, 2022

Copy link to clipboard

Copied

Did you use for the wanted highlighting character styles. If not, do thT. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 01, 2022 Aug 01, 2022

Copy link to clipboard

Copied

Hi @mhollopeter ,

looked into your document.

The main reason for marking the text in green is one thing:

 

There are style overrides with tracking

 

So remove all style overrides and you'll get rid of the green marks.

 

The "light yellow" marking will not go away here and there, because that's because of your justification and hyphenation settings. Settings you cannot avoid and I think, you should not avoid at all.

 

With style overrides:

220801-1-BeforeRemovingAllStyleOverrides.PNG

 

Without style overrides:

 

220801-2-AfterRemovingAllStyleOverrides.PNG

 

Of course you can turn it off in the Preferences under tab Composition.

H&J Violations for the yellow highlighting.

Custom Tracking/Kerning for the green highlighting.

 

Regards,
Uwe Laubender
( Adobe Community Professional )

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 01, 2022 Aug 01, 2022

Copy link to clipboard

Copied

Apparently I am not making myself clear. I'm completely aware of the style overrides, etc. My problem is that text that doesn't have a style override is being highlighted in green. This makes it difficult to see other loose lines that might need fixing in the paragraph--especially if it's highlighting random text in paragraphs

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 01, 2022 Aug 01, 2022

Copy link to clipboard

Copied

Hi @mhollopeter ,

ok, we have a couple of lines where the green highlighting should be done:

 

Under 26 it is the 1st and 5th line.

Under 28 it is the 4th line, or at least parts of it.

29 should be free of green highlighting.

 

At least according to the tracking value which is 0 in the applied paragraph styles. And also with the actual text on the page.

 

What I wonder is, if we have an issue with kerning here and there. The paragraph styles use Optical Kerning.

Hm. I also found paragraph overrides in the applied paragraph composer. Adobe Single Line Composer vs Adobe Composer. This could also be an issue, but I'm not sure…

 

Regards,
Uwe Laubender
( Adobe Community Professional )

 

 

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines