• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Index is listing the index entry

Explorer ,
Sep 17, 2023 Sep 17, 2023

Copy link to clipboard

Copied

I have a 30-chapter book and am creating the index. For example: "Chesapeake Bay" is indexed on pages 3, 24, 55 and 34. This is the result of clicking "Add All" in the New Page Reference dialog, which is what I want. But "Chesapeake Bay" is also appearing on page 2 of the index, which is causing the entry to look like this:

 

Chesapeake Bay, 3, 24, 55, 34, 2

 

How do I stop ID from indexing the index?  I can't take the "Index" file out of the book or it won't search for all book document entries. Thank you.

TOPICS
How to

Views

218

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Guide , Sep 17, 2023 Sep 17, 2023

In the "Index" Panel, click on "Chesapeake Bay" and develop to show us the page numbers! …

 

Anyway regenerate a second time the Index will fix your problem!

 

(^/)  The Jedi

Votes

Translate

Translate
Community Expert , Sep 17, 2023 Sep 17, 2023

The mistake was using "add all" with the index present. Delete it, or remove it to side storage, and regenerate the index.

 

(True story: I once created an index entry pointing only to that index entry, just because I knew the person would instantly look up their own name.)

Votes

Translate

Translate
Community Expert ,
Sep 17, 2023 Sep 17, 2023

Copy link to clipboard

Copied

Are you sure you don't have any hidden / overset texts on the page were you are creating index? 

 

▒► ID-Tasker / ID-Tasker Server - work smart not hard ◄▒

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Sep 17, 2023 Sep 17, 2023

Copy link to clipboard

Copied

In the "Index" Panel, click on "Chesapeake Bay" and develop to show us the page numbers! …

 

Anyway regenerate a second time the Index will fix your problem!

 

(^/)  The Jedi

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 17, 2023 Sep 17, 2023

Copy link to clipboard

Copied

The mistake was using "add all" with the index present. Delete it, or remove it to side storage, and regenerate the index.

 

(True story: I once created an index entry pointing only to that index entry, just because I knew the person would instantly look up their own name.)


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Sep 18, 2023 Sep 18, 2023

Copy link to clipboard

Copied

LATEST

By default:

 

Capture d’écran 2023-09-18 à 13.49.31.png

 

So no need to remove the Index contents before regenerating it!

 

(^/)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 17, 2023 Sep 17, 2023

Copy link to clipboard

Copied

Hi @leannz30751615:

 

When you Add(ed) All, you added an index marker (a caret ^) in front of each occurence of the two words, including in front of the entry in the actual index. (With Type > Show Hidden Characters enabled, you can see the ^ symbol in front of each occurence.)

 

As per @FRIdNGE, updating the index will regenerate the index content, and it will remove the index marker. It won't come back unless you use Add All again. 

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 17, 2023 Sep 17, 2023

Copy link to clipboard

Copied

InDesign isn't going to index anything that doesn't have an Index Entry Marker.

 

You may have copy/pasted a "Chesapeake Bay" and inadvertently picked up the index marker to go with it. You can check your entry in the index through this process:

 

  • Navigate your way to page 2 of your index, where "Chesapeake Bay" appears on your page. (For the purpose of this response, I'm going to change the indexed item to "abatement" for my illustrations).
  • Get your Text tool and click into the text near your "Chesapeake Bay" entry. Then, go to your Type pull-down menu and select the Show Hidden Characters menu command.
  • This will show you the non-printing characters entered into your document — like tabs, paragraph returns, spaces and indents, etc. Including index entries, which would show up as carat characters below the text as shown in the instances of "abatement" and "cancels" in the illustration below. If you look very closely, you'll sldo see two blue dots like a colon right at the start of each word. That's the non-printing indication of an index entry marker in your text.

 

1-index in text.jpg

 

  • Technically you can edit it from here but it's very difficult. It's much easier if you use InDesign's Story Editor function. Go to the Edit>Edit in Story Editor menu command to see the index entry marker as a ancient thunderbird in a box, as shown below. It's also easy to highlight it in the Story Editor and delete it there than it is in your page layout.

 

1a-index in story editor.jpg

 

 

  •  You can also go to your Index panel and find the index entry for page 2 of your index. While you can't exactly see where the index entry is in your text, you select the index entry in the panel and then trash it, as shown in the illustration below:

 

1b index panel.jpg

 

Once you hunt down and eliminate the errant index entry for "Chesapeake Bay", it should cease to haunting you forevermore.

 

Hope this helps,

 

Randy

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines