IO error creating ExternalObject('lib:AdobeXMPScript')

Community Beginner ,
Apr 25, 2022 Apr 25, 2022

Copy link to clipboard

Copied

Adobe InDesign CC 2022, v 17.2.0.20

IO error creating new object

if (ExternalObject.AdobeXMPScript == undefined)
ExternalObject.AdobeXMPScript = new ExternalObject('lib:AdobeXMPScript');
alert (ExternalObject.AdobeXMPScript);

 

Similar to what happen with CC 2021 update a couple of years ago.

 

Any way around this?

TOPICS
Bug , Scripting

Views

134

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 25, 2022 Apr 25, 2022

Copy link to clipboard

Copied

Your code works for me in Indesign CC 2022 v17.2.1 MacOS 12.3.1.

What platform are you on? Hopefully someone will be able to reproduce.

- Mark

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 25, 2022 Apr 25, 2022

Copy link to clipboard

Copied

Thanks for testing.


Windows 10


Regressed to v 17.0, then v 17.1.0.50 and no issue


v 17.2.0.20 - last revision for Windows - and I/O error returned.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 26, 2022 Apr 26, 2022

Copy link to clipboard

Copied

Hi Jim,

tested your code with InDesign 17.1.0.50 on Windows 10.

This works. Also unloading with:

ExternalObject.AdobeXMPScript.unload();
ExternalObject.AdobeXMPScript = undefined;

 

Now I tested with the latest prerelease version 17.3.0.48.

That did NOT work:

 

ERROR: 52, I/O error
Unable to load the AdobeXMPScript library!

 

I will do a bug report at Prerelease for this particular version.

Code for this test:

 

loadXMPLibrary()

function loadXMPLibrary()
{  
	if ( !ExternalObject.AdobeXMPScript )
	{  
		try
		{
			ExternalObject.AdobeXMPScript = 
			new ExternalObject( "lib:AdobeXMPScript" );
		}
		catch(e)
		{
			$.writeln
			( 
				"ERROR: " + e.number +", "+ e.message +"\r"+
				"Unable to load the AdobeXMPScript library!" 
			); 
			return false;
		};
	};
	return true;  
};

 

 

17.2.0.20 is not installed on my Windows 10 machine..

Still waiting for 17.2.1 that currently is not available for Germany, but hopefully will arrive in a few days.

 

You should do a bug report for 17.2.0.20 at InDesign UserVoice:

https://indesign.uservoice.com/forums/601180-adobe-indesign-bugs

 

When done, please come back and post a link to your bug report.

 

Thanks,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 26, 2022 Apr 26, 2022

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 28, 2022 Apr 28, 2022

Copy link to clipboard

Copied

LATEST

Now I had a chance to test the code on Windows 10 with

InDesign 17.2.0 and 17.2.1.105.

Both fail.

 

ERROR: 52, I/O error
Unable to load the AdobeXMPScript library!

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines