Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Italics spotty from imported Word documents

New Here ,
Feb 04, 2021 Feb 04, 2021

Copy link to clipboard

Copied

Hi Everyone,

 

I have a bit of a problem with imported Word files. This issue is new-ish to me, I never had it before a couple of month ago.

 

Some italicised text in the Word document (italicised with the "I" button) doesn't make it through after being imported into InDesign (import dialogue set to preserve incoming local overrides), the other instances are imported just fine.

 

I have tried troubleshooting this issue using different ID versions (from CC 2018 to CC 2021), fonts, paragraph language but none of these helped.

 

I attach a jpg which highlights the spotty behaviour (Word document in foreground, ID document with the newly imported document in the background) and a test Word document.

 

Do you have any suggestions? Any idea is VERY much appreciated, thanks!

TOPICS
Import and export

Views

398

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Feb 05, 2021 Feb 05, 2021
Try to save your word file as rtf and then place it in InDesign

Likes

Translate

Translate
Adobe Community Professional ,
Feb 04, 2021 Feb 04, 2021

Copy link to clipboard

Copied

Are you able to share the Word document by any chance? Are you able to determine if there's a difference in formatting within Word between the elements that are and are not working?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

Thanks for this!

 

Please, find a sample word document attached to the first post.

 

Great question! The text seems to be evenly italicised using the "I" button. So I would said the italics is being applied consistently? Is there something else I should pay attention to?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 04, 2021 Feb 04, 2021

Copy link to clipboard

Copied

It comes in just fine for me, using the default settings, meaning that Import options isn't checked in Place dialog box.

 

~Barb 

ital.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

Thanks for this, Barb!

 

Unfortunately, I can see that you also have issues with the with the 'é' and 'été' occurences in the footnote.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

Try to save your word file as rtf and then place it in InDesign

Schermata 2021-02-05 alle 17.28.23.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

Ah. I see the issue. The accented characters in the footnote are using Palatino Linotype in Word, but mapping to Arial Italic and Regular when placed in InDesign. 

 

You can address this either in Word or in InDesign.

  • To fix it prior to import, just create a character style in Word— perhaps call it Italics—and assign it to the italics text prior to import. Create a character style in InDesign with the same name. Then use InDesign's style mapping to map the Word character style to the InDesign character style. (Screen shots below.)
  • If you want to handle this in InDesign, you will need to Find/Change the italics to an italics character style, use Tyep Find/Replace Font to find Arial regular and Arial italic and change it to your desired font and then clear overrides. 

 

~Barb 

 

over1.png

 

over2.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

😂 

@vladan saveljic that is a much faster solution! Marking it as correct, as it worked with the test file.

 

~Barb 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

Yes, that is a great solution for random italic losses but now the footnotes are lost when I import the rtf file into InDesign. Why is that happening?

 

Easty

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

you should check if the best result you get by placing doc, docx or rtf format for your file

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

..."Why is that happening?"

 

that's happening because word and indesign are totally different softwares and not compatible with each other at 100%.

sometimes the "place" option can give very good results and sometimes not

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 29, 2021 May 29, 2021

Copy link to clipboard

Copied

Soooo.. I tried a couple of things:

Other than the .rtf route, which works, I tried a couple of other things:

1. I saved the document backwards to an old-school .doc file, and it imported just fine.

2. I modified your Style for the footnotes in the original Word file to a different font (ANY font other than Palatino Linotype), and saved that as a .docx... THAT imported fine.

 

So, something doesn't like that Palatino Linotype

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
May 30, 2021 May 30, 2021

Copy link to clipboard

Copied

LATEST

From my experience, I have to admit that .rtf is the safest solution.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 29, 2021 May 29, 2021

Copy link to clipboard

Copied

  1. Did you work in Word with paragraph Styles and Character Styles? Both should be applied. Avoid manual formatting.
  2. Check if your used font has these characters defined. Some fonts are incomplete. Look into InDesign’s Glyph Panel. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines