• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Lost formatting when copying and pasting from one indesign file to another.

New Here ,
Jun 23, 2017 Jun 23, 2017

Copy link to clipboard

Copied

We have an inDesign master file for a magazine that we place everything in once it has been approved for printing, but each individual article/ad/feature has its own file.  We make all edits in the individual files until it is approved and the information is ready to be placed in the master.  We have done things this way for at least 15 years and never had a problem until this week. When we copy the pages from the original file and paste in place in the master file, the format completely changes. The size of the images change, the font sizes change and the rules applied for no hyphenation change, among other things.  I have checked the document presets on all files and they are the same, the font books on the computers are the same and the fonts have been installed in the applications and not just in the document.  I tried searching for an answer and have not been successful at finding a solution.  Any suggestions would be greatly appreciated.

Views

6.8K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 24, 2017 Jun 24, 2017

Copy link to clipboard

Copied

A mystery! Hmm.

What happens if you copy/paste in place to a New document? Do the same changes happen?

If not, then something went glitchy w/your template. If you've been using it for 15 years it may be time for a tune-up. 😉  Do an IDML round trip with your template to get rid of any corruption. (export to IDML, open the IDML in the same ver of the app, save the resulting Untitled as a new file, and use that one from now on.

Or, use a backup?

AM

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jun 24, 2017 Jun 24, 2017

Copy link to clipboard

Copied

Try resetting your preferences.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 27, 2017 Jun 27, 2017

Copy link to clipboard

Copied

It could be a styles issue.

Is there any chance the paragraph, character or object styles in your master document have been changed since the last edition?

I'd start by opening a previous edition that you didn't have problems with, and compare the object styles from each; every one of these options ought to be the same in both your versions:

Screen Shot 2017-06-27 at 08.42.34.png

If your pictures are changing size when you bring them in, the only thing I can think of that might have that effect is different settings on [Basic Graphics Frame] or another object style you use a lot.

Also look at [Basic Paragraph] style in working/non-working documents and compare. Differences between the two could lead to some of the problems you describe.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

I had the same problem. It's to do with your style names. If two InDesign docs have the same style name when you paste it into the main doc, then it'll go a bit nuts. So before you copy and paste in between separate InDesign docs, give your styles a unique name for that page before pasting into the main doc. It's a pain in the arse, but it works.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 02, 2021 Feb 02, 2021

Copy link to clipboard

Copied

I had this problem and it was Paragraph Styles. All my text was Basic Paragraph Style, which I thought meant no style.

Select the text, open the Paragraph Styles window, click on the three horizontal stacked lines in upper right corner, and then click "Break Link to Style." This removes the paragraph style but retains formatting of text. The text can now be copied/pasted into a new document and fonts will be retained since there is no paragraph style.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 02, 2021 Feb 02, 2021

Copy link to clipboard

Copied

It's usually a Styles problem. Even if the Style you are using on the copy is unique to the document it was created in, if it is based on another Style, you need to go back to the underlying Style and make sure it itself is not based on an underlying Style..., etc etc. If any of those Styles (going back to the Basic Paragraph Style or whatever its starting point) are in the document you are pasting into, that document's Style definitions of the underlying Styles will affect what you're pasting. A few things you could do: 1) as mentioned, change your Style names before you copy and paste. 2) delete the "based on" reference in your Styles (this is a pandora's box right there), 3) If the Styles in your destination document should be the same as the source document, Import them from your Source document before you paste, but my guess you don't want to delete the existing Styles if they are in use in the destination.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 18, 2023 Nov 18, 2023

Copy link to clipboard

Copied

I can prove 100% that it's not a style issue... Exhibit A I have been using the same process for years now - I create graphics in one indesign document that has templates that I've created to brand their tables and figures and so on... and then once it's time to layout the report for my client, I simply paste the graphics into the layout with the text... well I updated to 2024 and then proceeeded to open my files and used the same process and it changed the text formatting, lost all of my wordwrap formatting and went nuts... It will also no longer allow me to open the templates document in 2022, the version I used earlier this year to create their last report and fro which I used this process with no issues. So after checking everything I knew to, I went and opened up the old report in 2022, opened up the templates document in 2023, copied the graphic that went nuts in the 2023 and 2024 version of indesign and the graphic pasted into the document with no formatting issues whatsoever. SO the issue has nothing to do with the styles or anything else and everything to do with the 2 most recent updates... 


The graphic in 2023 indesign pre copy/paste:

aprils75099586_0-1700368540258.png

 

The graphic copied from one indesign 2023 document into another 2023 document (the wordwrap and font formatitng was lost/changed):

aprils75099586_1-1700368617943.png

 

That same exact graphic copied from an indesign 2023 document, into the same exact document I was trying to paste into before but now opened instead in indesign 2022:

 

aprils75099586_2-1700368770573.png

No formatting problems whatsoever!! So this is NOT a style issue, it's an update buggy indesign issue... and I did copy preference from one to the other upon update, so that also has nothing to do with it either.

 

This is just the developers and markting team investing in adding dumb new features that no actual working professional cares about over just making the program stable and the basic features work well. Why even continuously update, it seems like everytime they work out all of the bugs or I have time to invest work-arounds for all of the bugs, they come out with some horrible new version that I have to wrestle with while trying to work and meet my deadlines. It's so rediculous! 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 18, 2023 Nov 18, 2023

Copy link to clipboard

Copied

And yes, I know this is from 2021, but these kind of issues happen everytime they do large updates to new versions and try to subnet working versions. They work out al of the bugs, have something that's finally stable and then they come out with something totally new that doesn't work well at all. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 18, 2023 Nov 18, 2023

Copy link to clipboard

Copied

LATEST

Sunset*

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines