Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Making Individual Words Italic in Index

Community Beginner ,
Feb 03, 2017 Feb 03, 2017

Copy link to clipboard

Copied

I have a huge index that has italic words through out it. 

The problem is that the italics doesn't carry through into the markers.

I have tried setting up a GREP but can't get it to recognize the italics.

Here's a sample of what I need in italics:

academic supervisor

attitude is </i>strong interest</i> in student progress, 153

definition, 16

description of functions and duties, 153

As you can see I have put <i> and </i> before and after the word, and the "hidden" character style makes these symbols small again but somehow the italics doesn't find its way to the words.

Any ideas, successful tips?

Thank you!

Views

1.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Feb 03, 2017 Feb 03, 2017
(^/)

Likes

Translate

Translate
LEGEND ,
Feb 03, 2017 Feb 03, 2017

Copy link to clipboard

Copied

Capture d’écran 2017-02-03 à 21.45.27.png

(^/)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 03, 2017 Feb 03, 2017

Copy link to clipboard

Copied

</i>strong interest</i> looks strange, <i>strong interest</i> would be the expected format.

Then you need to set up a GREP style in the index paragraph styles that applies an Italics character style to

<i>.+?</i>

Peter

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 03, 2017 Feb 03, 2017

Copy link to clipboard

Copied

Hi Peter,

Oups! Error from me!

Capture d’écran 2017-02-03 à 21.53.20.png

(^/)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 03, 2017 Feb 03, 2017

Copy link to clipboard

Copied

Dear Peter,

Thank you so much for your assistance.

I believe that I have it set up correctly.

But I can't seem to get it to work:

Do you possibly see what I have wrong?  I keep looking for the error but can't find it.

Thank you for your help!

Irene

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 04, 2017 Feb 04, 2017

Copy link to clipboard

Copied

Both variants (by pkahrel and Obi-wan Kenobi​) working well.

irenes96057146 Are you sure, that your italic character style is defined correctly?

Or can you upload an IDML file (only with one textfield and your character and paragraph styles)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 04, 2017 Feb 04, 2017

Copy link to clipboard

Copied

All looks set up correctly, Irene. As pixxxel suggested, check that italics is enabled in the italic character style.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 04, 2017 Feb 04, 2017

Copy link to clipboard

Copied

Just for comment:

Once, a guy posted a similar question about "superscript"! …

All seemed correct! Really! … As here!

Capture d’écran 2017-02-04 à 13.39.03.png

His problem came from the fact he copied the grep code from somewhere … with the hard-return behind, not visible!

(^/) 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 13, 2017 Feb 13, 2017

Copy link to clipboard

Copied

Thank you all for your help! I got it to work, so I am very happy right now!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 14, 2021 Aug 14, 2021

Copy link to clipboard

Copied

LATEST

Still not working for me. Help please.

Ginger

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines