• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Microsoft fonts into InDesign or Illustrator?

Community Beginner ,
Mar 29, 2022 Mar 29, 2022

Copy link to clipboard

Copied

How do I get Microsoft fonts (specifically Khmer UI, Khmer Sangam MN) to load and be useable in InDesign and Illustrator? I see and use them in Microsoft but they are not working well in InDesign. Some characters are missing. I am on a Mac not a PC, btw. Thank you!

 

TOPICS
How to , Print , Type

Views

2.1K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 29, 2022 Mar 29, 2022

Copy link to clipboard

Copied

Some characters are missing? I don't think that this sounds like a case where the font is not showing up in InDesign, right? I suspect that you're working in Cambodian and haven't turned on the World-Ready Composer. If the font shows up in the list, it's installed. If it's not rendering your Khmer text as you'd expect, it's probably because you're not using the correct Composer:

JoelCherney_0-1648601546221.png

This can be set  in a bunch of places (in Paragraph Styles, in Type -> Apply World-Ready Composer, the Justification dialog I've shown here, etc.). That's where I'd start. If this isn't the issue, can you please provide some more detail?

 

Also, please note that Khmer Sangam MN is not a Microsoft font, but part of OS X's infrastructure for displaying Khmer. I think it's an AAT font (Advanced Apple Typography) and I have no idea how well it works in InDesign, or if you'll be able to get it to work at all. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 29, 2022 Mar 29, 2022

Copy link to clipboard

Copied

Missing font has nothing to do with the composer.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 28, 2024 Feb 28, 2024

Copy link to clipboard

Copied

While it's true that missing fonts have nothing to do with the composer being used, this question isn't about missing fonts, but missing characters. If you don't know how Khmer type is composed, it's really easy to see an uncomposed vowel sign with its little empty dotted-line circle and think that there is a missing character, when no character is missing:

 

willistillwrong.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 29, 2024 Feb 29, 2024

Copy link to clipboard

Copied

Thank you Joel. Is this something I would do when I encounter a missing character- use the glyphs pallette? I wouldn't know which glyph to use...

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 29, 2024 Feb 29, 2024

Copy link to clipboard

Copied

No, I only included that screenshot to show what that particular composition failure looked like. See, when you see that dotted-line circle, you're not actually seeing a missing character. You're seeing a glyph that, when properly typed and properly composed, will combine with the glyphs next to it to render correctly. Kinda like this:

 

NOCOENG.png

 

So, that's not a "missing character" at all. A missing character would be what it looks like when you have set text in a font that doesn't posess a particular glyph. Turns out that Trajan Color doesn't have any accented glyphs at all, nor does it have a solidus! You can see that I have the missing-glyph pink highlighting turned on:

 

whisky.png

I've gone further and made a preflight profile that shows me every dropped glyph:

glyph.png

So, I'd say that the thing to do when you encounter a missing glyph is to think about the font you're using. If it doesn't have all the necessary characters, shouldn't you change it? Some people are okay with substituting only the missing glyphs. That can go okay sometimes; e.g. using weird glyphs from Times New Roman when working in Minon in less-frequently-encounterd languages that Minion doesn't cover. But I don't trust it. I especially don't trust the silent auto-substitution of glyphs that happens when you turn on Missing Glyph Protection in Preferences -> Advanced Type:yeah no.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 01, 2024 Mar 01, 2024

Copy link to clipboard

Copied

So, I totally get the glyph protection auto substitute issue. That makes sense! What I would struggle with is which glyph to use? So far, for Khmer, the available glyphs are accents (diacritical marks) over the previous character. It will combine the accent and character and it looks good. Is it enough to click on the glyph for each missing character? Sometimes I work with a few paragraphs which can get messy.  

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 01, 2024 Mar 01, 2024

Copy link to clipboard

Copied

I must not be understanding your question, then. You don't do any manual insertions with the Glyph menu. Unless you are the Khmer editor and you say "Oh yeah, translator used the wrong tone mark here, how do I fix it in InDesign?" I don't think that is what you are asking; please do correct me if I'm wrong. 

 

Assuming the text is correct from your Khmer translation provider, then the thing you have to do to make sure that it renders correctly is to use the correct formatting and the correct composer, and to know InDesign's limitations. At no point should you personally need to use the Glyphs menu to fix composition. Here's exactly what I would do if I were in your position:

 

1) I'd use File -> Place to insert Word files with my Khmer paragraphs into InDesign. (Again, copy/paste should probably work, but I don't trust the clipboard.)

 

2) I'd apply Paragraph Styles with Khmer MN font applied, Khmer language applied, the WRC turned on, and the amount of default leading increased:

khmer.png

3) I'd finish formatting my document, then I'd make a quick PDF and I'd probably send it back to my Khmer translator, because I know that InDesign can't be trusted to get the line breaks correct in Khmer.

 

As an aside for other future readers of this thread, having problems with Khmer layout in InDesign... I do have some clients with Khmer translators who know how to use zero-width spaces correctly, and so I don't have to necessarily run those through post-DTP linguistic QA for line-break purposes. But other translators are less willing to work in this way (I mean, how many times in one's life can one be told "Forces external to your culture are changing the way you type your language! Get ready to re-learn how to touch-type with a new keyboard layout! Again!"), and I just assume that translator review is Always Advisable.  

 

 

 

 

  

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Mar 29, 2022 Mar 29, 2022

Copy link to clipboard

Copied

Just to add to Joel's comments, are the fonts showing up in InDesign's font menu? If so, it's likely the composer. Also, I recommend taking a look at Google's Noto fonts. They are free and have an enormous range of language/glyph coverage. We use them often. https://fonts.google.com/noto

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 29, 2022 Mar 29, 2022

Copy link to clipboard

Copied

Microsoft saves its fonts in their application. 

On the Mac you do following, to get MS fonts:

  1. Right Mouse click on the Application Icon (MS Word or PowerPoint)
  2. Show Package Content
  3. Go to Ressources
  4. There you will find the DFonts directory.
  5. Copy all fonts from there to the Font folder, where InDesign will find those fonts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 20, 2024 Feb 20, 2024

Copy link to clipboard

Copied

Brilliant, thank you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 27, 2024 Feb 27, 2024

Copy link to clipboard

Copied

Hi Willi,  I am on a mac with a simple mouse that doesn't right-click. I tried option+click, command+click and control+click but nothing allowed me to access the fonts package. Do you have a suggestion?  Thank you!!

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 27, 2024 Feb 27, 2024

Copy link to clipboard

Copied

Hi Willi,  I am on a mac with a simple mouse that doesn't right-click. I tried option+click, command+click and control+click but nothing allowed me to access the fonts package. Do you have a suggestion?  Thank you!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 27, 2024 Feb 27, 2024

Copy link to clipboard

Copied

When you hold 2 fingers on the track pad on the mac or ctrl-mouse the context menu will show up.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 28, 2024 Feb 28, 2024

Copy link to clipboard

Copied

Hi Willi,
Well, I am not having luck with this. I am control+clicking on the file icon and on the application icon to find a menu that doesn't relate to font usage or a package. See screenshot 1 and 2. I don't have right-click capabilities on my apple mouse. 

To reiterate my issue- I don't think I explained it very well (!): I receive Word files from a translation company. In this case, Khmer. The font used in the Word file is Calibri. When I copy and paste the Khmer copy into InDesign, the font becomes not available (pink boxes). I then look through all of the fonts (including the vast Noto varieties) and the few that work are Khmer (makes sense) but some characters are missing. This process is shown in screenshot 3. If I could use the fonts that seem to be working in Word, I think it would solve this. I don't really understand why Calibri would show Khmer only in Word but not InDesign. When I type something in Calibri Word, copy and paste that into InDesign, it works well because it is in english. Any advice is much appreciated!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 28, 2024 Feb 28, 2024

Copy link to clipboard

Copied

There's a lot going on, here; maybe I can help sort it out. 

 

1) Calibri doesn't have any Khmer characters in it at all; that's Word misreporting the font being used. However, I'm sure we can figure out what kind of font will support your Khmer characters in Word. Courtesy of Apple forcing you to have All The Multilingual Fonts installed All The Time, you have some known working Khmer fonts already installed. 

 

2) If you really did need to extract a Microsoft Word font from the app, Willi's instructions would have been accurate. You'd need to context-click not on your Word document, but your Word app:

1_DE_uninstall-microsoft-office-mac (1)_1642015535.png

But you don't need to get your Calibri font out of your MS Word app; that won't help you with your Khmer layout. 

 

3) Copying and pasting your Khmer text into InDesign is more risky than using File -> Place and then placing the whole Word doc. That probably doesn't matter here, but it's worth pointing out, on the offhand chance the next step doesn't work.

 

4) Way back in 2022, I posted that, if it looks to you like some characters are missing (not a missing font, but some characters), then you likely don't have the World-Ready Composer turned on. In order for your Khmer text to render correctly, you must turn the WRC on. There are a few ways to do that - you can turn it on in your paragraph style, for example. You can find it in the little flyout menu (I hate the phrase "hamburger icon") in your Paragraphs panel.  In the following example animation, I'm using Control-Alt-Shift-J on Windows; on a Mac, you'd use Option+Command+Shift+J. 

 

williwrong.gif

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 28, 2024 Feb 28, 2024

Copy link to clipboard

Copied

Oh-oh-oh......... that works!!!!  I guess it is another step in the process but it definately works now. Wow, thank you Joel!!!!!  Really appreciate the video and the help!!!!!!!!   I am back to being a happy camper!!  : )

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 14, 2024 Feb 14, 2024

Copy link to clipboard

Copied

One way I've done it for individual words is to write the word(s) in MS Word. Save the document as a PDF. Open the document in Acrobat Pro. Under Tools select Export a PDF then Other Format as an option. EPS is one of the options. Save the file as an EPS then place into Illustrator. Granted, this is only suitable for one or two words, but it works.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 28, 2024 Feb 28, 2024

Copy link to clipboard

Copied

Wow, this one is a blast from the past! More than twenty years ago, I would sometimes turn my Khmer translator's PDFs into outlined EPS files using this workflow. It was essentially the only way to repurpose that text - as they would not deliver live text at all, fearing that I would damage it in the typesetting process. (It took some time to earn their trust. Also, InDesign didn't really have good complex script support, back in the CS2 era.) 

 

However, I can't reccomend that anyone use this workflow at all in 2024, for any reason. Yes, it totally works for a few words, if you're trying to cram an unsupported script into InDesign.  But if you can key Khmer text into Word, you can do it in InDesign as well; there's no need to saddle yourself with this 20th-century workflow. Very resourceful of you, though, to come up with it. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 01, 2024 Mar 01, 2024

Copy link to clipboard

Copied

LATEST

Dn't use EPS in modern times! Use PDF/X-4 instead. EPS is dead and causes only problems in modern versions.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines