Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Missing File Icon for InDesign 2021 after installing new version

Explorer ,
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

I recently installed InDesign 2021, and after trying it out, unsitalled InDesign 2019 which I had been using. After this, the file association was broken and it did not recognise existing InDesign files. I fixed the associate, and now it works, but it is not showing the correct icon for InDesign files. Instead it shows a generic white box.

 

I'd like to get the correct icon back. This is more than just an aesthetic thing because I make tutorials and the missing icon is a problem.

TOPICS
Bug, How to

Views

282

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

Yeah, the edit feature on this website is broken so I can't fix the typos.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

If you're on Windows, right click the InDesign.exe icon and choose properties.

2021-02-18_10-10-37.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

Thanks, but this is not the issue. The application / shortcut icon is fine. It's is the file icons that are lost, as you can see in this screenshot detail. These are files I'm working with at the moment:

explorer_zuD8yA4K9g.png

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

So I have tried:

  • Uninstalling all versions of InDesign, and using CCleaner to remove any leftovers
  • Reinstalling the latest version on InDesign, and restarting the PC.
  • Rebuilding the icon cache
  • Manually fixing the file associations in the registry

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 19, 2021 Feb 19, 2021

Copy link to clipboard

Copied

After wasting a large amount of time searching the Internet and trying different things, I found more registry entries that didn't look right. I was able to find this out only be examing the registry of another computer where the software was installed. I'd gladly share the registry keys but Adobe is blocking me from doing that, so the best I can do is show this image:

notepad_bYqijwfDmk.png

Since the icon file is a dll, containing several icons, then the IconIndex binary value must be set to the correct index hexadecimal value, which seems to be ffffff7b. I don't know if this is correct but it had the desired effect and my icons now look correct:

explorer_tTDgooKK2b.png

It was quite a simple fix once I knew what to do. The problem was that there were no instuctions anywhere. I can only wonder how such a simple error could baffle the Adobe installer!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 24, 2021 Nov 24, 2021

Copy link to clipboard

Copied

Hey Jason

Have the exact same issue after latest version update of InDesign. Only thing that's worked is uninstalling and going back to an older version of InDesign which seems too drastic for an esthetical thing. It's driving me nuts though. 
I can get to Windows Registry Editor Version 5.00, but when locating the folders your screenshot mentions, everything is set to 'standard'. Nothing seems to be editable. Can't see a hex value to change.

Any advice would be appreciated. Sorry for the inconvenience. 

peterj26509413_0-1637755764282.png

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 24, 2021 Nov 24, 2021

Copy link to clipboard

Copied

I performed an "open with" and the icons returned to normal.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 24, 2021 Nov 24, 2021

Copy link to clipboard

Copied

Yeah, I tried that to a bunch of times, doesn't work here I'm affraid. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 02, 2021 Dec 02, 2021

Copy link to clipboard

Copied

Hi @peterj26509413,

 

Sorry about the trouble.  I would suggest you to try the following steps and let us know how it goes:

  • Press Window/ Start Button + R
  • Type - regedit > press enter
  • Go to the following location: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
    Explorer\FileExts\
  • Locate .idml & .indd > OpenWithList
  • Make sure Name "b" & Data "InDesign.exe" values are correctly inserted in both the file extension registry settings.
  • Restart Windows

Anshul_Saini_0-1638465552786.png

 

 

I hope it helps!

 

Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
33m ago 33m ago

Copy link to clipboard

Copied

LATEST

Hi Ansul

This is a bit weird - it's working now, but here's the steps I went through:

- The settings were in both cases set to "ab" rather than "InDesign.exe", so I changed this accordingly and restarted. 

- After this it still didn't work - and now Windows did not know what to do when I double-clicked an indd-file. I had to scroll through apps and choose InDesign to open a file. Opening the files from within InDesign worked fine.

- Because things had now worsened, I changed back to "ab" for both settings and restarted - still the same result/error.

- But now - if I right clicked on a file/an icon > Open with > choose InDesign (and always use InDesign) - The icons are back!

Please note that this exact operation was performed multiple times before without the desired effect. For whatever reason I had to go through this process that doesn't quite make sense.
However it works now, and I hope it stays that way. Thanks for your advice and thorough guidelines.

Regards, Peter

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines