Multi-layered/language InDesign to Multi-layered/language PDF

New Here ,
Jan 22, 2019 Jan 22, 2019

Copy link to clipboard

Copied

I have a multi layered object with a different language on each layer. Each manual (layer) has numbered steps that are exactly the same in each language. However, the only layer that is printing the step numbers is the top layer. I have exported to PDF each language as the top language and that layer has the step numbers, but the languages below the top layer do not have the step numbers. This glitch just started today after 7 years of using InDesign never seen something like this. I have had a colleague attempt to create the multi-layered/language pdf and they have the same issue. I have uninstalled InDesign, re-installed, and deleted preferences. Not sure where to go now.

Views

948

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 22, 2019 Jan 22, 2019

Copy link to clipboard

Copied

Hi Tim,

what's your exact version of InDesign? What's your operating system?

Can you show the corresponding InDesign pages with hidden characters and frame edges showing?

Also the Layers panel with the same set of layers visible like in your screenshots from Acrobat.

Are the numbers set on their own layer in InDesign?

What's the color of the step numbers?

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 22, 2019 Jan 22, 2019

Copy link to clipboard

Copied

Also check your paragraph styles for Chinese.

Could be that auto numbering is turned off there.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 22, 2019 Jan 22, 2019

Copy link to clipboard

Copied

CC2018 14.0.1 x64

Windows 10 (Brand new system)

Are the numbers set on their own layer in InDesign? No

What's the color of the step numbers? Black

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 22, 2019 Jan 22, 2019

Copy link to clipboard

Copied

Hi Tim,

thank you for the screenshots.

Now it would be interesting to see into the paragraph style and the paragraph formatting that formats the text in Chinese.

Maybe auto numbering is turned off there? Or it is turned off as style override?

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 22, 2019 Jan 22, 2019

Copy link to clipboard

Copied

The styles

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 22, 2019 Jan 22, 2019

Copy link to clipboard

Copied

Hi Tim,

look into the Chinese layer.

Select some text of a Chinese paragraph where your numbering is missing in the PDF.

Are there any style overrides? Are the numbers visible in the layout? Any glyphs missing?

Is the Chinese font applied supporting formatting with style "strong"?

What's behind character style "strong"?

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 24, 2019 Jan 24, 2019

Copy link to clipboard

Copied

New information. When all layers are made visible as shown, the layers and all information on those layers will print. When only the top layer is visible and all layers are printed only the top layer has all information printed (step numbers). This workaround only works on Mac

not Windows.

This is the desired effect, however, it is not correct nor can I believe Adobe wanted this to work using this method since it worked correctly previously.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 24, 2019 Jan 24, 2019

Copy link to clipboard

Copied

Also, I have checked the Chinese font. The Chinese document is just one of the many languages (layers) that are in the document.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jan 24, 2019 Jan 24, 2019

Copy link to clipboard

Copied

I'm with Uwe on suspecting "strong."  Does the Chinese font offer a bold/strong weight?  Few do.  One exception is the open-source Source Han, but I suspect you'd be better off specifying an alphabetic font for the character style applied to numbered-list numbers.

David

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 25, 2019 Jan 25, 2019

Copy link to clipboard

Copied

All,

I spent a couple of hours on a chat with Adobe on Tuesday. During that time they took over my system and attempted to correct the error. Negative results. They advised they would be in touch within 24-48 hours. Well, I became impatient and started another chat today. They still have not figured out the issue. I was advised it could be another 48-72 hours.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 26, 2019 Jan 26, 2019

Copy link to clipboard

Copied

Hi Tim,

can you make one page available online? I'd like to have a look into this document.
Just package a one page InDesign document and upload it to Dropbox or a similar service and share the download link with me.

You can send me a private message with the link, just hover your mouse over my name here in the forum and do "Message".

Your issue is very mysterious.

Can do some tests with InDesign on Windows 10.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 29, 2019 Jan 29, 2019

Copy link to clipboard

Copied

Hello Uwe,

I have completely removed the Chinese layer in hopes that that step would remedy the situation. It didn't. Realizing you do not have the SKF font, it should substitute that font correct? I did receive a response from Adobe stating to make all layers visible and then print the pdf. This does work but does not remedy the problem in my eyes since it was not necessary to do this until last week. Something changed and I am not sure what? Thanks for the input and assistance.

Tim

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2019 Jan 29, 2019

Copy link to clipboard

Copied

Hi Tim,

ok. I substituted every missing font, the whole range of SKF custom fonts made especially for your customer and and also the two YouYuan fonts with Adobe Source Sans and Adobe Fangsong Standard.

Exported page 7 with the Chinese layer visible.

No issues found with automatic numbering:

ChineseLayerVisible-NoIssueFound.PNG

Still, I think the issue is the fonts you are using.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2019 Jan 29, 2019

Copy link to clipboard

Copied

What's your version of Acrobat Pro or Adobe Reader you are viewing the PDF?

I exported with a custom PDF/X-4 pdf export setting where I included layers.

I am working with Acrobat Pro DC Continous Release Version 2019.010.20064.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 29, 2019 Jan 29, 2019

Copy link to clipboard

Copied

Uwe,

Just double checking on my part. The sub-layers under Chinese have the numbers as well, correct? The SKF font was created by our company and until last week we had no issues with using the font for multi-layered pdfs created from layered InDesign documents. Now, we will have to go back to the old way. Heres hoping Adobe can figure out what was changed and correct it.

Thank you again for all of your time.

Tim

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2019 Jan 29, 2019

Copy link to clipboard

Copied

timl99453563  wrote

…The sub-layers under Chinese have the numbers as well, correct? …

Ah! There we have the issue!
Maybe I did not understand in the first place where you are seeing the issue!

Yep. The layers like Portugese, Swedish and German miss the numbers when visibility is turned on.

Here the German layer with visibilty set to true from the same PDF document:

GermanLayerMadeVisible-Numbering-is-missing.PNG

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2019 Jan 29, 2019

Copy link to clipboard

Copied

Next step for testing:

Export to IDML, using older versions of InDesign to see if the issue is also there.

Just tested with InDesign CS6 8.1.0 on the same machine.

Same issue found.

That's quite a bug.

Solution:
Export with all layers visible and turn off visibility of layers in the exported PDF/X-4 if necessary.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 30, 2019 Jan 30, 2019

Copy link to clipboard

Copied

Laubender  wrote

Solution:

Export with all layers visible and turn off visibility of layers in the exported PDF/X-4 if necessary.

No solution or workaround if you are working with text wrap in individual laguage layers.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

This is a workaround, but does not resolve the fact that it previously functioned without doing so in this manner.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

Hi Tim,

with my tests on my German Windows 10 it does not work with InDesign CS6 up to the latest version.

Also tested with diverse versions of InDesign on my German Mac OSX 10.10.6, even CS4. And it did never work.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 09, 2019 Feb 09, 2019

Copy link to clipboard

Copied

timl99453563  wrote

… that it previously functioned without doing so in this manner.

Hi Tim,

do you have a sample document where it worked?

Maybe we can find out why it worked back then?

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 19, 2019 Feb 19, 2019

Copy link to clipboard

Copied

Am working on finding the document. Shorthanded and extremely busy. Thank you for following up.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2019 Jan 29, 2019

Copy link to clipboard

Copied

Hi Tim,

tested on. This time by scripting.

I wanted to know the horizontal position of the first insertion point of a numbered paragraph.

Case 1: If the layer of the text frame is visible.

Case 2: If the layer of the text frame is not visible.

Turns out, that InDesign will not render the number for auto numbered paragraphs when layer visibility is turned off.

So this is no bug in the export engine. It's a bug in the composition engine of InDesign.

Here an experiment I did with a fresh InDesign document.

Just one text frame in the document holding a single paragraph with auto numbering turned on.

First auto number is 100, point size is 200 for demonstrating the issue.

Goal:
Meassure the horizontal position of the first insertion point in the frame.

Do that with the layer holding the text frame visibility turned on.

And as a second test do it with visibility turned off.

First attempt: Result is 139.7. Exactly the position the character "T" is beginning after the auto number.

The vertical guide colored in Cyan is indicating the position of the first insertion point.

HorizontalOffset-Layer-is-visible.PNG

Second attempt: Layer visibilty is turned off. Result: 12.7.

Just the beginning of the text frame that is not visble on the page.

The vertical guide colored in Red is indicating the position of the now invisible first insertion point:

HorizontalOffset-Layer-is-NOT-visible.PNG

Conclusion:
If a layer's visibility is turned off auto numbering is not rendered.

And therefore not exported to PDF.

Here the ExtendScript (JavaScript) code snippet that I used:

( function()

{

    // Do nothing if no document is open:

    if( app.documents.length == 0 ){ return };

   

    // Do nothing if there is no text frame or if there is more than one text frame in the document:

    if( app.documents[0].textFrames.length != 1 ){ return };

   

    // The first insertion point in the frame:

    var firstInsertionPoint = app.documents[0].textFrames[0].insertionPoints[0];

   

    // The horizontal position of that insertion point:

    var horizontalOffset = firstInsertionPoint.horizontalOffset;

    // Alert the horizontal position:

    alert( horizontalOffset );

}() )

Regards,
Uwe

//EDITED

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2019 Jan 29, 2019

Copy link to clipboard

Copied

Now also tested with InDesign CS6 8.1.0 on Mac OS X.

Same issue: Hide the layer, the rendering of auto numbers is not taking place.

Also did tests with InDesign CS 5.5, CS5 and CS4 on Mac OS X.

Still the same issue.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2