• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

My snaps won't snap/center even though they're turned on

New Here ,
Dec 04, 2013 Dec 04, 2013

Copy link to clipboard

Copied

I'm a bit of a novice with InDesign and your help would be much appreciated!

I went to View > Guides & Grids > and selected Snap to Grids and Snap to Document Grids but my text boxes/images/etc. won't snap and give that center line that helps align the object to others.

How do I turn these on?

Also, I have a Mac OSX Lion if that helps.

Much appreciated!

-Helen

TOPICS
Performance

Views

67.6K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Dec 04, 2013 Dec 04, 2013

On second reading of this, it sounds like you want Smart Guides on; not snap to grid. Smart Guides gives all that visual feedback that you are asking for.

Votes

Translate

Translate
Community Expert ,
Dec 04, 2013 Dec 04, 2013

Copy link to clipboard

Copied

In the Guides and Pasteboaed section of the InDesign preferences make sure that all the boxes under Smart Guides are checked. Then also make sure Samrt Guides is checked under View > Guides and Grids.

A word of warning about snapping to the document grid... you may find it interferes with easy snapping to objects.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 04, 2013 Dec 04, 2013

Copy link to clipboard

Copied

Snap to Grid interferes with Smart Guides. Have either on; but not both.

Mike Witherell

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 04, 2013 Dec 04, 2013

Copy link to clipboard

Copied

On second reading of this, it sounds like you want Smart Guides on; not snap to grid. Smart Guides gives all that visual feedback that you are asking for.

Mike Witherell

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 30, 2019 Oct 30, 2019

Copy link to clipboard

Copied

Came here for the object snapping issue, your advice fixed it, thanks Mike!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 26, 2020 Mar 26, 2020

Copy link to clipboard

Copied

I thought I was having this problem and ended up figuring out what it was on my own and thought I'd add what it was in my case for future people googling this. In your Guides & Pasteboards preferences make sure to check that your Snap to Zone is bigger than 1 px, probably something more like 4px, otherwise it WILL technically be snapping, but only if you're EXACTLY lined up with what you wanted to snap to… which kind of defeats the whole point of snapping to begin with. This probably won't happen all that often but if you're working with a pickup file it's not a bad thing to check.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 28, 2022 Jul 28, 2022

Copy link to clipboard

Copied

Thank you! This fixed it. 
For me, however, I had to set it to 10 px. The default, which was 4px, wasn't doing it for me on a 1366 x 768 document.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 21, 2023 Jul 21, 2023

Copy link to clipboard

Copied

I'm having the same problem. It's temprarily fixed if I colse and re-open Photoshop but the issure retuns after about 30 minites. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 21, 2023 Jul 21, 2023

Copy link to clipboard

Copied

LATEST

This is a question and answer about InDesign, not Photoshop.

Mike Witherell

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines