• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Numbering in list doesn't work – it stays at 1. for all paragraphs

Explorer ,
Sep 30, 2020 Sep 30, 2020

Copy link to clipboard

Copied

Hi all, don't know if this is a known issue or not:

I'm am setting up numbered lists and want to save them as a paragraph style. The weird thin: As soon as I save the style, all numbers in the list switch to 1. Even if I just use the default settings from InDesign and then just try to save these as a style. What am I missing here?

TOPICS
Bug , How to

Views

3.4K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Sep 30, 2020 Sep 30, 2020

That's because by default when you create a numbered list and save it as a style, the style records the bullets and numbering properties always starting at 1. You need to edit the style and go to the Bullets and Numbering section and change the mode to "Continue from Previous".

Votes

Translate

Translate
Explorer ,
Sep 30, 2020 Sep 30, 2020

Copy link to clipboard

Copied

So this is what happens:

---

Typing list and selecting Numbered list (or whatever it's called in the english version)

1. First paragraph

2. Second paragraph

---

Then I select this, click on the paragraph style panel, and save it. Immediately the numbering changes:

1. First paragrah

1. Second paragraph

 

Working on the latest version under MacOS Catalina.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 30, 2020 Sep 30, 2020

Copy link to clipboard

Copied

Would you mind sharing a screen shot of the numbering properties of the style in Paragraph Style Options > Bullets and Numbering after saving the style? Use the Insert Photos button on the toolbar in your reply (mountain range icon).

 

~Barb 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 30, 2020 Sep 30, 2020

Copy link to clipboard

Copied

That's because by default when you create a numbered list and save it as a style, the style records the bullets and numbering properties always starting at 1. You need to edit the style and go to the Bullets and Numbering section and change the mode to "Continue from Previous".

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 20, 2020 Oct 20, 2020

Copy link to clipboard

Copied

Thanks a lot! As InDesign, Illustrator and Acrobat are giving me headaches since two weeks now and the supoort's "solutions" don't solve anything, I couldn't reply earlier. I think this should be mentioned in the help section.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 16, 2023 Jan 16, 2023

Copy link to clipboard

Copied

No, does not work  "Continue from Previous"is on yet it always starts back at 1

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 16, 2023 Jan 16, 2023

Copy link to clipboard

Copied

Your style setup under Bullets & Numbering should look like this:

JamesGiffordNitroPress_0-1673903001459.png

 

And hit OK to save the style update.

 

Make sure this style is applied to all the members of any one list. There should be no override marker (+) on any of those paragraphs in the style list.

 

Is it possible that in the Number field, you put '1.' etc. instead of the ^# number wildcard?

 


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 09, 2023 Nov 09, 2023

Copy link to clipboard

Copied

Hi James, just came across this forum as I also have the same issue. My settings are exactly as your screenshot but all paragraphs start with 1..

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 09, 2023 Nov 09, 2023

Copy link to clipboard

Copied

There are only three reasons I can think of this would happen:

  • The Paragraph style is set to use 1, without automatic advancement. (That is sometimes done to provide a child style that will cleanly reset a list to 1, without relying on overrides.) Double check that the applied Paragraph style is set as above, with 'Continuing Numbers.'
  • The "Restart Numbering" override is applied to the faulty paragraphs. This is the override that comes from right-clicking on a numbered paragraph and selecting Restart Numbering. It will set the numbering back to 1, and an override flag will appear on the Paragraph Style name. Clear it by re-applying the numbered paragraph style or otherwise removing all overrides.
  • The document is corrupt. Try purging it to see if that fixes the problem...

 

It's a useful trick to purge and clean up an ID doc that's showing weird behavior — everything is fine except one aspect of numbering, footnotes, something. Save the doc as IDML, then open that and save again as INDD, under a new name. You'll often find that this fixes frustrating glitches in formatting.


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 12, 2024 Mar 12, 2024

Copy link to clipboard

Copied

LATEST

I figured it out (well my collegue actually did). It is pretty simple. Just don't select the whole the text but just have your blinker at the start of the list and then create the list. 

I selected the whole list at firts and InDesign seems to think that every line is a new start of a list.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines