Numbers typing backwards??? I'm going crazy LOL

New Here ,
Jun 22, 2017 Jun 22, 2017

Copy link to clipboard

Copied

When I type 3 - 4 for example it reverses it to 4 - 3. When I type June 23/17 it types June 17/23. What is going on? I have never seen this in all my years using Indesign.

I am on CS6 Mac.

I can't for the life of me understand why I would ever need Indesign to reverse things like that. Anyone have any advice on how to get it back to normal.

It is only like this  in one document. If I start a new document the problem doesn't happen.

Thank you in advance.

Views

11.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jun 23, 2017 Jun 23, 2017
And select the text in the paragraph with the type tool and change the language back to English UK/USOr change the language before typing.

Likes

Translate

Translate
Adobe Community Professional ,
Jun 22, 2017 Jun 22, 2017

Copy link to clipboard

Copied

Try restoring your InDesign preferences:

Trash, Replace, Reset, or Restore the application Preferences

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jun 22, 2017 Jun 22, 2017

Copy link to clipboard

Copied

What about Adobe jumping to the rescue and provide an own InDesign-Preference CleanUp-/Restore-/PreInstallValidation-tool for a heap of bucks?
…it starting to annoy me always reading again to "trash prefs" – I see Adobe to secure their Prefs of not getting broken.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 22, 2017 Jun 22, 2017

Copy link to clipboard

Copied

No such luck. Tried that.

It seems anything to do with numbers gets reversed

I just typed Page 15 and it reversed it to 15 Page. This is the oddest thing I have ever seen. Maybe it is a setting I changed  accidentally with an unknown key combination? Although what on earth would you ever want that setting for??lol

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Valorous Hero ,
Jun 23, 2017 Jun 23, 2017

Copy link to clipboard

Copied

Does that happen if you type something into TextEdit or any other app ?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 23, 2017 Jun 23, 2017

Copy link to clipboard

Copied

No I use text edit, Illustrator, Photoshop, Word...etc all day long and no problems.

I am thinking it is specific to just the file because starting a fresh document it doesn't do that.

I just wondering what it is about that file that would cause it to happen?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jun 23, 2017 Jun 23, 2017

Copy link to clipboard

Copied

It might be a fonts problem try to change the fonts to something like "Arial"

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 23, 2017 Jun 23, 2017

Copy link to clipboard

Copied

If the document was started in a Middle Eastern version then the Right to Left reading could still be there - change the Language in the paragraph settings by going to Window>Type & Tables> Paragraphs

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 23, 2017 Jun 23, 2017

Copy link to clipboard

Copied

And select the text in the paragraph with the type tool and change the language back to English UK/US

Or change the language before typing.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 23, 2017 Jun 23, 2017

Copy link to clipboard

Copied

Possibly because you have the Middle Eastern version of InDesign installed and you have Arabic language selected in the Paragraph dialog box.

Try switching the language to English Uk or US.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Jun 23, 2017 Jun 23, 2017

Copy link to clipboard

Copied

Hi there,

It does seems to be a case suggested above by Eugene. Styles still holding the right to left direction of typing as it normally happens in ME versions. You can change the text direction or change the paragraph style.

Regards,

Om

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 24, 2018 Jun 24, 2018

Copy link to clipboard

Copied

Type > Character

make sure the Language is English

Screen Shot 2018-06-24 at 3.35.05 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 01, 2018 Oct 01, 2018

Copy link to clipboard

Copied

I know its too late but finally found the solution to this. change your text engine from preferences- graphics to european and east asian

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 15, 2019 May 15, 2019

Copy link to clipboard

Copied

This made me crazy too.

Thank you for your kind solution!

Saved my life.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 15, 2022 Jun 15, 2022

Copy link to clipboard

Copied

LATEST

Go to the "Languages" menu of the computer, then "Administrative Languages Settings", a dialog box comes up titled "Region". In the "Administrative" tab of the dialog box, make sure "English" is set for non-Unicode programs. Mine was set to Arabic. 

That fixed it for me, when I would type "40-CAD-500", it would correct to "CAD-500--40". I struggled for a year and a half to find a solution until I got a hint on this forum that it could be a right-to-left language setting to be changed to left-to-right setting.

Cheers!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines