• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Paragraph Justification issue while using single line composer

Explorer ,
Aug 14, 2023 Aug 14, 2023

Copy link to clipboard

Copied

Hi All

I could not resolve the justification issue while using single line composer and the word should not be break at the end of the paragraph. I have not used any word space between the word "my" in my document. Here I do not want to split the content. could you please check and let me know this is bug? or can resolve? how? (tracking not allowed, should not remove Discretionary Line Break, Shift break not allowed)

 

I have attached the screenshot and IDML file here for troubleshoot.

 

Regards,

Sathis

TOPICS
Bug , How to

Views

559

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 14, 2023 Aug 14, 2023

Copy link to clipboard

Copied

Hi @SathishSekar_ I don't know what happens here, but reapplying the paragraph style or retyping either the “m” or the “y” fix the issue… 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 16, 2023 Aug 16, 2023

Copy link to clipboard

Copied

Hi All,

 

Still i am not get any solution for this issue? can help anyone?

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 17, 2023 Aug 17, 2023

Copy link to clipboard

Copied

Hi @SathishSekar_ does it occur again? I gave you the way to fix i

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 17, 2023 Aug 17, 2023

Copy link to clipboard

Copied

Hi @SathishSekar_ , Also there’s some kind of corruption in the file, Saving As IDML and opening the IDML fixed it for me.

 

Clearing the Paragraph Style’s Override also works.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 17, 2023 Aug 17, 2023

Copy link to clipboard

Copied

Hi rob,

It is not working; could you please share the issue fixed file?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 17, 2023 Aug 17, 2023

Copy link to clipboard

Copied

Screen Shot 30.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 21, 2023 Aug 21, 2023

Copy link to clipboard

Copied

I thought you are working with missing font. could you please use "ITC Berkeley Oldstyle Std" font and check.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 21, 2023 Aug 21, 2023

Copy link to clipboard

Copied

I don’t have that version of Berkeley, but it does seem to be font related. You might have to change fonts or switch to Paragraph Composer:

 

Screen Shot 4.pngScreen Shot 5.png

 

Minion with Paragraph Composer

 

Screen Shot 6.png

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 21, 2023 Aug 21, 2023

Copy link to clipboard

Copied

I should not change the customer specification. Any other solution?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 21, 2023 Aug 21, 2023

Copy link to clipboard

Copied

If you have to stay with Berkeley looks like switching to Paragraph Composer is the only solution—in general Paragraph Composer does a better job with line breaks. Not sure if it’s an InDesign or font bug.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 22, 2023 Aug 22, 2023

Copy link to clipboard

Copied

Also, looks like you are not using the latest version of InDesign, which no longer allows Type 1 postscript fonts—the problem in CC2021 seems to be limited to a few Type 1 fonts. You could use a converter to convert your version of Berkeley to Open Type. See this thread:

 

https://community.adobe.com/t5/indesign-discussions/ende-der-unterst%C3%BCtzung-f%C3%BCr-ps-type-1-f...

 

Here I’ve converted my version of Berkeley to OTF and it fixes the problem:

 

Screen Shot 13.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 22, 2023 Aug 22, 2023

Copy link to clipboard

Copied

@SathishSekar_ -- I think you missed @jmlevy's reply of the 14th, the first reply to your query. Please check if his solution works for you.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 22, 2023 Aug 22, 2023

Copy link to clipboard

Copied

@Peter Kahrel it is not working; I want to know actual error details.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 22, 2023 Aug 22, 2023

Copy link to clipboard

Copied

You should have reported that jmlevy's suggestion doesn't work.

 

As to error details, InDesign never gives you those unless it's caused by a script. And when InDesign crashes you could check the crash logs. But for general non-fatal malfunctions you'll be in the dark. @rob day suggested that it's a font problem (and so did @jmlevy, though indirectly), which I think is correct, and that's probably as close to 'error details' as you'll get.

 

To make further tests more precise, please post you ITC Berkeley Oldstyle Std font. Even if some tester has that font, it may not have the same (internal) version number.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 22, 2023 Aug 22, 2023

Copy link to clipboard

Copied

Hi Peter, I can replicate the problem using a few older Type 1 fonts in CC2021 (old version of Minion, Adobe’s Berkeley 1989, Eureka, Emigre’s Filosophia), so I thought it was a Type 1 used with Adobe Single Line Composer problem. However, looks like it can also happen with an OTF font—try setting @SathishSekar_ ’s text in Mrs. Eaves XL  Serif Narrow, which is available at Adobe Fonts:

 

Screen Shot 15.png

 

 

Screen Shot 16.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 22, 2023 Aug 22, 2023

Copy link to clipboard

Copied

Customer requirement to use Adobe Single-line Composer 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 22, 2023 Aug 22, 2023

Copy link to clipboard

Copied

@rob day The problem shows even with Minion Pro in 2023. And I remember now that I've seen this before a while ago. When you remove the discretionary line-break characters from six-year-old the text flows correctly. Those characters don't make sense there, it seems to me. InDesign never breaks words before a hyphen. The problem that the OP sees shouldn't occur, of course, but in this case it's easy to avoid.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 22, 2023 Aug 22, 2023

Copy link to clipboard

Copied

Thanks peter, I did not notice the discretionary line-breaks. Removing them works, but the Single line setting is as expected horrible:

 

Screen Shot 17.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 23, 2023 Aug 23, 2023

Copy link to clipboard

Copied

Specification says; it should be single-line composer, last word should not be break, should not be put manual hyphen, should not be adjust tracking and should not be delete discretionary line-breaks.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 23, 2023 Aug 23, 2023

Copy link to clipboard

Copied

Fine. But adding discretionary line breaks just cause problems, like irrational line breaks. You should use either non-breaking hyphens or apply NoBreak to the whole phrase.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 23, 2023 Aug 23, 2023

Copy link to clipboard

Copied

The specifications are producing a bad result, are the specifications more important than good typesetting? Even if it is an InDesign and not a font bug, it’s not going to get fixed anytime soon, and there are plenty of ways to improve the setting. The single line composer just isn’t very good because it doesn’t consider the entire paragraph.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 23, 2023 Aug 23, 2023

Copy link to clipboard

Copied

are the specifications more important than good typesetting?

 

Many people see only violations of their (usually pretty petty) rules, such as 'the last line of a paragraph must be at least n characters long'. Or 'a word must not break across pages'. Or 'widows are evil'. Violate the text by tightening and/or loosening paragraphs at will. As long as those rules are honoured it doesn't matter how awfully spaced a text turns out.

 

I'm reading a novel at the moment where the designer/publisher dictated that the last line of a paragraph must be at least two words long. In a text with lots of short paragraphs (two or three lines) that often causes some really awful type. If the book wasn't so good I'd give up. And this is a book that got the Booker prize, and the translation (from Hindi) got the booker prize, too. The typesetting definitely won't get any prizes.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 24, 2023 Aug 24, 2023

Copy link to clipboard

Copied

Have you discussed this problem (and it's solution) with the customer? Perhaps educating them a little bit would be useful.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 24, 2023 Aug 24, 2023

Copy link to clipboard

Copied

I will communicate with customer

Thank you all...

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines