• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Print booklet is junk.

New Here ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

I've been using Indesign for 15+ years, mostly CS3 - which was, and is, a tremendous piece of software. But because nothing ever stays the same, I've been forced to move to the current cloud based software running on Windows 10 Pro.

Attempting to create printer spreads using the print booklet feature, as I've done hundreds of times in the past using CS3. It's a digest size book when completed, 32 pages, with .125" bleed on the 5.5" x 8.5" page. I drop all of the single page PDF files in to my 32 page document, select print booklet, select my Adobe PDF printer, set the page size to letter, include crop marks, use document bleed settings (.125"), blah blah blah....literally all the same stuff I've done for years. Yet this program WILL.NOT.INCLUDE. crop marks and create the page size required for the marks to be included unless I manually set the page size to something larger than 8.75 x 11.25. I have never had to do this with CS3 - it would automatically set the page size needed whether you included no bleed, bleed, bleed with crop marks, or bleed with crop marks and bleed marks.

 

Screen shots inserted.

 

It's great that the software is 'more powerful'....but it's less functional than the previous platform. And not being a stand alone is definitely a detraction, not a benefit.

 

 

Printbook_1.jpgPrintbook_2.jpgPrintbook_3.jpg

TOPICS
Feature request , How to

Views

72

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Nov 02, 2022 Nov 02, 2022

Hi @spaktacular , Looks like your PPD needs to be updated. Should be this:

 

Screen Shot 45.png

 

Download here, read the install instuctions carefully:

 

https://helpx.adobe.com/indesign/kb/add-acrobat-ppd.html

 

Likes

Translate

Translate
Community Expert , Nov 02, 2022 Nov 02, 2022

It does still work. The Custom Page size will be automatically selected to fit your crop marks and bleed but you have to do things in a particular order.

Print Booklet > Print Settings.

Set your Crop Marks and Bleed, etc, FIRST, then go to Setup.

If it's not already selected, pull down Custom. It should give you a larger page size that just accommodates the crops, etc. (The size will have brackets around the dimensions.). Make sure you select Position > Centered, unless you have a neeed for a di

...

Likes

Translate

Translate
Community Expert ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

Well unless your copier has a fiery, it is useless. Here is a workaround instead of print booklet go Print only and set the booklet settings on the print box. Save it for future use. Then print.

Lee- Graphic Designer, Print Specialist, Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

Print booklet, IMO, has never been a very reliable method for this. And printing to PDF is completely archaic method for PDF production.

 

My advice is to export a proper PDF/X-4 file and use Acrobat's booklet feature to print it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

Hi @spaktacular , Looks like your PPD needs to be updated. Should be this:

 

Screen Shot 45.png

 

Download here, read the install instuctions carefully:

 

https://helpx.adobe.com/indesign/kb/add-acrobat-ppd.html

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

So CS3, which was basically the first fully functional version of InDesign, did one relatively minor and quirky function more seamlessly than current versions, and is thus the pinnacle of the app's evolution across 15 years.

 

Okay.

 


| Word & InDesign to Kindle & EPUB: a Pro Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

Just to reitterate a bit - you were using CS3 - from 2007 - that's about 15 years old now.

Print Booklet is rarely used in modern workflows and that feature has remained but I think it should have been phased out a long time ago. 

 

As others have said - create PDF and/or update your PPD drivers. 

15 years is a long time, a lot has changed, even if you haven't 😛 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

Why do you need print booklet?

Are you the printer, you should have professionel imposing software.

If you let the printer print, let do him the imposing.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

LATEST

It does still work. The Custom Page size will be automatically selected to fit your crop marks and bleed but you have to do things in a particular order.

Print Booklet > Print Settings.

Set your Crop Marks and Bleed, etc, FIRST, then go to Setup.

If it's not already selected, pull down Custom. It should give you a larger page size that just accommodates the crops, etc. (The size will have brackets around the dimensions.). Make sure you select Position > Centered, unless you have a neeed for a different position. If you are doing this regularly, this is the best time to create a Print Preset so you don't have to do this every time.

screen1.png

screen2.png

screen3.png

screen4.png

Caveat: when you create PDFs this way, your file becomes flattened, so your resulting PDF will no longer retain certain properties, such as live transparency. Unless you know which printer you are dealing with, this can be problematic. But you sound like someone that has done this for awhile, so you should know that already.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines