• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

questions about book mode

Enthusiast ,
Nov 27, 2022 Nov 27, 2022

Copy link to clipboard

Copied

Hello,

 

I have created a book inside InDesign.

From the book mode, if I try to export it to PDF, in the exported PDF I don't see any page number created by InDesign. How to have the page numbers on each page in the exported PDF (by example at the top of each page) ?

 

 

TOPICS
How to

Views

658

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Nov 27, 2022 Nov 27, 2022

You need to put the current page marker on the  parent pages. 

Votes

Translate

Translate
Community Expert ,
Nov 27, 2022 Nov 27, 2022

Copy link to clipboard

Copied

You need to put the current page marker on the  parent pages. 

David Creamer: Community Expert (ACI and ACE 1995-2023)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 27, 2022 Nov 27, 2022

Copy link to clipboard

Copied

Here is the book mode I have :

 

screenshot0001.jpg

From this book mode, I can choose to export to PDF. But if I do that, my PDF has no page number.

I would like that when I choose "export to PDF", InDesign put automatically a page number on each page (in the exported PDF). 

This book is made of 85 chapters (each chapter is corresponding to one InDesign file). And the book mode is combinating all these 85 Indesign files.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 28, 2022 Nov 28, 2022

Copy link to clipboard

Copied

You need to open up a document (not the book) and edit the parent/master page(s) to add the Type > Insert Special Character > Markers > Current Page marker. 

If the master/parent pages are the same throughout the book, you can then use the book file to synchronize the parent pages to all the other selected documents. 

 

David Creamer: Community Expert (ACI and ACE 1995-2023)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 28, 2022 Nov 28, 2022

Copy link to clipboard

Copied

Hello,

My book is made of 85 different indesign files (one page on each indesign file).

 

1) On one indesign file, in "Master A", I have created a page number : 

 

screenshot2.jpg

2) Then, in book mode, I have clicked on "synchronize button" (see green line) :

 

screenshot 1.jpg

But the result  : if I export the "synchronized" book to PDF : on the exported PDF I have no page number.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 28, 2022 Nov 28, 2022

Copy link to clipboard

Copied

Did you select the chapters (files) in the Book file before sync'ing?

 

David Creamer: Community Expert (ACI and ACE 1995-2023)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 28, 2022 Nov 28, 2022

Copy link to clipboard

Copied

In the book file, even if I select all the files before syncing, the exported PDF does not shows any page number.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 29, 2022 Nov 29, 2022

Copy link to clipboard

Copied

Did you select parent pages in the Synchronization Options?

 

David Creamer: Community Expert (ACI and ACE 1995-2023)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 29, 2022 Nov 29, 2022

Copy link to clipboard

Copied

LATEST

About the book mode, in synchronization option, all is checked, but I don't see any "parent page" in the list :

 

screenshot0006.jpg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines