• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Romanian hyphenation problems

New Here ,
Jan 25, 2024 Jan 25, 2024

Copy link to clipboard

Copied

Hello, everyone! 

 

I am typesetting a book in Romanian, an InDesign book consisting of multiple documents. I use the modern keyboard layout, which uses s-es and t-es with commas below, instead of the traditional layout, which uses s-es and t-es with cedilla. While InDesign knows how to hyphenate words written with the traditional keyboard layout, it seems not to recognize modern letters. It cannot therefore hyphenate words written with the modern keyboard layout.

 

I am not puzzled by this fact, but by the fact that in 2 or 3 of the documents of my InDesign book, somehow it can recognize these characters and it can produce correctly hyphenated words containing the modern glyphs (as opposed to the same words not being hyphenated at all in other documents in the book). It's the same font, the same language set for hyphenation. I would like to know how can I "force" it to apply hyphenation for those words in the rest of the documents.  

TOPICS
Bug , Type

Views

70

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 25, 2024 Jan 25, 2024

Copy link to clipboard

Copied

LATEST

Can you tell us what OS you're using, and where these input methods come from? I'm on Windows 10 and my only Romanian options are "Romania" and "Moldova," so I can't really run any tests of this on my own machine.  Also, can you perhaps post a test document with a few samples? Optimally, you could post an InDesign document with two bits of Romanian sample text, both using comma-below, in which one hyphenated correctly and the other did not. 

 

My suspicion is that one of your input methods is not encoding "s with comma below" but instead "s" followed by "combining comma below." However, there are quite a few possible causes of this, so it would be much faster to simply examine a sample. If you can't do this, just let me know and we can figure it out the old-fashioned way, with lots of posts and "Now try this" instructions. 

(One of the possibilities is Book-level style sync that is marking your Romanian text as some other language, which you will rapidly discover if you copy and paste some text that is not hyphenating correctly from your book into a fresh, empty file. If a given paragraph that is not hyphenating correctly starts behaving correctly once you get it out of your Book file, then my input-method guesses above are most likely going to turn out incorrect.)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines