Show all frame edges, always, not just on mouse hover!

Community Beginner ,
Feb 03, 2019 Feb 03, 2019

Copy link to clipboard

Copied

Hello,

I want to see text frame edges. Always. Not just when I hover my mouse over the frame.

The mouseover concept is evil from a UI standpoint. How can I know what exists if I can't see it? I am forced to move my cursor around everywhere on the layout and watch to see if a frame edge appears? This can't be right.

Please help.

Thank you,

Aaron

Views

815

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Feb 04, 2019 Feb 04, 2019

In addition to Steve's suggestion to trash preferences you might also try deleting your InDesign cache files. This can be helpful for interface issues.

To do so:

For Macintosh Users: The User Library folder in which InDesign’s cache files are stored is hidden by default on most Macintoshes. To access it make sure that InDesign is closed and click on the desktop to launch a Finder Window (Command-N).With this window in column view follow the path User>Home folder (it’s the folder with an icon that

...

Likes

Translate

Translate
Community Expert ,
Feb 03, 2019 Feb 03, 2019

Copy link to clipboard

Copied

It sounds like you're in Preview mode, instead of Normal mode. You can switch modes in the View > Screen Mode menu.

If you still don't see them in Normal mode, choose View > Extras > Show Frame Edges.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 03, 2019 Feb 03, 2019

Copy link to clipboard

Copied

Thank you Steve, but I already tried that before coming to the forums. I'm not in Preview mode, I'm in View > Screen Mode > Normal. Show Frame Edges is enabled.

With those settings, I am only able to see text frame edges when the mouse cursor is hovering over the frame.

This is CC 2017.0, Windows 10. Build number 12.0.0.81 x64. I will try updating and see if the problem is resolved.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 03, 2019 Feb 03, 2019

Copy link to clipboard

Copied

Double check the settings in View Options, Dr. Yo​. InDesign should not be doing that in Normal mode. You might need to reset Preferences.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 03, 2019 Feb 03, 2019

Copy link to clipboard

Copied

Here are instructions for restoring preferences for an Adobe HelpX file:

Set preferences in Adobe InDesign

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

View > Extras > Show/Hide Frame Edges

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

The OP says he tried that already, Frans

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

https://forums.adobe.com/people/Steve+Werner  schreef

The OP says he tried that already, Frans

Ooops... my bad.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

Is this happening on one file or all files? What version of InDesign and What operating system?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

In addition to Steve's suggestion to trash preferences you might also try deleting your InDesign cache files. This can be helpful for interface issues.

To do so:

For Macintosh Users: The User Library folder in which InDesign’s cache files are stored is hidden by default on most Macintoshes. To access it make sure that InDesign is closed and click on the desktop to launch a Finder Window (Command-N).With this window in column view follow the path User>Home folder (it’s the folder with an icon that looks like a house—it may have the user’s name rather than “Home”) and click on the Home folder. With the Option Key pressed choose Library from the Finder Go Menu. “Library” will now appear within the Home folder. Within the Library folder find the “Caches” folder. Within the Caches folder find and delete the entire folder “Adobe InDesign”. I find that deleting the InDesign cache folder completely leads to a lasting change. 

For Windows Users: On Windows 7 and above the caches files are hidden. To find them go to the Control Panel and open Folder Options and then click the View tab. Then select “Show hidden files and folders” or “Show hidden files, folders or drive options” in Advanced Settings. Then delete (or rename) the folder at the end of this path: C:\Users\[User Name]\AppData\Local\Adobe\InDesign\Version [#]\<Language>\Cache.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

Hi Aaron:

Jane's screen shot shows the frame edges clearly, but note that they are well in from the margin guides.

However, default text frames specifically will disappear—even when in Normal mode and with Frame Edges showing—when your cursor is in the frame, if it is snapped to the column and margin guides.

That insertion point is inside a text frame on this page. But you can't see it:

Screen Shot 2019-02-04 at 9.16.17 AM.png

Pressing Esc will show the frame edges:
Screen Shot 2019-02-04 at 9.16.29 AM.png

Or Preferences > Guides & Pasteboard > Guides in Back will always show the edge.

Screen Shot 2019-02-04 at 9.17.22 AM.png

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

Frame edges are not hidden behind guides. They are floating in an empty sea of whitespace. The frame edges ONLY display when the mouse is over the frame, AND the text insertion point is NOT within the frame.

I will try trashing the cache, then the preferences.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

Let us know. If it is still an issue, screen shots help.

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

OK, I trashed the cache files, and when I re-launched InDesign, "Show Frame Edges" was off again. I turned it back on again, and it seems to be working correctly now.

The problem did not occur when I created a New Document, only when I double-clicked a template to launch InDesign. So it does seem to be an issue with caching.

Thanks to everyone for their help!

Aaron

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

Glad it worked out.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

Me too.

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

LATEST

Me too! So glad it's working!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines