• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit Search
7

Smart guides not working

Community Beginner ,
Sep 20, 2017 Sep 20, 2017

Copy link to clipboard

Copied

Hello! I have read previous discussions on issues when the smart guides options gets grayed out due to accidental selection of "snap to document grid". I am wondering if there is a possibility for other commands to deactivate my smart guide. I have retrieved an idml layout file from work and it does not work for that file. My smart guides are working for my other indd documents.

I am also curious what the green boxes grids are? Thanks in advance to any help! smart guides.png

Views

46.7K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Sep 27, 2018 Sep 27, 2018

I know this an old thread, plus this isn't a solution for the initial issue (based on your screengrab), but I found that I had by mistake checked the "Snap to Document Grid" feature under View > Grids & Guides. This made the Smart Guides option inaccessible.

Once I'd taken that option off, the Smart Guides started working again.

Votes

Translate

Translate
Adobe Employee ,
Sep 22, 2017 Sep 22, 2017

Copy link to clipboard

Copied

Hi yu jiet,

Please try on a new document, if it is still the same, please try resetting preferences.

Set preferences in Adobe InDesign

Please update the discussion if the issue is resolved or if you have any further query.

Regards

Srishti

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 23, 2017 Sep 23, 2017

Copy link to clipboard

Copied

Hi Srishti,

The issue is only of that idml file. Smart guide works alright for all other files and new documents that I have.

Is there a way to reset preferences for that idml file?

Best

Yu Jie

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 22, 2017 Sep 22, 2017

Copy link to clipboard

Copied

Can you select the green grids with a text tool? It looks like table cells.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 23, 2017 Sep 23, 2017

Copy link to clipboard

Copied

Nope i cannot select it with a text tool!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Sep 23, 2017 Sep 23, 2017

Copy link to clipboard

Copied

I'm not entirely sure, but here are some common reasons why InDesign features may be grayed out: https://indesignsecrets.com/why-is-some-feature-grayed-out-in-indesign.php

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 24, 2017 Sep 24, 2017

Copy link to clipboard

Copied

Updates. I am still unable to solve the issue, but I have worked around it by moving the master pages to a new indd document. The green grids should be I type of grid i suppose? When i transferred them to a new document, the converted to the traditional guidelines. Thanks for everyone's help!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 29, 2018 Jan 29, 2018

Copy link to clipboard

Copied

Hi!

I'm a photographer who has worked with indesign for years. Right now I'm doing an online training session with lynda.com.

It appears that I too cannot access smart guides when creating a master page, even after resetting my indesign permissions and restarting my computer. I can, however, access them on other, non master pages. Yes, smart guides are selected in the view menu, and I've tried toggling on and off the snap to document guide feature. So go figure.

Is this a glitch in the program itself? Given what I've read here, that might be what's going on.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jan 29, 2018 Jan 29, 2018

Copy link to clipboard

Copied

Jane: that's weird… I have not seen any problems with Smart Guides appearing on master pages. Have you tried to zoom in or out, so that all the objects you want to align are visible? Are you seeing ANY smart guides as you drag objects around the master page? (For example, do you see the pink ones that say the object is centered on the page?)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 29, 2018 Jan 29, 2018

Copy link to clipboard

Copied

Thanks David, for your quick reply! The only smart (ish) guide that pops up is the vertical center line, which appears in red if I get close to while drawing a box. On other pages, I have no problem seeing the smart guides–only on the master page.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 01, 2018 Feb 01, 2018

Copy link to clipboard

Copied

Jane, that is definitely weird. I wish I could think of a good solution for you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 14, 2018 Aug 14, 2018

Copy link to clipboard

Copied

This is so funny! I'm actually watching your tutorial on Linkedin Learning (Chapter 3.2) and am having the same problem when trying to add the document name in the master page. At least I know it's not just me, and thank you for this course, David! It's been so fantastic to finally feel like I CAN learn InDesign!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 15, 2018 Aug 15, 2018

Copy link to clipboard

Copied

https://forums.adobe.com/people/yu+jiet15685082  wrote

… I am also curious what the green boxes grids are? Thanks in advance to any help!

smart guides.png

Hi,

the green boxes grid is from a Japanese InDesign document, I think.

Did you open a template document from a Japanese source?

Regards,
Uwe

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 27, 2018 Sep 27, 2018

Copy link to clipboard

Copied

I know this an old thread, plus this isn't a solution for the initial issue (based on your screengrab), but I found that I had by mistake checked the "Snap to Document Grid" feature under View > Grids & Guides. This made the Smart Guides option inaccessible.

Once I'd taken that option off, the Smart Guides started working again.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

Thank you @Owen Clay!  You've just made my Friday afternoon a lot easier!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

That's for that @Owen Clay . Been wondering for 45 minutes why no smart guides have been working lol.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 26, 2023 Jan 26, 2023

Copy link to clipboard

Copied

thank you !! you saved me

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
8 hours ago 8 hours ago

Copy link to clipboard

Copied

LATEST

THANK YOU! This saved my sanity.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 21, 2020 Sep 21, 2020

Copy link to clipboard

Copied

Thanks, @Owen_Clay!

Seems I cannot live without the Smart Guides and you just gave me the solution to a situation. 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 18, 2021 Nov 18, 2021

Copy link to clipboard

Copied

There is a button at the bottom of the tool panel. Click on there, and it will show smart guides. If it does not have a tick in the box, it means it is off. Click it, and this will reactivate them. Screenshot 2021-11-18 at 23.02.47.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines