Strange problem: Pasting text to InDesign CC2015 always adds cyan color

Explorer ,
Jun 22, 2015 Jun 22, 2015

Copy link to clipboard

Copied

Every time I paste a text into any InDesign document in InDesign CC2015 – it also imports the color 100% cyan to my swatch library. (They text is still black though, and there is no background color or anything.)

Anyone knows why this happens?!?

Not a big deal but quite odd...

Views

11.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jun 23, 2015 Jun 23, 2015

Another note on this.

What is not working:

Changing the default fill color of paragraph shading, if you are changing the defaults of your "Basic Paragraph Style" when no document is open to "None" and proceed.

You still have a swatch named "C=100 M=0 Y=0 K=0" that is in use. I suspect, that fill color "C=100 M=0 Y=0 K=0" is part of the "invisible" "No Paragraph Style" paragraph style. And "Basic Paragraph Style" is based on "No Paragraph Style".

Just tested this by scripting (ExtendScript/JavaScript

...

Likes

Translate

Translate
Adobe Community Professional ,
Jun 22, 2015 Jun 22, 2015

Copy link to clipboard

Copied

Hi Lars,

this is caused by the new Paragraph Shading feature where Cyan* is used as default color for the shading.

Example:

Add a new document.

Remove all unused colors from the Swatches Panel.

* The standard cyan swatch "C=100 M=0 Y=0 K=0" is still there (together with all colors in brackets you cannot remove).

So, if you remove this swatch, you have to substitute it with something else, let's say "[Black]" (by default).

Now copy/paste text from a different document to the document you removed "C=100 M=0 Y=0 K=0".

In the moment you paste the text, "C=100 M=0 Y=0 K=0" is back again.

Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 23, 2015 Jun 23, 2015

Copy link to clipboard

Copied

Another note on this.

What is not working:

Changing the default fill color of paragraph shading, if you are changing the defaults of your "Basic Paragraph Style" when no document is open to "None" and proceed.

You still have a swatch named "C=100 M=0 Y=0 K=0" that is in use. I suspect, that fill color "C=100 M=0 Y=0 K=0" is part of the "invisible" "No Paragraph Style" paragraph style. And "Basic Paragraph Style" is based on "No Paragraph Style".

Just tested this by scripting (ExtendScript/JavaScript) and can confirm my assumption.

One can address the "No Paragraph Style" by the index of 0 of the paragraph styles collection of the app (that means InDesign) like that:

app.paragraphStyles[0].paragraphShadingColor.name;

will return "C=100 M=0 Y=0 K=0".

And one cannot change this. Even by scripting.

Trying to assign "None" to the paragraph shading color property as value

app.paragraphStyles[0].paragraphShadingColor = "None";

will throw an error.

So "C=100 M=0 Y=0 K=0" will stay with us for a long time, I suspect 😉

Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 23, 2015 Jun 23, 2015

Copy link to clipboard

Copied

Thanks Uwe!

Just quite annoying...

For example:

If I have a document that will be printed in b/w (like a book inlay) – I like to remove all swatches so that I'm 100% sure that no text is still set in color.

Lars

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 23, 2015 Jun 23, 2015

Copy link to clipboard

Copied

Yes, I see this problem.

And it is not only about text. You do not know in advance, if "C=100 M=0 Y=0 K=0" is used or not on fills, strokes (or gradients) of any kind.

Just removing "C=100 M=0 Y=0 K=0" and substitute it with "[Black]" may result in an optical problem. Hm, instead of substitute it with pure black a better move would be to substitute it with a tint of black; but the percentage of that tint would vary depending of your printing method…

Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 23, 2015 Jun 23, 2015

Copy link to clipboard

Copied

Hands up all the InDesign users that have been longing for this new amazing feature...

/ L

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 14, 2015 Jul 14, 2015

Copy link to clipboard

Copied

What is not working:

Changing the default fill color of paragraph shading, if you are changing the defaults of your "Basic Paragraph Style" when no document is open to "None" and proceed.

You still have a swatch named "C=100 M=0 Y=0 K=0" that is in use. I suspect, that fill color "C=100 M=0 Y=0 K=0" is part of the "invisible" "No Paragraph Style" paragraph style. And "Basic Paragraph Style" is based on "No Paragraph Style".

I was able to stop the behavior by closing all documents, deleting all of the swatches except for the required [Black], [Paper], [Registration] and replacing with [Paper] when prompted. I then made my own default swatches. Now the Paragraph Shading default is paper for new documents and all of my swatches are selected on Select All Unused:

ScreenSnapz001.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 14, 2015 Jul 14, 2015

Copy link to clipboard

Copied

Example:

Add a new document.

Note that I closed all documents before deleting all of the non required swatches.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 14, 2015 Jul 14, 2015

Copy link to clipboard

Copied

Hi Rob,

yes, that is working, if you work on your own and do not bring any documents from outside into play.

Thank you for suggesting this!

Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 14, 2015 Jul 14, 2015

Copy link to clipboard

Copied

I can't get at 2015 at the moment but for incoming docs where the cyan swatch is sticky why not use your script to set the color to [Paper] instead of the "None" that throws the error? In that case the non required "C=100 M=0 Y=0 K=0" swatch should be unused assuming it isn't used elsewhere.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 14, 2015 Jul 14, 2015

Copy link to clipboard

Copied

Seems like Adobe fixed this – I just updated to the new version of InDesign (11.0.1.105) and the blue color isn't appearing any more when I paste a text in a document...

(Soon we will all be missing that blue little swatch.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2015 Jul 15, 2015

Copy link to clipboard

Copied

Hi Lars,

can you describe what's going on in more detail?

Yesterday I've updated InDesign to v11.0.1 and cannot confirm your finding.

Color "C=100 M=0 Y=0 K=0" is still added to a document, if I paste text from a fresh new doc to a document where I changed "C=100 M=0 Y=0 K=0" to "[Black] 20%".

Tested on Mac OSX 10.10.3.

What is your OS version?

Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2015 Jul 15, 2015

Copy link to clipboard

Copied

However with the help of Rob, I found out that exchanging the standard "[C=100 M=0 Y=0 K=0]" with "[Paper]" when no document is open and rebuilding a new "[C=100 M=0 Y=0 K=0]" afterwards to stay in synch with the behavior of InDesign CC-2014 will remove the problem for all new documents built from now on.

Opening older documents saved in v11.0.0 and older documents saved in v10.2 or below will still struggle with a "[C=100 M=0 Y=0 K=0]" that is tied to the fill color of paragraph shading of the "[No Paragraph Style]" style. But we could change this on an individual bases doc by doc as well.

@Rob – a note about the scripting side:
At least in ExtendScript I am not able to assign a different color to the paragraphShadingColor property of paragraphs[0], the "[No paragraphs style]". But what we can do is removing "[C=100 M=0 Y=0 K=0]" and exchanging that with "[Paper]" (or any other color I suppose) by using the scripting method remove(). This code in ExtendScript will work:

//For the active document:

app.documents[0].colors.itemByName("C=100 M=0 Y=0 K=0").remove(app.documents[0].colors.itemByName("Paper"));

//For the app, best used when no documents are open, setting a new default value:

app.colors.itemByName("C=100 M=0 Y=0 K=0").remove(app.documents[0].colors.itemByName("Paper"));

And afterwards one could add a new color named "[C=100 M=0 Y=0 K=0]" that falls in the category "Unused Color".

Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 22, 2016 Feb 22, 2016

Copy link to clipboard

Copied

Trying to assign "None" to the paragraph shading color property as value

app.paragraphStyles[0].paragraphShadingColor = "None"

will throw an error.

So "C=100 M=0 Y=0 K=0" will stay with us for a long time, I suspect 😉

@Rob – a note about the scripting side:

At least in ExtendScript I am not able to assign a different color to the paragraphShadingColor property of paragraphs[0], the "[No paragraphs style]".

Uwe, if you are still following, I looked at this again today and it's true that No Paragraph Style is read only, but there does seem to be a round about way to set its paragraph shading property.

Here is an annotated AppleScript, which sets No Paragraph Style's shading to [Paper]. If I run this on CC2015 with no doc's open it edits the normally read only [No Paragraph Style]. I'm sure you can translate to JS:

tell application "Adobe InDesign CC 2015"

 

    ----the default Paper swatch is item 3 or [2] in all swatches

    set p to object reference of item 3 of every swatch

 

    ----No Paragraph Style is item 1 or [0] in all paragraph styles

    set nopara to item 1 of all paragraph styles

 

    ----No Paragraph style's properties are read only so we can't set the paragraph shading color

    ----but we can get it, which by default is the cyan swatch.

    set c to object reference of paragraph shading color of nopara

 

    ----if we delete and replace No Paragraph Style's shading color with "Paper"

    ----we have changed the shading property of the read-only No Paragraph Style

    if name of c is not "Paper" then

        set cp to properties of c

        delete c replacing with p

     

        ----re makes the default cyan swatch

        make new color with properties cp

    end if

 

    ----set the application text default

    set paragraph shading color of text defaults to c

end tell

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 22, 2016 Feb 22, 2016

Copy link to clipboard

Copied

Hi Rob,

yes I'm still following, but will not to be able to test until tomorrow.
I'm too busy right now…
( And was knocked out a bit last week by the flu. )

Hi Andersson,

hm, tested with my German version of InDesign CC-2015.2 v11.2.0.99 on OSX 10.9.3.
And it worked there… The only thing I noticed—a side effect—was, that a new swatch "Schwarz" (German: "Black") was created, defined with 0 C, 0 M, 0 Y, 100 K.
Maybe that's a problem with an English version InDesign. I'll test again tomorrow.

Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 23, 2016 Feb 23, 2016

Copy link to clipboard

Copied

Ok, I'm using the Swedish version.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 23, 2016 Aug 23, 2016

Copy link to clipboard

Copied

rob day wrote:


Here is an annotated AppleScript, which sets No Paragraph Style's shading to [Paper]. If I run this on CC2015 with no doc's open it edits the normally read only [No Paragraph Style]. I'm sure you can translate to JS:

Hi Rob, I finally had time trying out your AppleScript on my German InDesign CC 2015.4.

Unfortunately it is throwing an error. Roughly translated from German:

AppleScript Error
Error number: 30477

Unexpected value for "paragraph shading color".

Swatch or string expected but recieved nothing.

Engine: Default

Nevertheless, after clicking the error message's OK button, the default shading has changed to "Paper".
A new swatch "C=100 M=0 Y=0 K=0" was added to the bottom of the list of swatches.

New documents will contain the new defaults. Old documents saved before running the script will keep the old defaults.
So if I copy text from an old document to a new one that was created after the script run, the default paragraph style [Basic Paragraph Style] will be changed. That change can be observed by the added +-sign after its name in the Paragraph Styles panel.

One could remove the +-sign by doing an click holding the alt key.

That's ok, I think.

Important note: Never assume that the order of colors in your Swatches panel is the order of colors everyone is seeing in their Swatches panel. For example, one could drag the swatch "[Paper]" to a different position, if no document is open.

See my version with ExtendScript that is trying to do the same. I do not rely on the order of swatches, but I'm identifying the swatch I want to use by its universal name. I would recommend using the color "Black" and a tint of 20% for the default color of paragraph shading.

The script will do nothing, if a document is open.
And the script's action can be undone in one go.

// ChangeTheDefaultColor-for-ParagraphShading-v2.jsx

// Uwe Laubender

/**

* @@@BUILDINFO@@@ ChangeTheDefaultColor-for-ParagraphShading-v2.jsx !Version! Tue Aug 23 2016 15:04:34 GMT+0200

*/

/*

    Changing the Default of inDesign with

    paragraphShading

   

    26. Re: Strange problem: Pasting text to InDesign CC2015 always adds cyan color

    Uwe Laubender | Feb 3, 2016

    https://forums.adobe.com/message/8457900#8457900

   

*/

app.scriptPreferences.userInteractionLevel = UserInteractionLevels.INTERACT_WITH_ALL;

app.doScript

    (

   

    main,

    ScriptLanguage.JAVASCRIPT,

    [],

    UndoModes.ENTIRE_SCRIPT,

    "Change The Default Color for Paragraph Shading | SCRIPT"

   

    );

function main()

{

    /* Section where you can change the color and the tint. */

   

    // Do not change the name to "[Black]" or "[Schwarz]" or "[Noir]" etc.pp.

    // Leave it at "Black" for UI-Color: "[Black]", "[Schwarz]" or "[Noir]" etc.pp.

   

    // Alternative: "Paper" for UI-Color: "[Paper]", "[Papier]" etc.pp.

   

    var newShadingColorName = "Black";

    //var newShadingColorName = "Paper";

   

    // If you want to get 100% assign the default value:

    // -1

    var newShadingTint = 20;

    //var newShadingTint = -1; // Gets you 100%

    /* End of section. */

   

   

    if(app.documents.length !=0)

    {

        alert("ERROR:"+"\r"+"Close All documents and try again!");

        return;

    }

    if(!app.textDefaults.hasOwnProperty("paragraphShadingColor"))

    {

        alert("ERROR:"+"\r"+"Paragraph shading seems not to be supported with your version of inDesign that is:"+"\r"+app.version);

    }

    // InDesign's defaults for paragraph shading are:

    // app.textDefaults.paragraphShadingColor.name = app.colors.itemByName("C=100 M=0 Y=0 K=0");

    // app.textDefaults.paragraphShadingTint = -1;

   

    // IMPORTANT NOTE: The name "C=100 M=0 Y=0 K=0" could be different in different locale versions of InDesign

    // It's good with InDesign German, English-International, US, English

    // It's NOT GOOD with e.g. InDesign French!!

   

    var oldShadingColor = app.textDefaults.paragraphShadingColor;

   

    var oldShadingColorName = oldShadingColor.name;

    var oldShadingColorValue = oldShadingColor.colorValue;

    var oldShadingColorModel = oldShadingColor.model;

    var oldShadingColorSpace = oldShadingColor.space;

    app.textDefaults.paragraphShadingColor = app.colors.itemByName(newShadingColorName);

    app.textDefaults.paragraphShadingTint = newShadingTint;

   

    app.paragraphStyles[1].paragraphShadingColor = app.colors.itemByName(newShadingColorName);

    app.paragraphStyles[1].paragraphShadingTint = newShadingTint;

   

    if(app.colors.itemByName(oldShadingColorName).isValid)

    {

        // Exchange shading color with new shading color:

        // If that's possible. If not end the function immediately.

        try

        {

            app.colors.itemByName(oldShadingColorName).remove(app.colors.itemByName(newShadingColorName));

        }catch(e)

        {

            return

        };

    };

       

    // Add the replaced color again.

    app.colors.add

    (

        {

            name : oldShadingColorName ,

            colorValue : oldShadingColorValue ,

            model : oldShadingColorModel ,

            space : oldShadingColorSpace

        }

    );

};

Thank you,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 23, 2016 Aug 23, 2016

Copy link to clipboard

Copied

Another issue I am seeing.


Even if my script ran successfully, copying some text from e.g. TextEdit App (no formatting) to InDesign will add the swatch "C=100 M=0 Y=0 K=0" again, if it was removed before. So "C=100 M=0 Y=0 K=0" seems to be somewhere else as "active". Even if it is not used. One could remove "C=100 M=0 Y=0 K=0" again without problem after copying the text from a different app.

This problem was mentioned in the German Adobe forum here:

InDesign erstellt Cyan-Farbfeld beim kopieren

("InDesign adds Cyan swatch when copying")

GrafikLVM | Sep 21, 2015

https://forums.adobe.com/thread/1959077

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 08, 2017 Jan 08, 2017

Copy link to clipboard

Copied

A workaround for the issue I see that unformatted text copied from e.g. TextEdit App through the clipboard will add the swatch "C=100 M=0 Y=0 K=0" is to enable "Paste Unformatted" in InDesign.

To do that:

1. Change InDesign's preferences for the clipboard to paste text to "All Information".

Do not use "Text only".

2. Use the now functional "Paste Unformatted" feature when pasting text.

Then "C=100 M=0 Y=0 K=0" is not added to the Swatches panel.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 15, 2015 Jul 15, 2015

Copy link to clipboard

Copied

Hi Uwe,

I use:
InDesign 11.0.1.105

OSX 10.10.4


Before I got the new update – every time I pasted text into a document it added the color 100% Cyan to my swatch library.

After updating to the new InDesign 11.0.1.105 yesterday, this doesn't happen any more. (Neither in an old or in a new/empty document.)



/ Lars








Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2015 Jul 15, 2015

Copy link to clipboard

Copied

Hi Lars,

hm – and I'm on OSX 10.10.3. Strange. And you pasted from a new InDesign document?
Did you remove "[C=100 M=0 Y=0 K=0]" and exchanged that with "[Paper]" as Rob suggested (no documents open)?

Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 15, 2015 Jul 15, 2015

Copy link to clipboard

Copied

Hi,

No. I usually don’t have any swatches in my new documents (I prefer to add only the colors I use for that document), so in a new document I only have: Black, Paper and Registration.

I don't think I changed anything, except just updating InDesign.


/ Lars

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2015 Jul 15, 2015

Copy link to clipboard

Copied

So you changed "C=100 M=0 Y=0 K=0" to something else before doing the update, right?

Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 15, 2015 Jul 15, 2015

Copy link to clipboard

Copied

Not really, since I always keep my preset document without any swatches (except Black, Paper and Registration) it was not in there.

Then I just upgraded and discovered that when I paste text in the new version the cyan color doesn't show up.

L

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 22, 2015 Sep 22, 2015

Copy link to clipboard

Copied

Hallo, kann ich Deutsch hier sprechen? 🙂

Hello, can i speake here in German? 🙂

Anyways... i realized also this bug (no feature!).

So you solved this problem with scripting?

i am a n00b with this, can you describe it?

and why the hell the consumer must solve this,

and not the company who gets our money??

you can describe it in german for better understanding 🙂

thank you! - Marco

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines