Strange problem: Pasting text to InDesign CC2015 always adds cyan color

Explorer ,
Jun 22, 2015 Jun 22, 2015

Copy link to clipboard

Copied

Every time I paste a text into any InDesign document in InDesign CC2015 – it also imports the color 100% cyan to my swatch library. (They text is still black though, and there is no background color or anything.)

Anyone knows why this happens?!?

Not a big deal but quite odd...

Views

11.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Jun 23, 2015 Jun 23, 2015

Another note on this.

What is not working:

Changing the default fill color of paragraph shading, if you are changing the defaults of your "Basic Paragraph Style" when no document is open to "None" and proceed.

You still have a swatch named "C=100 M=0 Y=0 K=0" that is in use. I suspect, that fill color "C=100 M=0 Y=0 K=0" is part of the "invisible" "No Paragraph Style" paragraph style. And "Basic Paragraph Style" is based on "No Paragraph Style".

Just tested this by scripting (ExtendScript/JavaScript

...

Likes

Translate

Translate
New Here ,
Oct 02, 2015 Oct 02, 2015

Copy link to clipboard

Copied

Hi all,

I have the same issue (I think), although I have the latest version of inDesign installed.

I have a document with custom swatches. At the moment I am replacing the English text with the German translation (that I have in a Word Document.). Everytime I paste a new section of the text to inDesign, it automatically adds a new version of one of my blue swatches (not the cyan that you had issues with). I didn't notice this in the beginning, but suddenly I had 110 versions of the same blue swatch, even though the text itself is black (both in Word and inDesign).

Does ayone know how to resolve this issue? It's not a big thing for me to delete the swatches since they aren't even used, but it's still a bit annoying that I have to do it...

/Lisa

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 02, 2015 Oct 02, 2015

Copy link to clipboard

Copied

Everytime I paste a new section of the text to inDesign, it automatically adds a new version of one of my blue swatches

I think this is a different issue and isn't related to the new paragraph shading feature the OP was having a problem with.

When you paste text or an object that uses a named swatch that already exists in the document; the Color Type, Color Mode and color values have to be identical otherwise a new swatch will be created with a numbered suffix. Try using Paste Without Formatting rather than Paste.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 05, 2015 Oct 05, 2015

Copy link to clipboard

Copied

Ah, true - yes, this is probably related to something else.

Unfortunately "paste without formatting" is not enabled 😕 But I suppose it has something to do with the original formatting and me first copying/pasting the English text from inDesign to Word, then pasting it back to the inDesign-document. Oh well Thank you anyway!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 05, 2015 Oct 05, 2015

Copy link to clipboard

Copied

I've never liked the default where a new color is created when there's a conflict, so I use this AppleScript (OSX only) and assign it Command-V. It will use the document's version of the named swatch and delete the incoming version.

--------------------------------------------------------------------------

--When pasting an object with a conflicting color swatch changes the incoming swatch to match the document swatch

tell application "Adobe InDesign CC 2014"

    set myDoc to active document

   

    --get the list of document swatches before the paste

    set currentColors to name of every swatch of myDoc

   

    paste

   

    --get a new list which would include duplicates

    set newColors to name of every swatch of myDoc

   

    --find the duplicates and merge with the original

    repeat with i from 1 to number of items in newColors

        set c to item i of newColors

       

        --the duplicate has a space + 2 added to its name so get its name minus 2 characters

        if c is not in currentColors then

            set mergename to characters 1 thru ((count of characters of c) - 2) of c as string

           

            --merge with the original swatch

            try

                merge swatch mergename of myDoc with swatch c of myDoc

            end try

        end if

    end repeat

end tell

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 05, 2015 Oct 05, 2015

Copy link to clipboard

Copied

Ah, unfortunately I'm on a PC (maybe we can blame the PC for messing things up?!)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 06, 2016 Jan 06, 2016

Copy link to clipboard

Copied

I am having a similar issue to this. I have a custom swatch that is duplicating every time I paste something in. So I end up with multiples of the same swatch colour. I can delete unused as suggested, but it's just annoying that I have to do this on a regular basis.

I have tried "zeroing out" the paragraph shading for my new docs and it "seems" to have solved this on new docs I create. However how can I remove this for existing documents? Any solutions?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 02, 2016 Feb 02, 2016

Copy link to clipboard

Copied

I am having the same issue. Would love to hear about any resolutions.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 03, 2016 Feb 03, 2016

Copy link to clipboard

Copied

Hi Carolyn,

I found yet another method by scripting to zeroing out the color "C=100 M=0 Y=0 K=0" by default.

It's written in ExtendScript (JavaScript), so this should work on Windows and Mac OSX as well:

Have no document open and execute the following script:

// ExtendScript script for InDesign CC 2015:

// When no document is open, you can change the default:

// Example to change the default of paragraph shading to 20% Black:

app.textDefaults.paragraphShadingColor = app.colors.itemByName("Black");

app.textDefaults.paragraphShadingTint = 20;

// After executing the script:

// If you add a NEW document, the "cyan" color will NOT be added to the document automatically.
// Instead 20% of Black is used as default for paragraph shading.

Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 22, 2016 Feb 22, 2016

Copy link to clipboard

Copied

The script is not working here. Mac OS X and InDesign 11.2.0.99.

I tried it and even restarted InDesign but no change.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 22, 2016 Feb 22, 2016

Copy link to clipboard

Copied

I am working on a 64 page brochure. Before going to print I like to check my document and delete unused colors. The clients design guidelines doesn't allow any cyan colors. I can't just assume "aha that's the paragraph shading color". The only way of knowing it's not used if it's not there anymore.

Why can't the default colors for InDesign be named like this:

Black

Paper

Paragraph shade (can also be cyan)

This would be followed by the default colors as before 100% Cyan, 100% Magenta etc

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 22, 2016 Feb 22, 2016

Copy link to clipboard

Copied

If you are not using paragraph shading at all, try this AppleScript (paste into Script Editor and run). It will set paragraph shading of all of the paragraphs and paragraph styles in the active doc to "Paper".

tell application "Adobe InDesign CC 2015"

    tell active document

        set p to item 3 of every swatch

      

        set pstyles to all paragraph styles

        repeat with i from 1 to number of items in pstyles

            try

                set paragraph shading color of item i of pstyles to p

            end try

        end repeat

      

        try

            set paragraph shading color of every paragraph of every story to p

        end try

        try

            set paragraph shading color of every paragraph of every cell of every table of every story of active document to p

        end try

    end tell

end tell

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 07, 2016 Jul 07, 2016

Copy link to clipboard

Copied

This all begs the question: Who on Earth was ever using or needing Paragraph Shading?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 07, 2016 Jul 07, 2016

Copy link to clipboard

Copied

simonflynn wrote:

This all begs the question: Who on Earth was ever using or needing Paragraph Shading?

This question can be asked for a lot of InDesign's features. Even for the very basic ones. Different needs for different tasks I'd say. And paragraph shading is helpful for long document creation and is simplifying the formatting of text without using text cells or anchored text frames for the same purpose.

I must admit that it could be even more helpful, if strokes and corner effects were added and if paragraphs holding tables aren't ignored.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 25, 2017 Aug 25, 2017

Copy link to clipboard

Copied

So, has this actually been resolved?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 26, 2017 Aug 26, 2017

Copy link to clipboard

Copied

Nothing has changed in this regards…

Best,

Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 07, 2018 Apr 07, 2018

Copy link to clipboard

Copied

No it has not been fixed in 2018, have tried with a new doc, no cyan, changed paragraph shading to none, then paper, then black - cyan comes back when any text is pasted (not from another Indesign doc, from Powerpoint, Acrobat, etc).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 07, 2018 Apr 07, 2018

Copy link to clipboard

Copied

Hi,

Can you please elaborate a little more on the steps? or maybe attach a video link demonstrating the issue?

You can also mail me the video at amaarora@adobe.com

-Aman

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 07, 2018 Apr 07, 2018

Copy link to clipboard

Copied

I'll be happy to, will be out rest of the day but will email you steps by Monday. Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 08, 2018 Apr 08, 2018

Copy link to clipboard

Copied

denised  wrote

No it has not been fixed in 2018, have tried with a new doc, no cyan, changed paragraph shading to none, then paper, then black - cyan comes back when any text is pasted (not from another Indesign doc, from Powerpoint, Acrobat, etc).

Did you make that change in the Paragraph panel or in the Paragraph Styles panel to the Basic Paragraph Style?

have you tried resetting your prefs?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 08, 2018 Apr 08, 2018

Copy link to clipboard

Copied

I made sure the default basic paragraph shading was black (2018 default). Also tried making it white or none through Paragraph style settings. It's a new doc so I wouldn't pick up any left overs from earlier versions. No other paragraph styles but the default. Copied and pasted text from an AcrobatPro pdf into a new text box and the cyan swatch appeared. The paragraph shading does not change but I get the swatch.Also had the problem with pasting from Powerpoint. Will investigate further in case there are settings in the pdf or PPT that are copying with the text. Thanks for checking back.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 08, 2018 Apr 08, 2018

Copy link to clipboard

Copied

denised  wrote

… cyan comes back when any text is pasted (not from another Indesign doc, from Powerpoint, Acrobat, etc).

Can you elaborate on this a bit more?

Do you say: You copy/paste text from e.g. PowerPoint and suddenly Cyan is back?
Just tested this with InDesign CC2018.1 on my Mac. True. I can see this as well. Just copy/pasted text from a text-only file of TextEdit app to InDesign. However the definition for paragraph shading—20% [Black] by default—will not change.

Note: In my case it was not "C=100 M=0 Y=0 K=0", but "C=0 M=100 Y=0 K=0" because I think ( I'm not sure, have to investigate this! ) at one point I changed app.textDefaults.paragraphShadingColor by scripting for testing reasons to "C=0 M=100 Y=0 K=0". The strange thing with this: I did that in CC 2017 and not in CC 2018, but maybe CC 2018 inherited this definition from CC 2017after installing.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 08, 2018 Apr 08, 2018

Copy link to clipboard

Copied

Just tested this with InDesign CC2018.1 on my Mac. True. I can see this as well. Just copy/pasted text from a text-only file of TextEdit app to InDesign. However the definition for paragraph shading—20% [Black] by default—will not change.

Hi Uwe, I am not seeing that here pasting from either TextEdit or Text Wrangler.

Screen Shot 21.png

Have you cleared your Prefs and Caches since updating to 2018.1? I hadn't installed 2018 on my production machine until recently, so my upgrade was from 2014 to 2018 and that might be the difference.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 08, 2018 Apr 08, 2018

Copy link to clipboard

Copied

Hi Rob,

good thought to clean Prefs and Caches. And no, I did not do that. On the contrary, I installed so that old workspaces and other prefs would come along from CC 2017 automatically. And perhaps earlier?! Why do I say earlier? Because after installing CC 2018 I had workspaces from CC 2015 as well.

Hm. Maybe I should clean Prefs and Caches and also do a reinstall as well?

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 08, 2018 Apr 08, 2018

Copy link to clipboard

Copied

Ah yes, just checked my installation of InDesign CC 2017.1:

The "No Paragraph Style" style of a new document is showing this:

app.documents[0].paragraphStyles[0].paragraphShadingColor.name is indeed "C=0 M=100 Y=0 K=0".

And the CC 2018 installation obviously migrated that.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 09, 2018 Apr 09, 2018

Copy link to clipboard

Copied

Right, it's been awhile, but wasn't the problem with the normally uneditable [No Paragraph Style], which everything is based on, using cyan? Your script's paragraphStyles[0]. I would think everyone who upgraded from 2015 might have to clean their migrated prefs in order to get the change to [Black]?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines