• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Text outside cropped embedded document still visible via selection in exported PDF

New Here ,
Mar 28, 2017 Mar 28, 2017

Copy link to clipboard

Copied

In our pricelist we use placed/embedded PDF documents.
For non excisting customers we want to make a version without prices.

For that I crop the frame of the embedded document, so the last columns dissappear.

But, after exporting the design to a .PDF file,
the cropped text is still (invisible) in the document.
When selecting, the text seems to appear and can be pasted in word to read it.

I tried all kinds of tricks and export options. various layers, placing blocks or images over the frame,
but text keeps excisting below it and selectable.
It's really annoying me, I hope someone has a solutions for this issue.

See screenshot:

https://www.eurocold.nl/wp-content/uploads/2017/03/indesign-prijsloosissue.png   (high res version)

indesign-prijsloosissue.png

Views

2.4K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Mar 28, 2017 Mar 28, 2017

Copy link to clipboard

Copied

Hi ralf

As far as I know, there's no way to completely get rid of cropped pdf part, non-printing or non-showing layers...

Even if you outline your PDF (which is probably NOT what you want to do, and you're right), you could retrieve the hidden vector using Illustrator. Only a raster image could be downsampled. But again, this is probably not what you want to do...

That said, I don't have a magic solution for you. Meaning fast and easy.

My advice would be to recreate your tables in Indesign and use Conditional Text.

Unselected conditional text definitely can't be retrieved...

Problem here are colored cells background that you probably want to hide too.

If you just want to hide the text and can live with the remaining background color, well... that would be easy then.

If not, here's a workaround using 4 paragraph styles instead of a table:

"header 1" > next style: "header 2" > next style "line1" > next style "line2" (next style "line1")

Forcing "apply next style" would make things quite easy.

Each style has a paragraph rule set as for a background color, length set to text.

Then use Conditional text to show/hide the prices "columns".

See example below (see the red waves under invisible text):

tableau.gif

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 29, 2017 Mar 29, 2017

Copy link to clipboard

Copied

Hi Vinny,

thank you very much for your detailed answer,

but I think this is not an option for us.

The thing is: we extract these PDF files from our ERP system,
so that we can easily update the pricelist when needed...
It's to time consuming to recreate the tables in InDesign.

I think my best option is to extract PDF files without prices from our ERP,
en then make a second InDesign file with the PDF's without prices embedded.

It's a pitty, I would be a lot more easier if I could simply crop the frame... .


Possible solution: (?)

When I run my generated PDF from indesign through a freeware PDF compressor,
It makes images of my tables (so non-selectable text) and then the "invisible" text dissappeared too.


But, the freeware program ruins my quality and even makes the file size bigger.
Is there such an option in indesign to create images of the embedded tables? Of do you know a good PDF convertor/compressor to "image" the tables in my created PDF? 

Br, Ralf

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Mar 29, 2017 Mar 29, 2017

Copy link to clipboard

Copied

Apologies, I was going to try and answer this yesterday but I have a few thoughts...

Can you tell me what the frame properties are in InDesign for the PDF's being placed?

I'm wondering if they are assigned as graphic frames > the thought being that perhaps this tells InDesign on export to rasterize and flatten the PDF to an image.

2017-03-29_09-11-41.png

Also while we are on the subject... have you tried using Object Export Options...?

I noticed this:

2017-03-29_09-25-42.png

IF THIS does work... I Imagine you should be able to set up an Object Style with the Object Export Options... but I will look into this.

Otherwise I would say you could try using redactions in the original PDF's using Acrobat... If you then sanitise the document - or delete the price part of the table essentially - you definitely shouldn't get this ghosting invisibly anymore.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 29, 2017 Mar 29, 2017

Copy link to clipboard

Copied

https://forums.adobe.com/people/Ralf+1981  wrote

Possible solution: (?)

When I run my generated PDF from indesign through a freeware PDF compressor,
It makes images of my tables (so non-selectable text) and then the "invisible" text dissappeared too.


But, the freeware program ruins my quality and even makes the file size bigger.
Is there such an option in indesign to create images of the embedded tables? Of do you know a good PDF convertor/compressor to "image" the tables in my created PDF? 

There is, but then you would do the exact same thing, only inside InDesign. So the quality would still be worse than plain text, and the file would still be larger. (Draw a transparent frame on top of the table and export to a PDF version that does not support live transparency.)

Other than on plain bitmap data, InDesign cannot crop or delete vector files. There are just too many possible things that can go wrong, with different types of coordinate systems, clipping masks, and objects that would need being broken up.

The best way is to just not export these columns to PDF. Second best -- marginally, as you need to do so by hand -- would be to use Acrobat Pro to physically delete the columns in the PDF before placing them.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Mar 29, 2017 Mar 29, 2017

Copy link to clipboard

Copied

Hi Vinny,

Redaction/sanitising in Acrobat DC etc will permanently delete content/hide it regardless of cropping etc.

[UPDATE] Nope it definitely deletes it FOREVER!!

Best,

EW

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 18, 2019 Apr 18, 2019

Copy link to clipboard

Copied

I had an identical problem and after many attempts I came to the solution that suited for me. I exported the file from InDesign as EPS! Such a document can be opened in the illustrator and saved as a PDF or via Adobe Distiller converted to PDF.

See Screenshots:

Screenshot 1.png

Screenshot 2.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 27, 2023 Feb 27, 2023

Copy link to clipboard

Copied

LATEST

Great suggestion, your solution worked for me. I soon found another option using Adobe Acrobat. 

The Redact "Sanitize Document" tool in Adobe Acrobat has the ability to remove invisible text. 

default6ar1u82phfxv_0-1677532139852.png

 

Click this tool

 

default6ar1u82phfxv_1-1677532139853.png

 

Use “Selectively remove”

default6ar1u82phfxv_2-1677532162862.png

Unselect everything except “hidden text”

 

Run then save as a new document. 

 

Hope this helps someone else. This was helpful for us in making PDFs accessible. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines