• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Thin White Line Between Table Cells with No Stroke

Participant ,
May 03, 2024 May 03, 2024

Copy link to clipboard

Copied

Hello. I'm creating a table and inserting a graphic into a cell next to a cell that is the same color as the graphic to create an arrow. But even though I've removed the stroke width on both sides, you can still see a thin white line between them. Is there any way to eliminate this? See attachment.

Thank you 🙂

TOPICS
How to

Views

131

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 03, 2024 May 03, 2024

Copy link to clipboard

Copied

Does the line still show when you export to PDF (or JPG, if you're doing this for digital view)? Sometimes these fine artifacts in the layout disappear when exported.

 

ETA: I just did some quick and dirty tests and that's exactly what I am seeing. The faint line is just a screen/layout artifact and does not appear on export. Throwing a cell border of the same color on the solid cell just moves that line over a little, so I'm not sure there's any easy way to get rid of it even if it's just a visual distraction. (ETA2: And the various overprint/stroke control options do nothing useful, either. I don't think ID knows it has this line showing. 🙂 )


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 03, 2024 May 03, 2024

Copy link to clipboard

Copied

Yes. The line is still there in the pdf.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 03, 2024 May 03, 2024

Copy link to clipboard

Copied

Ugh. Well, check all of Barb's suggestions to make sure the space between cells is truly 0 (and None color might help).

 

Also try shifting the graphic a bit left in its frame  — it may have a faint outline from some scaling or other process step.

 

A graphic line laid over the seam makes it disappear, but that's a complete hack.


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 03, 2024 May 03, 2024

Copy link to clipboard

Copied

Hi @Kathy5FFA:

 

A couple of things to try:

 

  1. Make sure the vertical interior line in the proxy is selected as you set the width to zero
  2. Make sure the image is fully against the edge of the frame. You could move the graphc, resize the graphic, or you could resize the column width.

 

~Barb

 

2024-05-03_09-56-04 (1).gif

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 03, 2024 May 03, 2024

Copy link to clipboard

Copied

None of the above, for me. I emptied the bag of tricks and still see that faint seam, but as noted, it doesn't export.

 

It seems to disappear in Presentation mode, not that that's helpful.


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 03, 2024 May 03, 2024

Copy link to clipboard

Copied

Here is the same (quickly drawn, wonky) shape exported and viewed in  Adobe Acrobat at 400% magnification. I don't see it. Do you, James?

 

~Barb

 

EDIT: Sorry. You said it didn't export. 2024-05-03_09-59-44.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 03, 2024 May 03, 2024

Copy link to clipboard

Copied

As a shape, no. But the problem seems to be the seaming/blending between a filled cell and a cell with a graphic. With the table set to zero/none all around, I see the seam on the screen but not in any export. I'd say it's a system variation, but if the OP is seeing it in the PDF, there's something still unresolved. (I am betting on a halo around the triangle graphic.)


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 03, 2024 May 03, 2024

Copy link to clipboard

Copied

Wow. I'm a nightmare today! Totally missed the sentence about it being a filled cell.

 

Once again, I keystroked it with the filled cell and I'm getting the same result—I am not seeing any sort of a line so yes, assuming the vertical lines are actually set to 0 and the triangle is flush with the left side of its cell, let's look at the triangle graphic. Can you share it with us, @Kathy5FFA?

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 03, 2024 May 03, 2024

Copy link to clipboard

Copied

It's the weather. I'm staring out there more than at this dreary screen. 🙂


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 03, 2024 May 03, 2024

Copy link to clipboard

Copied

None of the above worked for me, but I did solve it on my own. Since the graphic is anchored in the cell, in the Anchor settings, I set the X Offset to -0.001 and that moved it over enough to remove the line. Thanks to all who responded!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 03, 2024 May 03, 2024

Copy link to clipboard

Copied

Ah, you didn't say it was anchored. That brings another layer of settings and adjustments into play.

 

And that said, there's no good reason to anchor it. Putting it in a cell is as anchored as an item gets, pretty much. The only reason to anchor graphics is to make them move with text (which the table/cell already does, here) and to lock them in place for things like EPUB export. Not adding the complication is sometimes the wiser choice. 🙂


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 03, 2024 May 03, 2024

Copy link to clipboard

Copied

I don't know how to put it in a cell without anchoring. I copied the graphic and pasted it inside the cell which automatically anchors it. How would I get it in the cell another way?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 03, 2024 May 03, 2024

Copy link to clipboard

Copied

...you're right. I wasn't looking at the same thing. But I will back up to my contention that the problem is a slight flaw in the graphic, that it has a few pixels of "halo" around it, which nudging it over in the frame obscures. So all good, no matter which mysterious icon we're not looking at. 🙂

 

You can/should set an Object Style for these frames so you can tweak them as a group. Manually bumping each graphic is sure to lead to mistakes and (more) frustration.


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 03, 2024 May 03, 2024

Copy link to clipboard

Copied

Yes, I did set the style for it. Thanks so much for your help.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 03, 2024 May 03, 2024

Copy link to clipboard

Copied

Kathy:

 

One quick clarification that may be helpful. There are two ways to add a graphic to a table in InDesign. If you have an insertion point when you place it, it will come in as an inline graphic, which means it is anchored.

 

The alternative is to simply load the graphic with File > Place, and place it directly over the cell. This forces InDesign to create a graphic frame. It will not be anchored—it's just in a frame that is perfectly-sized to the cell. 

 

~Barb

 

2024-05-03_10-49-20 (1).gif

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 03, 2024 May 03, 2024

Copy link to clipboard

Copied

Thanks so much Barb for the detailed answers!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 03, 2024 May 03, 2024

Copy link to clipboard

Copied

LATEST

We are always happy to help, Kathy. Come back whenever you have a question. 

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines