Threaded text — InDesign adds blank frames I cannot delete

New Here ,
Feb 22, 2022 Feb 22, 2022

Copy link to clipboard

Copied

I am setting a lengthy book with text flow in each chapter. Sometimes when I make a change that causes text to reflow, InDesign adds a blank frame — like this:

Screen Shot 2022-02-22 at 10.50.56 AM.png

 The text flows right on to the frame FOLLOWING the blank one: 

Screen Shot 2022-02-22 at 10.51.58 AM.png

The text in the frame before the blank one ends in "'door'" and the beginning of the next frame ends in "over" — there is nothing in between. I tried deleting the empty frame (select it with selection tool, choose Type tool, command + select + delete), but when I do this, InDesign adds ANOTHER empty frame to the thread that isn't holding text. The opposite of what it should do. I don't know how to get rid of these extra frames. Can anyone help?

TOPICS
How to

Views

77

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Community Professional , Feb 22, 2022 Feb 22, 2022

Likes

Translate

Translate
Adobe Community Professional , Feb 22, 2022 Feb 22, 2022
This is a known problem in InDesign, one of several recomposition problems, especially, as in your case, with footnotes. It's often also, as Eugene mentioned, related to InDesign's inability to honour its Keep settings. Do you use the latest version of InDesign? Anyway, the only way to deal with this is to force the frame or the story to recompose. The gentle way is to press Ctrl+Alt+/ (or its Mac equivalent). If that doesn't work, a more cavalier method is to resize the empty frame by a whisker...

Likes

Translate

Translate
Adobe Community Professional ,
Feb 22, 2022 Feb 22, 2022

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 22, 2022 Feb 22, 2022

Copy link to clipboard

Copied

This is a known problem in InDesign, one of several recomposition problems, especially, as in your case, with footnotes. It's often also, as Eugene mentioned, related to InDesign's inability to honour its Keep settings. Do you use the latest version of InDesign?

Anyway, the only way to deal with this is to force the frame or the story to recompose. The gentle way is to press Ctrl+Alt+/ (or its Mac equivalent). If that doesn't work, a more cavalier method is to resize the empty frame by a whisker.

Please join the crowd at https://indesign.uservoice.com and support the resolution of the problem.

P.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 02, 2022 Mar 02, 2022

Copy link to clipboard

Copied

LATEST

Thanks, everyone! These suggestions solved the problem, and I'm keeping them on file in case it crops up in the future.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines