• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

type a hyphen but get an underscore

Community Beginner ,
Apr 11, 2024 Apr 11, 2024

Copy link to clipboard

Copied

Windows 10.  New InDesign user. Doing something wrong.

I am trying to get "15 - 2". If I use the keyboard key, I get 15_2, regardless whether I hold the shift key or not. If I try inserting em dash or en dash I still get 15_2. Tried in Arial font, Times New Roman and Calibri., all with same problem. 

The 15 and the 2 are hi-lited in yellow. Perhaps a clue. Tried kerning, characters moved, but the yellow hi-lite remained.

First happened when inserting page number. I've deleted the text box and started over just typing 15-2 without having the page number automatically inserted. Also tried em dash and en dash again. No change.

 

Raymond26965993n8ct_0-1712880176298.png

 

 

TOPICS
How to , Type

Views

148

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Apr 12, 2024 Apr 12, 2024
quote

[...]

Now my problem is finding that setting and unchecking it. I don't see it in document settings. I think it was somewhere that handles glyph replacement.


By @Raymond26965993n8ct

 

Check GREP styles and Nested Styles in the [Basic Paragraph] style.

 

It's possible, that you somehow managed to change definition of [No Paragraph Style] - but this one you won't be able to edit from the UI...

 

Votes

Translate

Translate
Community Beginner ,
Apr 11, 2024 Apr 11, 2024

Copy link to clipboard

Copied

More poking around. Turns out the hyphen is not the problem. The problem is the numbers are acting like superscripts or something. Any numbers I type anywhere, in any text frame, with this paragraph style or others, look like they are superscripts. This is clearly self inflicted. Trying to change this with the superscript or subscript options using the tool sabove the ruler has no effect. I've been through the paragraph settings a few times now, can't find anything related to number settings. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 11, 2024 Apr 11, 2024

Copy link to clipboard

Copied

The yellow background is yours?

 

What CharStyle is applied? What do you have in OpenType Features options in the ParaStyle?

GREP Styles? Drop Caps and NestedStyles?

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 11, 2024 Apr 11, 2024

Copy link to clipboard

Copied

All this, and I'd wonder about the font you're using. Does this all stop if you switch to a vanilla font like Minion?

 

Does it happen in all docs, including new ones? Or just this one? If the latter, the doc is probably corrupted.

 

This wouldn't happen to be a.... template, would it?


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 11, 2024 Apr 11, 2024

Copy link to clipboard

Copied

quote

All this, and I'd wonder about the font you're using. Does this all stop if you switch to a vanilla font like Minion?

[...]


By @James Gifford—NitroPress

 

Right - there is Times New Roman "active" but no text is selected - so James is right - what font are you using @Raymond26965993n8ct ? It's possible that digits are like that - Superscripted - by design in this font.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 12, 2024 Apr 12, 2024

Copy link to clipboard

Copied

Thanks for the help. It is font independent. Through trial and error (and recall) I see I have configured numbers for fractions as a document setting. So if after the 15 I type /32 I get a very nice fraction of 15/32 where the 32 fills in the lower half of the fraction. So the 15 is reduced in size and elevated to make room for the denominator of the fraction. Unexpectedly, this is applied to any number, typed in any frame throughout the document.

Now my problem is finding that setting and unchecking it. I don't see it in document settings. I think it was somewhere that handles glyph replacement.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 12, 2024 Apr 12, 2024

Copy link to clipboard

Copied

quote

[...]

Now my problem is finding that setting and unchecking it. I don't see it in document settings. I think it was somewhere that handles glyph replacement.


By @Raymond26965993n8ct

 

Check GREP styles and Nested Styles in the [Basic Paragraph] style.

 

It's possible, that you somehow managed to change definition of [No Paragraph Style] - but this one you won't be able to edit from the UI...

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 12, 2024 Apr 12, 2024

Copy link to clipboard

Copied

LATEST

As Robert T noted, this is (almost) unquestionably a GREP Style in play. InDesign has no "autocorrect" like Word that changes typed sequences into fractions, superscript TH and RD's, etc. The only functions that change text from what is typed in are GREP and Line Styles.

 

So check your relevant styles, under the GREP Styles pane, and remove any style definitions there. You may have to work back through the chain of "Based On" styles to find the definition in the hierarchy. (It's unlikely, but also check the Line Styles pane in each.)


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines