Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Weird '+' appears under Khmer, how to fix this?

Explorer ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

Khmer problem.JPG

As you can see in the screenshot, '+' appears under the text and it isn't supposed to be there. In Photoshop I was able to fix this through by switching the text option from Eastern Asia to Middle East. In Indesign I cannot find that option. I tried using 'International Adobe Composer' but that does't solve it either. 

The other threads I found in this forum didn't help me further. 
Does anyone have a solution???

TOPICS
How to, Type

Views

572

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , May 10, 2021 May 10, 2021
Hi YviGeese, does the Glyph panel show that + as well? First select any of the "characters" with the + and open the Glyph panel. I wonder, if you need to enable the "Harfbuzz" feature to get the right glyph rendering. There is no control in the GUI for this, no checkmark in any of the preferences dialogs. Instead you have to run a little ExtendScript (JavaScript) script to enable the feature. Script for enabling Harfbuzz workflow in InDesign Sheena Kaul, Adobe Employee , Jul 17, 2020 https://community.adobe.com/t5/indesign/script-for-enabling-harfbuzz-workflow-in-indesign/m-p/112951......

Likes

Translate

Translate
Adobe Community Professional ,
May 09, 2021 May 09, 2021

Copy link to clipboard

Copied

Hey 

 

Why not try the World Ready Composer and other text tips here

https://helpx.adobe.com/uk/indesign/using/arabic-hebrew.html

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

Thank you, tried this but didn't solve my problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

I've requested additional support for ME native user. 

Thanks for the feedback. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

Hi YviGeese,

does the Glyph panel show that + as well?

First select any of the "characters" with the + and open the Glyph panel.

 

I wonder, if you need to enable the "Harfbuzz" feature to get the right glyph rendering.

 

There is no control in the GUI for this, no checkmark in any of the preferences dialogs. Instead you have to run a little ExtendScript (JavaScript) script to enable the feature.

 

Script for enabling Harfbuzz workflow in InDesign
Sheena Kaul, Adobe Employee , Jul 17, 2020

https://community.adobe.com/t5/indesign/script-for-enabling-harfbuzz-workflow-in-indesign/m-p/112951...

 

What is harfbuzz? Yo may find some answers here:

https://harfbuzz.github.io/

 

Also see this little article:

What’s New in InDesign 2019–2020
December 10, 2019

2020
Support for South-East Asian languages

https://pubassist.paratext.org/2019/12/10/whats-new-in-indesign-2019-2020/

 

Regards,
Uwe Laubender

( ACP )

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

It does indeed not show in the glyph panel.

The selected language is Battambang which I'm using on request of our Cambodian partner. Was using Khmer but that didn't look right to them. Mind that I cannot read it myself at all but we translated our online courses to Khmer and I enter everything on the website including all the pictures we used. They themselves lack the PS/ID etc. skills. So that's an extra handicap. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

Hm.

What is the applied value for language on the text?

It should be Khmer (Cambodia).

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

OK, this is weird ... I manually replaced the characters with a + under them with the glyph sign, the + was still visible but then I did the International Adobe Alinea Composer again and most +-es disappeared and the ones that didn't were gone after adjusting the indentation of the margin on the right so the character went to the next line. So it seems to be solved even though in a somewhat unconventional way. I'm going to work with this, send it to Cambodia and see if it's really fixed.

 

Thank you for thinking along!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

How did you access Battambang as language for the texts?

 

I cannot see it in the standard set of languages in my German InDesign.

Khmer (Cambodian) is available, Battambang is not:

Khmer-LanguageAvailable-Battambang-is-not-2021.png

 

And yes the "Adobe World-Ready Single-line Composer" or the "Adobe World-Ready Composer" is necessary.

Here in my German InDesign with the Paragraph panel:

AdobeWorldReadyParagraphComposer-ParagraphPanel.png

What was the setting for the composer before?

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

LATEST

Hallo Uwe, Ich hatte die Schriftart installiert, usere Kambodschanischer partner hat uns das geschickt. 

Und die 'Composer' war Adobe-Absatzsetzer und jetzt habe ik die Globaler Adobe-Afsatzsetzer gebraucht. Aber was hat mich überrascht war das dies keine Wirkung hatte, befor ich die Zeichen geändert habe dürch die Glyph panel. 

And in English because I'm not too confident about my German and others should be able to read this too.

 

Our Cambodian partner sent me the Battambang font. The composer was originally set on Adobe paragraph composer (3rd on the list), after that I used the International paragraph composer (2nd on the list). What surprised me was that I needed to change the characters manually through the Glyph panel in order for it to work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines