Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


When column "span all" is used, an unintended "space after" is created between that graf and next

Community Beginner ,
Aug 04, 2021 Aug 04, 2021

Copy link to clipboard

Copied

InDesign 16.3.2 on an iMac with OS 10.15.7

 

When I set my headline to span all columns, it adds a space after that I don't want. (And isn't actually added in the style itself, it is just making a space.) I know there is a pretty simple workaround, but wondering if anyone else has had this happen or if I am just missing somethin obvious. Thanks for any help!

TOPICS
Bug, Type

Views

48

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 3 Correct answers

Adobe Community Professional , Aug 04, 2021 Aug 04, 2021
I think this is what you are talking about, see below:    

Likes

Translate

Translate
Adobe Community Professional , Aug 04, 2021 Aug 04, 2021
Hi @kateb75582932: I would look for the following things: Are there one or returns after the head? (Enable Type > Show Hidden Characters. Look for one or more ¶s.) Is there a space after value defined under the head? (Click on head and look for any value other than 0.) Is there space defined by the span? (Alt/Opt+ click the Span Columns icon and check the Space After Span value.) ~Barb

Likes

Translate

Translate
Community Beginner , Aug 04, 2021 Aug 04, 2021
Hi Barb,Thanks for your reply. No, it is none of the usual things, when I uncheck span all columns it takes the extra space away without my having to do anything else. --Kate

Likes

Translate

Translate
Adobe Community Professional ,
Aug 04, 2021 Aug 04, 2021

Copy link to clipboard

Copied

I think this is what you are talking about, see below:

 

Screen Shot 2021-08-04 at 6.10.49 PM.png

 

Screen Shot 2021-08-04 at 6.11.40 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 04, 2021 Aug 04, 2021

Copy link to clipboard

Copied

Thank you! I have never seen that before, so good to know! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 04, 2021 Aug 04, 2021

Copy link to clipboard

Copied

Hi @kateb75582932:

 

I would look for the following things:

  1. Are there one or returns after the head? (Enable Type > Show Hidden Characters. Look for one or more ¶s.)
  2. Is there a space after value defined under the head? (Click on head and look for any value other than 0.)
    space after.png
  3. Is there space defined by the span? (Alt/Opt+ click the Span Columns icon and check the Space After Span value.)
    span.png

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 04, 2021 Aug 04, 2021

Copy link to clipboard

Copied

Hi Barb,

Thanks for your reply. No, it is none of the usual things, when I uncheck span all columns it takes the extra space away without my having to do anything else. --Kate

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 04, 2021 Aug 04, 2021

Copy link to clipboard

Copied

Whoops, yes, it was in the span cols box! Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 06, 2021 Aug 06, 2021

Copy link to clipboard

Copied

LATEST

Also: you have your layout set to Snap to Baseline, which works fine for the body text, but your CH style has leading that doesn't conform to that in any logical way, so even after setting your Space After Span to "0p0", you still will get differing space depending on how many lines your heads are. I suggest turning that off if you don't really need it.

Now if you DO want a bit of space after your headlines, just add it where you normally would: In Indents and Spacing > Space After.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines