• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

when I use "span footnote across columns" the file became very slow

Community Beginner ,
Jul 09, 2017 Jul 09, 2017

Copy link to clipboard

Copied

I am using Indesign CC 2017: when I use "span footnote across columns" the file became very slow when I make any editing.

Can anybody help me?

Views

1.8K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 09, 2017 Jul 09, 2017

Copy link to clipboard

Copied

InDesign is just slow when spanning footnotes, and at other times as well. Here are some general things you can try in order to speed up InDesign:

  • Preferences > Display Performance. Set the Default View to Typical.
  • Click the down arrow next to the preflight button and turn off preflight while working on the document. Preflight can significantly slow InDesign. Be sure to turn it back on again before finishing up your document to make sure there are no preflight errors.

  • Preferences > Interface. Turn off Live Screen Drawing.
  • In the Hyperlinks panel, turn off 'Auto Update URL Status'
  • If you have lots of page, in the Pages panel menu, select Panel Options and deselect the Show Thumbnails.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 09, 2017 Jul 09, 2017

Copy link to clipboard

Copied

Thank you for your reply, but the problem still exists

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 09, 2017 Jul 09, 2017

Copy link to clipboard

Copied

I don't have further suggestions unless I could examine the problem file. It can slow InDesign if there are lots of separate pieces -- multiple text frames and so forth. Usually those can be combined and made more efficient.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 09, 2017 Jul 09, 2017

Copy link to clipboard

Copied

It might also help if you could provide more information about the project. How many pages are being justified at the same time? What are the specs of your system? When there's a lot of computation a faster processor, and more RAM will definitely speed it up.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 09, 2017 Jul 09, 2017

Copy link to clipboard

Copied

Hi,

There is no specific reason why spanning footnotes should cause the problem.

In addition to what Barbara said, you can start with cleaning your cache and preferences Troubleshooting 101: Replace, or "trash" your InDesign preferences

Another important step you can try is to upgrade your InDesign from CC 2017.0 to the latest which is CC 2017.1 It includes fixes related to bugs that can cause InDesign to be slow.

If still your problem persists and if its fine, you can mail me your document at amaarora@adobe.com so that I too can look into the issue and suggest a possible workaround, if one exists.

-Aman

amaarora@adobe.com

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 09, 2017 Jul 09, 2017

Copy link to clipboard

Copied

In agreement, as Aman suggested, replacing Preferences can sometimes help -- and definitely upgrade to the newest version of InDesign if you've not already done that.

Another thing that could slow InDesign is if you have lots of images that have been copied or embedded into the document rather than linked. Check your Links panel to see if that is the case. If an image is embedded it will have a little badge as shown in the screen capture.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Valorous Hero ,
Jul 09, 2017 Jul 09, 2017

Copy link to clipboard

Copied

hbmcfhsh31443093  wrote

I am using Indesign CC 2017: when I use "span footnote across columns" the file became very slow when I make any editing.

Can anybody help me?

InDesign becomes very slow when using any of the "spanning" features, not just footnote spanning. It's been that way since the span features were introduced.

Suggestions:

1. Don't use "balance columns" until you absolutely have to.

2. Divide a very long story into separate shorter stories (i.e., don't have a single story for an entire 100+ page book; instead, divide the book into chapters, one story per chapter [but avoid using InDesign's "book feature" unless you really have to).

3. Consider not using the "span footnotes" feature until you really have to. That is, do as much designing and typesetting as you can without spanning footnotes, and only as a last stage switch on that feature and make the necessary adjustments.

Meanwhile, Adobe may want to consider some serious optimization of these features.

(And if your only symptom is InDesign slowdown when using "span footnotes," I wouldn't bother trashing your prefs, as it's unlikely to make any difference.)

Ariel

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 10, 2017 Jul 10, 2017

Copy link to clipboard

Copied

Dear All,

Thank you very much for responding to my issue

Below is the link to download the file, note that I have done more than one file and the same problem exists ..

Greetings

https://we.tl/rPj8563RaC

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 10, 2017 Jul 10, 2017

Copy link to clipboard

Copied

I can confirm your slow down when editing.

I'm on a MacBook Pro (2015) with Retina Display. 2.5 Ghz Intel Core. 16 Mb RAM. I tried editing the spanned footnotes and it was slow just to change a date in the footnote. Slow response followed by the Mac "rainbow" cursor. It happened both with GPU turned on and turned off.

This should make a good example for the engineers to look at.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 10, 2017 Jul 10, 2017

Copy link to clipboard

Copied

Thanks for providing the file. I can also confirm that the file is slow when editing. It isn't just slow, it is painfully slow.

I created a new file with the same document setup and copied all of the content into the new file. Although the two files are identical as far as I can tell, the new one does not have the slowness problem, other than the standard InDesign sluggishness.

This leads me to believe that there is something in the original file that is corrupt. It would take quite awhile to figure out exactly what is corrupted, so I didn't try to track down the exact culprit. The process would involve eliminating items little by little, testing in between to see if the file is still s-l-o-w. If you don't want to go through the

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 10, 2017 Jul 10, 2017

Copy link to clipboard

Copied

Adding to my reply. I don't know if this is the case with this specific file, but this type of corruption is more likely to happen if a file has been edited many times over the years and was originally created in a prior version of the application.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 10, 2017 Jul 10, 2017

Copy link to clipboard

Copied

Dear All,

I think I found the cause of the problem, which is to make the text "align to baseline grad". When I omitted this option and select "Do not align to baseline grad", the program returned almost to normal, but it is still slow but better than before.

I hope someone else will find a solution to this problem.

Screen Shot 2017-07-10 at 9.51.49 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 10, 2017 Jul 10, 2017

Copy link to clipboard

Copied

Yes, I think you're right. You have Align to Grid turned on in all your paragraph styles.

It makes text composition much more complicated, when combined with handling the spanned footnotes.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 10, 2017 Jul 10, 2017

Copy link to clipboard

Copied

I had Align to Baseline Grid turned on when I copied into a new file, so there may be something more going on. You could try sending the file to Amnan at Adobe (post #5), who kindly offered to spend the time to analyze the file.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 11, 2017 Jul 11, 2017

Copy link to clipboard

Copied

I already sent it to him.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 25, 2017 Jul 25, 2017

Copy link to clipboard

Copied

I'm having the same problem. In any multiple-page document, when I have span footnotes turned on, the program slows to a crawl on any editing change - except on the last page, where the speed is normal. Turning off span footnotes resolves the problem, but I really need to span footnotes in these documents.

It is so slow that when I need to edit text, I type the text into a text editor and paste that into InDesign - otherwise, InDesign pauses for several seconds before displaying each character.

I do not have Align to Baseline Grid turned on. These are not long documents (2-10 pages), and they are mostly straight text, with very few graphics and a single text thread. The documents are in a Book, but the problem persists whether I edit them from within the Book or before I place them into the Book.

FWIW, the documents were created by opening an InDesign template and placing a Word file, including footnotes, into the document. The speed is normal until I span footnotes. I've tried both the document-level span footnotes (through the Type menu) and frame-level span footnotes (through Text Frame options) - same result. I have tried all the "tips for speeding up InDesign," none have helped.

I'm running Windows 10 on a computer with 12GB RAM, an Intel Core i7-6500U Processor, InDesign 2017.0 release, 12.0.0.81 x64 build, The problem has persisted through several InDesign upgrades. I had the same problem on, an older machine with 16GB RAM and Windows 7.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 25, 2017 Jul 25, 2017

Copy link to clipboard

Copied

First things first. Update to CC2017.1

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 25, 2017 Jul 25, 2017

Copy link to clipboard

Copied

Did that. Major improvement. Still a little sluggish, but nothing like before.

EDIT: Spoke too soon. Seemed to be improvement on a test document. Opened an actual production document, and it was back to very slow operation, no real change noticed from the original symptoms.

Other suggestions?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2017 Nov 11, 2017

Copy link to clipboard

Copied

Well, hope springs eternal. I just upgraded to InDesign CS 2018, in the hope that this problem had been fixed. The bad news is, nope, it hasn't been fixed, just as slow as before. The good news is that I now get entertained by a little spinning blue circle while waiting for InDesign. Thanks, Adobe!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 04, 2018 Aug 04, 2018

Copy link to clipboard

Copied

Unfortunately, I have no solution for your problem – but reading your question solved my problem, on which I had almost given up. Deactivating "Span footnotes across columns" (which I don't need in my document) made typing in InDesign quick and smooth for me again. On top, it resolved another issue with disappearing text in text boxes. I couldn't be more happy right now and hope that you'll finally find a solution to make "span footnotes" work.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 08, 2022 Dec 08, 2022

Copy link to clipboard

Copied

LATEST

Sorry to resume this old thread, I have not found a more recent one. Just to say that after all these years the problem is still there with CC2013. Thanks to this old discussion I managed to find what the problem was and make one of my files usable again. It changed like night and day. Luckily I have a single column layout, and for some reason spanning was on anyway.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines