Adobe indesign keeps defaulting to typing in arabic?

New Here ,
Apr 11, 2019 Apr 11, 2019

Copy link to clipboard

Copied

I just started using indesign, and whenever I type the font defaults to adobe arabic, and the dictonary defaults to arabic. I don't speak arabic, and i never specified a download of an arabic version. In addition, whenever i paste in text, the period shows up on the left side, and everything deletes from the left side. Does anybody know how to stop defaulting to arabic, and typing from right to left?

Views

911

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 11, 2019 Apr 11, 2019

Copy link to clipboard

Copied

What version of InDesign? What operating system?

If you are using InDesigh CC (one of the Creative Cloud versions), open the the Creative Cloud desktop app (in the menu bar (Mac) or task bar (Windows). Choose Preferences from the menu at the upper right:

Screen Shot 2019-04-11 at 8.21.12 PM.png

Click on Creative Cloud > Apps and tell me what App Language shows there:

Screen Shot 2019-04-11 at 8.20.24 PM.png

Another source of the wrong language could be the character Language attribute has been set by default to the wrong one.

With no file open, view the Character panel (or the Character Formatting option on Control panel), and look at the Language setting:

Screen Shot 2019-04-11 at 8.26.30 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 15, 2019 Apr 15, 2019

Copy link to clipboard

Copied

Hi Sam,

Steve is right. This generally happens when you have an Arabic version installed on your system. Please change the language from the Creative Cloud app and install the English version. If you need Arabic version for your work but still need a different font as your default font, simply save and close all the open documents and go to Type > Character and change the font (See video: Adobe Creative Cloud ).

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 24, 2020 Jul 24, 2020

Copy link to clipboard

Copied

And don't forget to go into Document Setup and select left to right binding.

 

Steve

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

I have the same issue, but the newer version of the Creative Cloud app doesn't have the Apps Language dropdown. It just randomly switches to Arabic from time to time. Any ideas? 16.2.1 on a Mac.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 23, 2021 May 23, 2021

Copy link to clipboard

Copied

I'm assuming that you have a Middle Eastern ME version downloaded to your machine. If you desire to keep the ME version to type Arabic from time to time, then you can change InDesign's defaults manually to the English language by doing the following…

Launch InDesign, don't open any document, change the font name, size, leading… etc. Change Dictionary language to English, add colors, style sheets as needed, then close InDesign.

Next time you go and create a new document, you will find all the English settings preserved and ready to use. If however, you open an existing document, you will then find old Arabic defaults in the document which you need to change on this particular document as follows… Deselect all, change font name, style, size… etc. Change Dictionary language, add colors and style sheets. This way, this document will always retain these new defaults.

 

If you are not going to use Arabic at all, you don't need to keep the Middle Eastern version, and you better uninstall InDesign, go to change the Language to International English in the Adobe Creative Cloud application, then download a fresh copy of InDesign which will be an English version only this time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 23, 2021 May 23, 2021

Copy link to clipboard

Copied

LATEST

Change the fonts or other settings when no document is open, so any new document will start with these settings. Redefine the default styles, don't forget object styles, draw a text frame with 2 colums, open story panel, click on the correct column direction and redifene the object style.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines