Highlighted

[bug?] Deselecting "Use Typographer's Quotes" for Excel import not working

I'm importing data from Excel into a table, and I want to retain the straight quotes, since they're used not as quotation marks but as characters for "inch" and "foot." However, deselecting "Use Typographer's Quotes" in the import options doesn't seem to make any difference--I end up with curly quotes either way.

 

Here's a visual walkthrough of what I'm doing and the results:

Curly Quotes.png

 

I don't think it should make any difference for imported content, but just in case, I also have "Use Typographer's Quotes" deselected in the Type Preferences panel:

Preferences.png

 

Is this a bug, or am I missing something?

Adobe Community Professional
Correct Answer by Laubender | Adobe Community Professional

Hi Laura,

I'm on Windows 10. Just working with the old Excel 2011 and InDesign 2020.

 

Copy/paste from Excel to an InDesign table yield straight quotes.

Even if the cell's applied paragraph style is the Basic Paragraph Style and the applied language in my case is German.

 

CopiedContents-from-Excel-2011.PNG

 

Pasted contents of clipboard to InDesign table:

 

PastedContents-in-InDesign-Table-CC-2020.PNG

 

Placing unformatted table with Typographer's Quotes un-checked gives the wrong result:

 

Placed-Excel-Table-in-InDesign-CC-2020.PNG

 

What can be done?

Change the table style while importing? Yes. We need a new table style for import where cell styles are applied where paragraph styles are used that are defined with "No Language" to the property "Language". Like in this example:

 

Placed-Excel-Table-in-InDesign-NewTableStyle-CC-2020.PNG

 

Regards,
Uwe Laubender

( ACP )

Topics

Bug, Import and export, Type

Views

66

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn More

[bug?] Deselecting "Use Typographer's Quotes" for Excel import not working

I'm importing data from Excel into a table, and I want to retain the straight quotes, since they're used not as quotation marks but as characters for "inch" and "foot." However, deselecting "Use Typographer's Quotes" in the import options doesn't seem to make any difference--I end up with curly quotes either way.

 

Here's a visual walkthrough of what I'm doing and the results:

Curly Quotes.png

 

I don't think it should make any difference for imported content, but just in case, I also have "Use Typographer's Quotes" deselected in the Type Preferences panel:

Preferences.png

 

Is this a bug, or am I missing something?

Adobe Community Professional
Correct Answer by Laubender | Adobe Community Professional

Hi Laura,

I'm on Windows 10. Just working with the old Excel 2011 and InDesign 2020.

 

Copy/paste from Excel to an InDesign table yield straight quotes.

Even if the cell's applied paragraph style is the Basic Paragraph Style and the applied language in my case is German.

 

CopiedContents-from-Excel-2011.PNG

 

Pasted contents of clipboard to InDesign table:

 

PastedContents-in-InDesign-Table-CC-2020.PNG

 

Placing unformatted table with Typographer's Quotes un-checked gives the wrong result:

 

Placed-Excel-Table-in-InDesign-CC-2020.PNG

 

What can be done?

Change the table style while importing? Yes. We need a new table style for import where cell styles are applied where paragraph styles are used that are defined with "No Language" to the property "Language". Like in this example:

 

Placed-Excel-Table-in-InDesign-NewTableStyle-CC-2020.PNG

 

Regards,
Uwe Laubender

( ACP )

Topics

Bug, Import and export, Type

Views

67

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn More

Re: [bug?] Deselecting "Use Typographer's Quotes" for Excel import not working

Adobe Community Professional , Jan 07, 2020

It's not clear that those are actually prime marks in the original Excel document. Try the following experiment:

1. In the Excel document, select one of the quote marks and from the Insert tab click on Symbol.

2. In the Symbol dialog search field, type "prime". When you find the correct prime mark, double-click on the symbol to replace the currently selected quote mark.

3. Save a copy of the Excel file.

4. Try importing the new document into InDesign using the same options.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn More
Reply
Loading...

Re: [bug?] Deselecting "Use Typographer's Quotes" for Excel import not working

No, they're not actual prime marks, just straight quotation marks. I did try what you described, and those characters are imported correctly.

 

However, using prime marks isn't practical. For one thing, most fonts, including the brand fonts, don't support them. More importantly, using them isn't as straightforward as just typing--they have to be inserted individually via the symbols panel. Something like find-and-replace or a macro could streamline the process, but this spreadsheet will be maintained by people who aren't especially tech savvy and won't remember to use special symbols or find-and-replace.

 

Besides all that, isn't deselecting "Use Typographer's Quotes" supposed to do exactly what I want here--leave the quotation marks straight? Or am I misunderstanding its purpose?

 

The font I'm using fully supports standard straight quotation marks; I'm using the same font in Excel as in InDesign, and the characters are definitely straight in Excel. If I'm not misunderstanding what "Use Typographer's Quotes" is supposed to do, is there any way to get it to work? Or is this just a bug?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn More
Reply
Loading...

Re: [bug?] Deselecting "Use Typographer's Quotes" for Excel import not working

Hi Laura,

I'm on Windows 10. Just working with the old Excel 2011 and InDesign 2020.

 

Copy/paste from Excel to an InDesign table yield straight quotes.

Even if the cell's applied paragraph style is the Basic Paragraph Style and the applied language in my case is German.

 

CopiedContents-from-Excel-2011.PNG

 

Pasted contents of clipboard to InDesign table:

 

PastedContents-in-InDesign-Table-CC-2020.PNG

 

Placing unformatted table with Typographer's Quotes un-checked gives the wrong result:

 

Placed-Excel-Table-in-InDesign-CC-2020.PNG

 

What can be done?

Change the table style while importing? Yes. We need a new table style for import where cell styles are applied where paragraph styles are used that are defined with "No Language" to the property "Language". Like in this example:

 

Placed-Excel-Table-in-InDesign-NewTableStyle-CC-2020.PNG

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn More
Reply
Loading...

That did it! Thank you so much!   Changing the paragraph...

That did it! Thank you so much!

 

Changing the paragraph style's Language to [No Language] didn't change anything for the tables I had already placed, but everything's working perfectly when I import new tables.

 

This still seems like a bug--it doesn't make sense that you'd have to remove the language to keep straight quotation marks, especially when straight quotation marks work just fine in pasted text and manually entered text--so I think I'll report this to support.

 

Thanks again!

 

Here's the bug report: https://indesign.uservoice.com/forums/601180-adobe-indesign-bugs/suggestions/39384505-deselecting-us...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn More
Reply
Loading...

Re: [bug?] Deselecting "Use Typographer's Quotes" for Excel import not working

Update: I tested this with importing a Word document, and weirdly, even with Language set back to English (USA), new  Word imports maintain their straight quotation marks. So far, this seems to be just a problem with Excel imports.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn More
Reply
Loading...

Re: [bug?] Deselecting "Use Typographer's Quotes" for Excel import not working

Adobe Community Professional , Jan 08, 2020

Hi Laura,

and know what, the crazy thing is that after I did my import like that, the paragraph style actually used in the placed table cells is not the one I defined with my cell styles. It's just the [Basic Paragraph Style] with the right straight quotes.

 

Placed-Excel-Table-in-InDesign-NewTableStyle-CC-2020.PNG

As one can see below, formatting recieved in the placed table cells:

[Basic Paragraph Style] ( in my German InDesign: [Einf. Abs.] ) where property "Language" ( Sprache ) is defined as "Deutsch: 2006 Rechtschreibreform" ( German Reformed 2006 ). And definitely not with [No Language]:

Placed-Excel-Table-in-InDesign-NewTableStyle-CellFormattingRecieved-CC-2020.PNG

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn More
Reply
Loading...