Highlighted

Can't hyperlink to LinkedIn profile in InDesign CC

New Here ,
Aug 30, 2017

Copy link to clipboard

Copied

Hi there, I'm using InDesign CC. Trying to hyperlink to my LinkedIn profile. I get a red light saying the URL is not available. The irony is that when I click on the red light it jumps to my LinkedIn profile. So the URL works and is available.

I can't figure out why this won't work, and the last discussion related to something like this was two years ago and involved extended character escapes (which I've tried BTW).

Help!

Correct answer by hued3751123 | Community Beginner

I figured it out.

The linkedin hyperlinks don't work because of the "login wall" around linked in.

This is a workaround:

(1). have two browsers open, in the first be logged in to linkedin (I'm using Firefox) in the second browser (I'm using Chrome) be LOGGED OUT of linkedin.

(2). copy the URL from the logged in browser and paste into the logged out browser

(3). you will get a long URL like this:

https://www.linkedin.com/authwall?trk=ripf&trkInfo=AQGe2BFMPsrkNAAAAWL59zLwkH901PkKy0XUjxCt6D8k2kQPy2G2R3ewxfphQwhT000tVkik2ohWEpIqkI0jIilxEI5sk2OfXTZJEDzezvb2fCzNlv5DBoFbRY8cU9NYcNXD9Jg=&originalReferer=&sessionRedirect=https%3A%2F%2Fwww.linkedin.com%2Fin%2Fandrew-j-chapin%2F

(4). copy that URL into the hyperlink windown in indesign
(5). make sure you export your PDF as "interactive PDF" not "printable PDF" (option in the first dialogue box after "export"

Views

2.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Can't hyperlink to LinkedIn profile in InDesign CC

New Here ,
Aug 30, 2017

Copy link to clipboard

Copied

Hi there, I'm using InDesign CC. Trying to hyperlink to my LinkedIn profile. I get a red light saying the URL is not available. The irony is that when I click on the red light it jumps to my LinkedIn profile. So the URL works and is available.

I can't figure out why this won't work, and the last discussion related to something like this was two years ago and involved extended character escapes (which I've tried BTW).

Help!

Correct answer by hued3751123 | Community Beginner

I figured it out.

The linkedin hyperlinks don't work because of the "login wall" around linked in.

This is a workaround:

(1). have two browsers open, in the first be logged in to linkedin (I'm using Firefox) in the second browser (I'm using Chrome) be LOGGED OUT of linkedin.

(2). copy the URL from the logged in browser and paste into the logged out browser

(3). you will get a long URL like this:

https://www.linkedin.com/authwall?trk=ripf&trkInfo=AQGe2BFMPsrkNAAAAWL59zLwkH901PkKy0XUjxCt6D8k2kQPy2G2R3ewxfphQwhT000tVkik2ohWEpIqkI0jIilxEI5sk2OfXTZJEDzezvb2fCzNlv5DBoFbRY8cU9NYcNXD9Jg=&originalReferer=&sessionRedirect=https%3A%2F%2Fwww.linkedin.com%2Fin%2Fandrew-j-chapin%2F

(4). copy that URL into the hyperlink windown in indesign
(5). make sure you export your PDF as "interactive PDF" not "printable PDF" (option in the first dialogue box after "export"

Views

2.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 30, 2017 0
Valorous Hero ,
Aug 31, 2017

Copy link to clipboard

Copied

Hi

Well if the link works in the exported PDF, that should be ok. Maybe the url is a bit long for indesign or contains characters that it doesn't like. Use a link shortener to see how that goes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 31, 2017 0
New Here ,
Aug 31, 2017

Copy link to clipboard

Copied

Thank you. The link does *not* work in the exported PDF. I tried using bitly to shorten the link and that didn't work either. I wonder if it's something to do with LinkedIn?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 31, 2017 1
Community Beginner ,
Apr 24, 2018

Copy link to clipboard

Copied

I figured it out.

The linkedin hyperlinks don't work because of the "login wall" around linked in.

This is a workaround:

(1). have two browsers open, in the first be logged in to linkedin (I'm using Firefox) in the second browser (I'm using Chrome) be LOGGED OUT of linkedin.

(2). copy the URL from the logged in browser and paste into the logged out browser

(3). you will get a long URL like this:

https://www.linkedin.com/authwall?trk=ripf&trkInfo=AQGe2BFMPsrkNAAAAWL59zLwkH901PkKy0XUjxCt6D8k2kQPy...

(4). copy that URL into the hyperlink windown in indesign
(5). make sure you export your PDF as "interactive PDF" not "printable PDF" (option in the first dialogue box after "export"

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 24, 2018 3
New Here ,
Jul 30, 2019

Copy link to clipboard

Copied

The copy and paste into a logged out linked in isn't working for me. I wonder if they made the login wall stronger. -_-

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 30, 2019 0
New Here ,
Jun 27, 2020

Copy link to clipboard

Copied

Screen Shot 2020-06-28 at 0.39.53.pngWhen you press "Export" as PDF, you are shown "Export Adobe PDF" window. On its "Include" section below, tick "Hyperlinks." 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 27, 2020 0