Highlighted

Creative Cloud Library Graphics now have a white background

Community Beginner ,
Jun 29, 2017

Copy link to clipboard

Copied

I had set up various continuous project libraries and they always worked great. I have assets (logos in ai format) that were always transparent backgrounds. Today for some reason, all the assets have a white background (think jpeg), when I open the graphic files in illustrator, there's no background color. This is particularly more annoying that InDesign is the primary culprit. 

Has anyone had anything like this happen and if so how did you correct it?

Adobe Community Professional
Correct answer by Steve Werner | Adobe Community Professional

One of the limitations of using transparent Illustrator files in the CC Library is that there is no setting when placing from CC Library into InDesign that automatically retains the transparency. InDesign uses the current status of the Place command.

I just did a test. I placed the same transparent AI file into InDesign using the File > Place command. When I placed it, I checked Show Import Options. The first time, I checked Transparent and it appeared as transparent in InDesign. If I then placed the same graphic from CC libraries by right-clicking and choosing Place Linked or Place Copy, it honored that transparent setting.

Then I repeated the test using File > Place. This time I unchecked Transparent. It appeared with an opaque white background. When I placed the same transparent AI file from CC Libraries, it used the File > Place setting and came in with an opaque background.

Views

2.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Creative Cloud Library Graphics now have a white background

Community Beginner ,
Jun 29, 2017

Copy link to clipboard

Copied

I had set up various continuous project libraries and they always worked great. I have assets (logos in ai format) that were always transparent backgrounds. Today for some reason, all the assets have a white background (think jpeg), when I open the graphic files in illustrator, there's no background color. This is particularly more annoying that InDesign is the primary culprit. 

Has anyone had anything like this happen and if so how did you correct it?

Adobe Community Professional
Correct answer by Steve Werner | Adobe Community Professional

One of the limitations of using transparent Illustrator files in the CC Library is that there is no setting when placing from CC Library into InDesign that automatically retains the transparency. InDesign uses the current status of the Place command.

I just did a test. I placed the same transparent AI file into InDesign using the File > Place command. When I placed it, I checked Show Import Options. The first time, I checked Transparent and it appeared as transparent in InDesign. If I then placed the same graphic from CC libraries by right-clicking and choosing Place Linked or Place Copy, it honored that transparent setting.

Then I repeated the test using File > Place. This time I unchecked Transparent. It appeared with an opaque white background. When I placed the same transparent AI file from CC Libraries, it used the File > Place setting and came in with an opaque background.

Views

2.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Jun 29, 2017

Copy link to clipboard

Copied

Moving this discussion to the File Hosting, Syncing, and Collaboration forum.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Jun 29, 2017

Copy link to clipboard

Copied

Hi Gb,

I'm neither an InDesign or an Illustrator expert so I could be completely wrong but could you try this.

I'm wondering if dragging an InDesign file from the Libraries panel is essentially the same thing as using the place command. If so, it may be remembering the last settings used for the place command.

Please try this and see if it makes any difference.

1) Save one of your .ai files with a transparent background to the desktop

2) In InDesign use the place command File > Place

3) In the which file to place dialogue, select the .ai file you saved to the desktop, ALSO check the option "Show Import Options", click Open

4) In the Place window showing the import options ensure the transparency option is checked

5) See if this placed .ai has transparency in InDesign (hopefully yes)

6) Now test other .ai files from the Libraries panel to see if they do too

Hope that helps?

Best,

- Dave

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jun 29, 2017

Copy link to clipboard

Copied

One of the limitations of using transparent Illustrator files in the CC Library is that there is no setting when placing from CC Library into InDesign that automatically retains the transparency. InDesign uses the current status of the Place command.

I just did a test. I placed the same transparent AI file into InDesign using the File > Place command. When I placed it, I checked Show Import Options. The first time, I checked Transparent and it appeared as transparent in InDesign. If I then placed the same graphic from CC libraries by right-clicking and choosing Place Linked or Place Copy, it honored that transparent setting.

Then I repeated the test using File > Place. This time I unchecked Transparent. It appeared with an opaque white background. When I placed the same transparent AI file from CC Libraries, it used the File > Place setting and came in with an opaque background.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 26, 2018

Copy link to clipboard

Copied

Thank you so much! I've been having this issue, too. I would have never thought of this as a solution. Y'all rock!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 08, 2018

Copy link to clipboard

Copied

Yours is actually the correct solution to the problem. Thank you for this. This happened to me all of a sudden so I can't figure out WHY it happened but the How-To-Fix solution you provided worked!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 02, 2017

Copy link to clipboard

Copied

Thank you so much for your help David!

The odd thing about all this is that the assets that I have in my libraries worked for almost a year, flawlessly. The libraries allowed a repeated set to assets to be readily available on any CC software which was amazing. I do know about placing with transparency options as a backup and that works for me. It's just such a shame and a puzzle to have these assets all of a sudden stop working as they have for a long time.

Regardless, your help is incredibly appreciated and I am so grateful you took the time to help!! I will resort to your solution until this gets sorted out. I will post if I figure anything else out.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 16, 2018

Copy link to clipboard

Copied

It's a little strange work-around but it works. Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 24, 2017

Copy link to clipboard

Copied

Thanks everyone! So just an update... the assets that were housed in the Creative Cloud Library work properly all of a sudden. No real solution to be offered on this. I don't believe there were any updates made during that time to the software. The files don't have a white background on them. I had been using the libraries for months, I knew there was nothing wrong with the files so I was incredibly perplexed and frustrated with the issues, and while I'm glad they're resolved I would love to know what happened.

I guess we may never know... *sigh*

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 24, 2017

Copy link to clipboard

Copied

Did you read my post #3? If you placed an Illustrator file and checked Transparent, then all the CC Library AI files which had a transparent background would then show a transparent background when dragged into InDesign.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 17, 2020

Copy link to clipboard

Copied

Is there a way to set this as a default setting so you don't have to do this every time?

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 25, 2020

Copy link to clipboard

Copied

Thank you so much for this solution. It was driving me insane! Phew

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...