Data Merge – Blank Lines & Space removal does not work ?

New Here ,
Jul 22, 2019

Copy link to clipboard

Copied

Dear Community –

Using InDesign CC 2019 / Version 14.0.2 (latest) and consulting everyone I know and everything there is out there has not produced a solution to my question/problem.

Problem 1Empty Space is not eliminated on fields that should adjust to the left margin

Problem 2

Soft (Shift + Return) or Hard (Return) plus (Remove Blank Lines) does not what it is supposed to do,

Example Fields to be filled (and some remain empty)

<Name> <Familyname>

<Flield 1>

<Flield 2>

<Flield 3>

Lorem Ipsum dolor …………

and it ALWAYS look like this:

Problem 1 | SpaceSpace is not ignored

<Familyname>

<Flield 1>

Lorem Ipsum dolor …………

Screenshot 2019-07-22 at 12.02.27.pngScreenshot 2019-07-22 at 12.02.44.png

Problem 2 | Empty FieldsHeader 2Header 3

<Name> <Familyname>

<Flield 1>

<Flield 2>

<Flield 3>

Lorem Ipsum dolor …………

Screenshot 2019-07-22 at 12.15.06.pngScreenshot 2019-07-22 at 12.15.20.png

Content Placement

Screenshot 2019-07-22 at 11.56.03.png

I really really don't get it … and i hope there is a simple solution to this …

Thank you very much!

Danny

Views

208

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Data Merge – Blank Lines & Space removal does not work ?

New Here ,
Jul 22, 2019

Copy link to clipboard

Copied

Dear Community –

Using InDesign CC 2019 / Version 14.0.2 (latest) and consulting everyone I know and everything there is out there has not produced a solution to my question/problem.

Problem 1Empty Space is not eliminated on fields that should adjust to the left margin

Problem 2

Soft (Shift + Return) or Hard (Return) plus (Remove Blank Lines) does not what it is supposed to do,

Example Fields to be filled (and some remain empty)

<Name> <Familyname>

<Flield 1>

<Flield 2>

<Flield 3>

Lorem Ipsum dolor …………

and it ALWAYS look like this:

Problem 1 | SpaceSpace is not ignored

<Familyname>

<Flield 1>

Lorem Ipsum dolor …………

Screenshot 2019-07-22 at 12.02.27.pngScreenshot 2019-07-22 at 12.02.44.png

Problem 2 | Empty FieldsHeader 2Header 3

<Name> <Familyname>

<Flield 1>

<Flield 2>

<Flield 3>

Lorem Ipsum dolor …………

Screenshot 2019-07-22 at 12.15.06.pngScreenshot 2019-07-22 at 12.15.20.png

Content Placement

Screenshot 2019-07-22 at 11.56.03.png

I really really don't get it … and i hope there is a simple solution to this …

Thank you very much!

Danny

Views

209

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 22, 2019 0
Adobe Community Professional ,
Jul 22, 2019

Copy link to clipboard

Copied

Hi Danny,

the special characters you are seeing in the result are of unicode value FEFF.

You could remove them with a TEXT Find/Change action using <FEFF> for find and nothing for change.

GREP Find/Change will not work for this.

Trailing white space could be removed with a GREP Find/Change action.

You could try ^\s+ as pattern.

More on the why and how in this rather lengthy old thread:

Multiple record data merge into paragraph styles-applies the wrong style

( Best read it all… )

Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 22, 2019 0
Adobe Community Professional ,
Jul 22, 2019

Copy link to clipboard

Copied

For the first issue, have you considered using a GREP style to condense any spaces at the start of a line to 1% at .1pt in size?

The GREP code would be ^\p{Zs}+ and the style would just have a horizontal width of 1% and size of 0.1pt.

Screen Shot 2019-07-23 at 00.28.56.png

For the second issue, I think the content placement options should be rephrased to be more accurate. I believe that the "Remove Empty Lines for Blank Fields" should more accurately read "Remove the hard return if one field was placed in a line and there was nothing in it". It doesn't work with soft returns and assumes there's only going to be one field in that line. If you use hard returns instead of soft returns then the feature should work. Is there a reason that soft returns have been used in this instance? I'd imagine hard returns would work just as well.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 22, 2019 0