How can I stop the text cursor from blinking in InDesign for Mac?

Community Beginner ,
Apr 10, 2021 Apr 10, 2021

Copy link to clipboard

Copied

According to the InDesign manual, to stop the text cursor from blinking I should go to InDesign Preferences, select Story Editor, and deselect the Blink checkbox.

 

I do this and it has no effect, whether I have a document open in InDesign or not. Can anyone help?

TOPICS
How to, Type

Views

133

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 10, 2021 Apr 10, 2021

Copy link to clipboard

Copied

Do you have the CAPS lock on?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 10, 2021 Apr 10, 2021

Copy link to clipboard

Copied

No; should I?

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 10, 2021 Apr 10, 2021

Copy link to clipboard

Copied

Just tried it both ways - with the caps lock on and then off. No effect either way; the cursor is still blinking

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 10, 2021 Apr 10, 2021

Copy link to clipboard

Copied

Also, I'm finding that InDesign pays no attention to anything about the cursor that I select in Preferences / Story Editor Display. I tried changing its shape from standard to thick, and then barbell, and then block, and InDesign just continue to display a blinking standard cursor. WTF?

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 10, 2021 Apr 10, 2021

Copy link to clipboard

Copied

Blinking text-editing cursors are a standard, default setting, not something you can usually control--but some programs do have overrides. InDesign's Story Editor settings are only for when you are using the Story Editor view, not in the layout view. 

 

You can try changing the OS settings with some Terminal commands. Here is a website I googled:

http://macissues.com/2014/12/08/how-to-change-your-macs-text-cursor-blink-rate/

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 10, 2021 Apr 10, 2021

Copy link to clipboard

Copied

Thank you, Creamer Training! I didn't even know there was such a thing as Story Editor view. I used that and sure enough, the mouse cursor stopped blinking. The only bad thing is that the text goes right up to the edge of the window, which I find visually distracting / unfriendly, and I can find no way to add a margin to either side. 

 

I did try the Terminal commands but no luck in either Word or InDesign; the cursor blinks at the same rate no matter what rate I specify. It was worth a try, though!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 10, 2021 Apr 10, 2021

Copy link to clipboard

Copied

Edit in Story Editor is a really useful facility Tiffany; it's worth learning.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 10, 2021 Apr 10, 2021

Copy link to clipboard

Copied

LATEST

@Derek Cross If I could get some margins to appear to the left and right of Story Editor View, I would definitely use it.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines