Highlighted

InDesign 2019 Keyboard shortcuts not working

Community Beginner ,
Feb 20, 2019

Copy link to clipboard

Copied

I have a potentially similar issue with InDesign CC 2019 (v14.0.1) on Windows 10. Occasionally when I first open ID, none of the keyboard commands work. For example, the selection tool is currently in use, so I'll press "T" to to use the text tool, but nothing happens. The workaround I found to alleviate this is to click into any text box on the properties bar and then hit the escape key until I lose focus of that item. The tools are once again responsive to the keyboard, at least until I close and restart ID. I don't recall having this issue until the past few months.

[ branched from Illustrator 2019 shortcuts stop working by moderator ]

{Renamed by MOD}

Views

8.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

InDesign 2019 Keyboard shortcuts not working

Community Beginner ,
Feb 20, 2019

Copy link to clipboard

Copied

I have a potentially similar issue with InDesign CC 2019 (v14.0.1) on Windows 10. Occasionally when I first open ID, none of the keyboard commands work. For example, the selection tool is currently in use, so I'll press "T" to to use the text tool, but nothing happens. The workaround I found to alleviate this is to click into any text box on the properties bar and then hit the escape key until I lose focus of that item. The tools are once again responsive to the keyboard, at least until I close and restart ID. I don't recall having this issue until the past few months.

[ branched from Illustrator 2019 shortcuts stop working by moderator ]

{Renamed by MOD}

Views

8.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 20, 2019 1
Adobe Community Professional ,
Feb 20, 2019

Copy link to clipboard

Copied

Please Post InDesign issues to the InDesign forum

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 1
Community Beginner ,
Feb 20, 2019

Copy link to clipboard

Copied

Hah. Wasn't even paying attention. I told Google to search for InDesign and it sends me here.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 0
Most Valuable Participant ,
Feb 20, 2019

Copy link to clipboard

Copied

Moved from Illustrator to InDesign

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 0
Community Beginner ,
Feb 21, 2019

Copy link to clipboard

Copied

Thank you for moving this to the correct forum.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 21, 2019 0
Explorer ,
Feb 20, 2019

Copy link to clipboard

Copied

This sounds suspiciously similar to a bug that I reported on UserVoice: No keyboard focus on launch. If you can add any additional information to my report there, it might help to get it fixed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 1
Adobe Community Professional ,
Feb 21, 2019

Copy link to clipboard

Copied

FlameTechIT  wrote

I have a potentially similar issue with InDesign CC 2019 (v14.0.1) on Windows 10. Occasionally when I first open ID, none of the keyboard commands work. For example, the selection tool is currently in use, so I'll press "T" to to use the text tool, but nothing happens. The workaround I found to alleviate this is to click into any text box on the properties bar and then hit the escape key until I lose focus of that item. The tools are once again responsive to the keyboard, at least until I close and restart ID. I don't recall having this issue until the past few months.

[ branched from Illustrator 2019 shortcuts stop working  by moderator ]

Hi,

I can see this as well. Always.

After launching InDesign I first have to give it focus so that InDesign is activated.

I always do this with a click to the gray area of the application window ( I am using a custom workspace, that will show up after starting InDesign ).

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 21, 2019 0
Community Beginner ,
Feb 21, 2019

Copy link to clipboard

Copied

Laubender

I can see this as well. Always.

After launching InDesign I first have to give it focus so that InDesign is activated.

I always do this with a click to the gray area of the application window ( I am using a custom workspace, that will show up after starting InDesign ).

I don't think this is the case, as I believe ID is already focused when this happens. However, it's possible that I'm not paying attention in my rush. I'll keep an eye on my actions and see if this is the cause.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 21, 2019 0
Community Beginner ,
Feb 21, 2019

Copy link to clipboard

Copied

Just now ran into the problem again. It may be related to opening an existing file, rather than from creating a new one. ID was already running and I had created a new file without issues, and the keyboard worked fine. I closed the new file and opened an existing file by double-clicking it in a folder. After that file was opened, I clicked on ID to get focus and pressed "T" to activate the text tool. Nothing happened. I unlocked some layers and selected a text box and pressed "T" again. Still nothing happened. After clicking onto my web browser to start typing this, I then clicked back into ID to verify something and now "T" and other such keys do exactly as they are expected.

I'm going to clear my settings on ID yet again and see if this persists. I say "yet again" because I have other GUI issues with ID that have nothing to do with keyboard shortcuts.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 21, 2019 0
Community Beginner ,
Feb 21, 2019

Copy link to clipboard

Copied

Reset didn't fix it. Two out of three times, opening a file from a folder causes ID to not be responsive to keyboard until I click on the top menu, click into a properties bar text box, or click on another window entirely. Simply clicking a non-text box item on a pallet (such as layer lock) doesn't fix it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 21, 2019 0
Adobe Community Professional ,
Feb 21, 2019

Copy link to clipboard

Copied

Hi,

if this issue happens to me it also helps if I switch to a different app like a browser and come back to InDesign.

So your issue might be a different one than yours…

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 21, 2019 1
Adobe Employee ,
Feb 21, 2019

Copy link to clipboard

Copied

Hi Aaron,

Sorry to hear about this issue. I would request if you can check if there is some third party utility installed on your system? If yes, try to uninstall it and try again.

If that does not help, please try the steps shared here: https://indesignsecrets.com/topic/keyboard-shortcuts-not-working and let us know if that works.

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 21, 2019 1
Explorer ,
Feb 22, 2019

Copy link to clipboard

Copied

Hi Srishti,

Can you please confirm that you either can or cannot reproduce the issue that I reported in UserVoice, No keyboard focus on launch? This does sound very much like the problems that both FlameTechIT and Uwe are seeing, although they are on Windows and I am on macOS. To be honest, I am rather surprised that no one from Adobe has commented on the bug report, either to confirm it or to say that it was not reproducible.

Regards,

Eric

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 22, 2019 1
Community Beginner ,
Feb 22, 2019

Copy link to clipboard

Copied

ericcarlson

Confirmed I have something very similar and up-voted with comment on UserVoice. For me, it appears that having the "Start" screen turned ON is the cause of the problem. I'd prefer to not turn off "Start", because it is very handy for jumping back into recent work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 22, 2019 0
Community Beginner ,
Feb 22, 2019

Copy link to clipboard

Copied

srishtib8795206

I don't believe I have any 3rd party items installed on CC 2019. However, I do still have a copy of CS 5.5 installed with an old 3rd party product that has not been upgraded for CC editions.

Followed the steps on the linked forum. Still see the problem.

After reinstalling, when I first opened ID and tried to open a file from a folder, nothing happened. I figure Windows needed a chance to re-associate the file type, so I closed ID. Restarted ID and the "Start" screen shows with nothing on it. Right-clicked the file in the folder and hit "Open with..." InDesign. The keyboard worked fine at that time. Closed ID entirely and reopened it. This time "Start" had a preview of the file that was recently opened. I reopened that file by double-clicking it in the folder. Keyboard issue happens. Closed the file and reopened it with right-click "Open with..." and Keyboard issue happens again. Opening the file via drag and drop into ID does not cause the keyboard issue.

NOTE: When the option to show "Start" is turned off, the keyboard issue is not noticed. In fact, I can open a file via double-click and immediately hit keys and ID instantly responds without the need to click on it for focus.

To summarize:
The "Start" screen needs to be active and have recent file previews. A file must be opened from its folder via double-click or right-click "Open with...". It appears to me that those are the significant items that must be done in order to observe the keyboard issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 22, 2019 0
New Here ,
Feb 21, 2019

Copy link to clipboard

Copied

I sometimes get this problem but it is due to me accidentally changing my keyboards language (I have nordic keyboard so I accidentally change it to english.)

Or if it stops working I go to check from Edit -> Keyboard shortcuts    What default shortcuts I have in use.

I hope these helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 21, 2019 1
Community Beginner ,
Feb 21, 2019

Copy link to clipboard

Copied

Thank you for the input, as it could have been something for me. On the PC in question, I use only the English keyboard.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 21, 2019 0
Community Beginner ,
Dec 11, 2019

Copy link to clipboard

Copied

I thought I had the same issue with the Romaji (Japanese) keyboard settings, but when I changed it back to Belgian the issue persisted. So not sure if it is entirely related to the keyboard/language setting.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 11, 2019 0
New Here ,
May 10, 2019

Copy link to clipboard

Copied

from an end user - with Mac OS Mojave installed, Adobe 2019 InDesign: 

Hello,

For some reason my shortcut keys are not working in InDesign. Specifically these are the ones with issues:

> hold down spacebar to use the hand tool (using the selection tool)

> duplicate as dragging artwork (option + selection tool + command) and duplicate as dragging in alignment (option + shift + selection tool)

> moving artwork while in alignment (shift + selection tool)

> scaling proportionally from one edge (shift + selection tool, dragging the corner of the transform box)

> scaling proportionally from the center (shift + option + selection tool, dragging the corner of the transform box)

It essentially seems like option and shift are just not working!

This came abruptly. One day last week it simply didn't work. I do not install updates automatically but I do install fonts, so perhaps it is a font issue? Trashing my preferences did not help.

My personal computer does have the shortcut keys working so I'm OK for now, but would really prefer to use the school's computer for work."

The only difference between her personal laptop and her work one is that her personal one has the Mac OS version prior to Mojave installed.  The end user uninstalled InDesign2019, reinstalled it to see if that would resolve the issue.  Still does not work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 10, 2019 0
Community Beginner ,
May 10, 2019

Copy link to clipboard

Copied

Out of curiosity, do the shortcuts work correctly after clicking into any text box in any panel and then clicking out? This has worked for me with Windows 10.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 10, 2019 0
Adobe Employee ,
May 13, 2019

Copy link to clipboard

Copied

Hi there,

Thanks for reaching out. As per your query, keyboard shortcuts with option or shift key doesn't work on InDesign. Let us help you make this right. Would you mind sharing a few more details like:

  • Is there an antivirus or web extension installed recently?
  • Please check and let us know if resetting InDesign Preferences (Set preferences in Adobe InDesign ) help resolve the issue?

Please note resetting preferences will remove all the custom settings and InDesign will launch with default settings. Please take a backup of preferences folders. Location is mentioned in the article.

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 13, 2019 1
New Here ,
May 17, 2019

Copy link to clipboard

Copied

No antivirus was added recently.  We set up machines with AV before giving to end users.  No web extension has been installed.

The user states - "Resetting the preferences was the first thing I did to fix this issue. They are notorious for causing the Adobe products to act up."

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 17, 2019 0
Adobe Employee ,
May 20, 2019

Copy link to clipboard

Copied

Thanks for sharing the details. Please login to the Root account (How to enable the root user on your Mac or change your root password - Apple Support ) and check how it works there. If it works fine in the root account, set read-write permissions for InDesign preferences folders by following these steps:

  • Go to Terminal (Go > Utilities > Terminal.app)
  • Execute the following command on the terminal to provide permission:
  1. sudo chmod -R 777 /Users/<user>/Library/Preferences/Adobe InDesign
  2. sudo chmod -R 777 /Users/<user>/Library/Caches/Adobe InDesign
  3. sudo chmod -R 777 /Users/<user>/Library/Application Support

Let us know if that helps. If this doesn't help, please reach us Contact Customer Care for a live troubleshooting session. Please click on the small chat icon on the bottom-right corner of the screen to start the chat.

                                                                           

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 20, 2019 1
Community Beginner ,
May 20, 2019

Copy link to clipboard

Copied

I tried something similar with Windows 10. Added permissions for "Everyone" to have full control on the following folders:

  • C:\Users\<username>\AppData\Local\Adobe\InDesign
  • C:\Users\<username>\AppData\Roaming\Adobe\InDesign
  • FYI: C:\Users\<username>\AppData\LocalLow\Adobe has no InDesign folder in it on my PC

I found a "caches" folder inside the "Local\Adobe\InDesign" folder, so I'm hoping that covered it. I'm not aware of an equivalent folder to "Application Support" in Windows. Maybe C:\ProgramData?

I checked a few files in those folders to verify that the permissions propagated throughout and they did.

Anyways, this did not fix the keyboard issue for me. I tested a few times with restarting InDesign in case it needed to write changes and re-read them upon opening.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 20, 2019 0
Adobe Employee ,
May 21, 2019

Copy link to clipboard

Copied

Hi Aaron,

For Windows please try these steps:

Reset Preferences: Set preferences in Adobe InDesign

Please note that resetting preferences will remove all the custom settings and InDesign will launch with default settings. You can also take a backup of the folders in case you want to. Location is mentioned in the article.

If that doesn't help, please log in to built-in administrator account (Windows 10 - Enable The Built-in Administrator Account - YouTube ) and check how it works there. If it works fine in the admin account, set read-write permissions for InDesign preferences folders by following these steps:

  • Go to the following locations one by one:

C:\Users\<user>\AppData\Local\Adobe InDesign

C:\Users\<user>\AppData\Roaming\Adobe InDesign

Note: In folder paths or names listed in the procedures, replace <user> with your account name.

  • Open the File Explorer window. Click the View tab, and then select Hidden items.
  • Navigate to the folders using the paths listed in the table above.
  • In File Explorer, right-click the folder InDesign and choose Properties.

                                              

  • Click the Security tab, and then click Edit to set permissions.

                              

  • In the Permissions dialog, select your user name. In the Permissions area, allow Full control to your user.

                                                          

  • Click OK twice.
  • Launch Adobe InDesign.

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2019 1
Community Beginner ,
May 31, 2019

Copy link to clipboard

Copied

I've basically done similar to this already as well as deleted and re-created my setting several times and also re-installed InDesign. I don't see how messing around with file permissions and settings yet again will fix this, considering that the core problem is easily bypassed by disabling Preferences -> General -> Show "Start" Workspace When No Documents Are Open. I don't observe turning off that option as an actual fix, because then it's forcing me to use InDesign in a manner I don't prefer. I'd rather that the programmers find the actual problem and resolve it so that InDesign is a better product.

Again, I've not noticed this problem until about 3rd or 4th quarter 2018. It may have been an issue for me ever since the "Start" Workspace was introduced (can't remember when that was), but I maybe didn't realize it right away or perhaps I was opening files differently (drag and drop don't cause the problem for me).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 31, 2019 0
New Here ,
Oct 14, 2019

Copy link to clipboard

Copied

Hello Foggy1989, did you find a solution to this? I am having the same issue. Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 14, 2019 0