Highlighted

InDesign Preferences Reset After Crashing - Display Performance and Dynamic Spelling

Explorer ,
May 19, 2020

Copy link to clipboard

Copied

My InDesign CC preferences setting keep resetting every time the app crashes.

 

The 'Display Performance' reverts back to 'High Quality', resulting in the beachball of doom for several minutes each time when working on files with large photos.

 

I also notice that the 'Dynamic Spelling' gets switched off, meaning my file looks like it has no mistakes!

 

It is very frustrating having to reset these preferences every time - any ideas on how to fix this bug?

Thanks for trying that, Nadine! Please try following these steps one by one and share your observations. 

1. Reset Preferences: -

  • Close all adobe applications
  • Go to Locations:
  • ~/Library/Caches
  • ~/Library/Preferences
  • Rename Adobe InDesign and com.adobe.indesign to Adobe InDesign.old and com.adobe.indesign.old
  • Launch InDesign from the CC
  • Once done, set the prefer once gain with no files open and let us know if this helps.

 

2. If that doesn't help either, login to root account (https://support.apple.com/en-in/HT204012). Check how application works there. If it works fine there, then it could be related to permission errors. Follow these steps to repair permission errors: 

  • Go to Terminal (Go Utilities Terminal.app) 
  • Execute the following command on terminal to provide permission: 
    • sudo chmod -R 777 /Users/<user>/Library/Preferences/Adobe InDesign 
    • sudo chmod -R 777 /Users/<user>/Library/Caches/Adobe InDesign 
    • sudo chmod -R 777 /Users/<user>/Library/Application Support 

 

Topics

Bug

Views

670

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

InDesign Preferences Reset After Crashing - Display Performance and Dynamic Spelling

Explorer ,
May 19, 2020

Copy link to clipboard

Copied

My InDesign CC preferences setting keep resetting every time the app crashes.

 

The 'Display Performance' reverts back to 'High Quality', resulting in the beachball of doom for several minutes each time when working on files with large photos.

 

I also notice that the 'Dynamic Spelling' gets switched off, meaning my file looks like it has no mistakes!

 

It is very frustrating having to reset these preferences every time - any ideas on how to fix this bug?

Thanks for trying that, Nadine! Please try following these steps one by one and share your observations. 

1. Reset Preferences: -

  • Close all adobe applications
  • Go to Locations:
  • ~/Library/Caches
  • ~/Library/Preferences
  • Rename Adobe InDesign and com.adobe.indesign to Adobe InDesign.old and com.adobe.indesign.old
  • Launch InDesign from the CC
  • Once done, set the prefer once gain with no files open and let us know if this helps.

 

2. If that doesn't help either, login to root account (https://support.apple.com/en-in/HT204012). Check how application works there. If it works fine there, then it could be related to permission errors. Follow these steps to repair permission errors: 

  • Go to Terminal (Go Utilities Terminal.app) 
  • Execute the following command on terminal to provide permission: 
    • sudo chmod -R 777 /Users/<user>/Library/Preferences/Adobe InDesign 
    • sudo chmod -R 777 /Users/<user>/Library/Caches/Adobe InDesign 
    • sudo chmod -R 777 /Users/<user>/Library/Application Support 

 

Topics

Bug

Views

671

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 19, 2020 0
Adobe Community Professional ,
May 19, 2020

Copy link to clipboard

Copied

Hi,

Can you confirm the exact version of your software and operating system?

Have you changed the preferences with the document opened or without any document started?

Does the same issue happen if you work on a different file or a new one?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 19, 2020 0
Explorer ,
May 21, 2020

Copy link to clipboard

Copied

Hey,

 

I’m using:

Indesign 15.0.3

Mac OS Catalina 10.15.3

 

I have tried setting the preferences before opening any document. It only seems to reset after crashing or force quit.

 

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2020 0
Adobe Community Professional ,
May 19, 2020

Copy link to clipboard

Copied

Hi Nadine,

before resetting the preferences you should had a backup of them.

What's your operating system version?
What's your InDesign version?

 

When on Mac OS X you should have access to the old preferences with TimeMachine.

So you should be able to get a version of your preferences that are intact some days or weeks ago.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 19, 2020 0
Explorer ,
May 21, 2020

Copy link to clipboard

Copied

Hey,

 

I’m using:

Indesign 15.0.3

Mac OS Catalina 10.15.3

 

I'm not sure how to do the TimeMachine - but would I have to TimeMachine backup every time InDesign crashes or is forced quit, as this would be just as slow as resetting my preferences? 

 

Thanks!

 

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2020 0
Adobe Employee ,
May 19, 2020

Copy link to clipboard

Copied

Hi Nadine,

 

Sorry to hear about the trouble you are facing with InDesign. Display Settings and Spellcheck is not a part of Workspace. Whenever InDesign is closed/ crashed and relaunched, it opens with default settings. Try following these steps and let us know how it goes:

  • Close all open documents in InDesign.
  • Open Preferences (CMD/ CTRL+ K).
  • Go to Display Performance and set Default view as per your requirement.
  • Then click Spelling and check Enable Dynamic Spelling

       Enable dynamic spelling.png  Set default display performance.png

 

If it happens again, please share the crash report (https://helpx.adobe.com/in/indesign/kb/submit-crash-reports.html) along with the details asked above.

While submitting the crash report please use the same email address, with which you are signed in on this community. This will help us find the crash report and help accordingly.

 

Regards,

Srishti

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 19, 2020 0
Explorer ,
May 21, 2020

Copy link to clipboard

Copied

Hey Srishti,

 

Thanks for you help, but my problem is that InDesign is resetting every time it crashes/force quit, which means when I open document with large imagery, it takes several minutes to load as it is trying to load High Quality images. I have tried setting the preferences with no document open too, it's just frustrating having to set it every time.

 

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2020 0
Adobe Employee ,
May 21, 2020

Copy link to clipboard

Copied

Thanks for trying that, Nadine! Please try following these steps one by one and share your observations. 

1. Reset Preferences: -

  • Close all adobe applications
  • Go to Locations:
  • ~/Library/Caches
  • ~/Library/Preferences
  • Rename Adobe InDesign and com.adobe.indesign to Adobe InDesign.old and com.adobe.indesign.old
  • Launch InDesign from the CC
  • Once done, set the prefer once gain with no files open and let us know if this helps.

 

2. If that doesn't help either, login to root account (https://support.apple.com/en-in/HT204012). Check how application works there. If it works fine there, then it could be related to permission errors. Follow these steps to repair permission errors: 

  • Go to Terminal (Go Utilities Terminal.app) 
  • Execute the following command on terminal to provide permission: 
    • sudo chmod -R 777 /Users/<user>/Library/Preferences/Adobe InDesign 
    • sudo chmod -R 777 /Users/<user>/Library/Caches/Adobe InDesign 
    • sudo chmod -R 777 /Users/<user>/Library/Application Support 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2020 0
Adobe Community Professional ,
May 22, 2020

Copy link to clipboard

Copied

Hi Nadine,

it would be best to run TimeMachine all the time. That's the least you can do to gain some security.

Depending on the number of volumes and volume sizes you want to backup you'll need an external disk with a couple of terabytes capacity.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 22, 2020 1
New Here ,
Sep 25, 2020

Copy link to clipboard

Copied

Yep. Great advice. Become an IT expert, root your computer, hire specialists, because Adobe CAN'T MAKE THEIR SOFTWARE TO WORK FULLY CORRECT. 
LOL

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2020 0