Some hyperlinks not working in PDF published online- Indesign 2021 (version 16)

New Here ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

We have a INDD file that was exported to PDF (interactive), and then published online. The hyperlinks all work in the INDD file, and they work in the PDF file, but when we post it to the web some links work but many do not. When we download the PDF off of our website, all of the links work. 

 

These are hyperlinks that take you to other pages within the same document. We use this method in many, many files and have never run into this issue before. The file was created in Version 16.0.1, and we have now updated to V.16.1. 

 

We tried the following in the INDD file:

1. Deleting, and re-linking some of the hyperlinks in the hyperlink panel (no luck)

2. Deleting the hyperlink destination, creating a new hyperlink destination, and re-linking; this also didn't work. 

3. Exporting to PDF(print) with box checked to include hyperlinks

4. Saving as and IDML file, and then resaving a fresh INDD file

 

Thanks in advance for any suggestions! This is a real head-scratcher, but I'm determined to figure it out! 

 

 

TOPICS
Bug, Performance, Publish online

Views

98

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

Any chance you could provide the file or small sampling thereof?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

Thank you so much for your reply. Unfortunately, I am unable to share the file. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 07, 2021 Feb 07, 2021

Copy link to clipboard

Copied

LATEST

So, if I understand you correctly, hyperlinks going to Text Anchors are not working in Publish Online? 

I took an old file that illustrates using a hamburger menu for navigation (neat trick), and added a block of text, set it as a text anchor (hyperlink destination) on page 4. On page 1, there is a text block that says "Let's go to page 4."  It seems to work just fine. https://indd.adobe.com/view/b4711d1f-497c-406d-a588-234ba9fc4cf4

(Sorry, the menu collides with the text, but it's just to test it quickly)

Are *all* your text anchor hyperlinks not working in Publish Online? There shouldn't be an issue (but... that's why we're all here, I suppose 😊).

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines