Unwanted space after any special characters?

New Here ,
Sep 04, 2017

Copy link to clipboard

Copied

Anytime I type any character such as an apostrophe, indesign is automatically adding a large space.

For example "it's" would look like "it'   s"

Copying in doesn't work and I have only just downloaded indesign onto this laptop so all the settings are completely unchanged. The only way I have found of dealing with this is change the kerning to -800 which I'd rather not have to do for every apostrophe.

So any ideas on how to fix this? There's another thread on this issue but it doesn't seem like they actually solved this problem. Unwanted space after apostrophe

Adobe Community Professional
Correct answer by Bill Silbert | Adobe Community Professional

This is not normal behavior. You did not say if it is happening with multiple fonts or just one. At any rate since InDesign should not be doing this I would suggest rebuilding your preferences just to make sure that this is happening even when the program is at its factory settings.

To reset preferences:

For Macintosh Users: With InDesign closed Launch a Finder Window in column view and click on your home folder. With the Option Key pressed choose Library from the Finder Go Menu. Within the Library folder find the folder called Preferences and within it find the following two files and delete them: “Adobe InDesign” and “com.adobe.InDesign.plist”. When InDesign is next launched it will create new preference files and the program will be restored to its defaults.

After you’ve reset up the program (make sure that no document window is open) to your liking, it is a really good idea to create copies of your personalized “mint” preference files (make sure that you quit the program before copying them—that finalizes your customization) and use them in the future to replace any corrupt versions you may need to delete.

For Windows Users: Hold down Ctrl + Alt + Shift when launching InDesign and respond affirmatively when asked if you want to reset.

By the way the thread you mentioned is for Illustrator. Even if they had come to a solution it may not have helped the problem in InDesign.

Views

1.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Unwanted space after any special characters?

New Here ,
Sep 04, 2017

Copy link to clipboard

Copied

Anytime I type any character such as an apostrophe, indesign is automatically adding a large space.

For example "it's" would look like "it'   s"

Copying in doesn't work and I have only just downloaded indesign onto this laptop so all the settings are completely unchanged. The only way I have found of dealing with this is change the kerning to -800 which I'd rather not have to do for every apostrophe.

So any ideas on how to fix this? There's another thread on this issue but it doesn't seem like they actually solved this problem. Unwanted space after apostrophe

Adobe Community Professional
Correct answer by Bill Silbert | Adobe Community Professional

This is not normal behavior. You did not say if it is happening with multiple fonts or just one. At any rate since InDesign should not be doing this I would suggest rebuilding your preferences just to make sure that this is happening even when the program is at its factory settings.

To reset preferences:

For Macintosh Users: With InDesign closed Launch a Finder Window in column view and click on your home folder. With the Option Key pressed choose Library from the Finder Go Menu. Within the Library folder find the folder called Preferences and within it find the following two files and delete them: “Adobe InDesign” and “com.adobe.InDesign.plist”. When InDesign is next launched it will create new preference files and the program will be restored to its defaults.

After you’ve reset up the program (make sure that no document window is open) to your liking, it is a really good idea to create copies of your personalized “mint” preference files (make sure that you quit the program before copying them—that finalizes your customization) and use them in the future to replace any corrupt versions you may need to delete.

For Windows Users: Hold down Ctrl + Alt + Shift when launching InDesign and respond affirmatively when asked if you want to reset.

By the way the thread you mentioned is for Illustrator. Even if they had come to a solution it may not have helped the problem in InDesign.

Views

1.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 04, 2017 0
Adobe Community Professional ,
Sep 04, 2017

Copy link to clipboard

Copied

This is not normal behavior. You did not say if it is happening with multiple fonts or just one. At any rate since InDesign should not be doing this I would suggest rebuilding your preferences just to make sure that this is happening even when the program is at its factory settings.

To reset preferences:

For Macintosh Users: With InDesign closed Launch a Finder Window in column view and click on your home folder. With the Option Key pressed choose Library from the Finder Go Menu. Within the Library folder find the folder called Preferences and within it find the following two files and delete them: “Adobe InDesign” and “com.adobe.InDesign.plist”. When InDesign is next launched it will create new preference files and the program will be restored to its defaults.

After you’ve reset up the program (make sure that no document window is open) to your liking, it is a really good idea to create copies of your personalized “mint” preference files (make sure that you quit the program before copying them—that finalizes your customization) and use them in the future to replace any corrupt versions you may need to delete.

For Windows Users: Hold down Ctrl + Alt + Shift when launching InDesign and respond affirmatively when asked if you want to reset.

By the way the thread you mentioned is for Illustrator. Even if they had come to a solution it may not have helped the problem in InDesign.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 04, 2017 1
New Here ,
Nov 08, 2020

Copy link to clipboard

Copied

Hi, I had the same issue but when I followed your suggestion, InDesign couldn't connect to the internet anymore even though my connection was stable and strong. I had to uninstall and reinstall InDesign to get it to function at all after that. Is there any way to keep a chosen font and fix this issue without that method? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2020 0
Adobe Community Professional ,
Nov 09, 2020

Copy link to clipboard

Copied

Hi cosmoc75944851 and Fiona,

the reason for this behavior could very well be the used font. Therefore the used glyph.

So select the glyph and look it up in the Glyphs Panel.

 

As is shown in this thread:

 

Apostrophe Spacing Issue with Font Adobe Myungjo Std.
Anna5EED, Nov 03, 2020

https://community.adobe.com/t5/indesign/apostrophe-spacing-issue-with-font-adobe-myungjo-std/m-p/115...

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2020 0