• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
26

P: Book Module – Unfinished book vanishes

Community Beginner ,
Apr 02, 2012 Apr 02, 2012

Copy link to clipboard

Copied

I’m creating my first Blurb book inside of Lightroom 4. There are some 175 images in my collection/filmstrip. I was about 80% complete with the book, when I selected an image to go into the Development Module for adjustments. When done I returned to the Book Module. But the book was gone! The filmstrip at the bottom of the page is there indicating images are in the book, but the book itself is empty with only a cover and two blank pages. If I add an already “used” image, the filmstrip counter goes from 1 to 2.

Trying to fix this problem, I backed up and optimized my catalog. But upon restarting Lightroom no change... and no book!

Any suggestions as how to get my book back? Or do I have to start over!

Bug Fixed
TOPICS
macOS , Windows

Views

887

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Employee , Dec 02, 2012 Dec 02, 2012
Hi Ben,

This bug is fixed in Lightroom 4.3. Upgrading may not recover your book, but will prevent you from losing books in the future.

Becky

Votes

Translate

Translate
Adobe Employee , Oct 09, 2012 Oct 09, 2012
Sharad, the product manager for Lightroom, has just posted an update as blog entry on this book issue. It includes specifics on what can cause it and how to avoid it. Thanks to the help of Marko and few other users the team has tracked down a reproducible case/steps that the team can use to nail down a more permanent fix in a future update to Lightroom 4:

http://blogs.adobe.com/lightroomjourn...

Votes

Translate

Translate
replies 124 Replies 124
124 Comments
LEGEND ,
Sep 13, 2012 Sep 13, 2012

Copy link to clipboard

Copied

Yeah, a single catalog its to risky as you say.. but there is and option in LR4 catalog options to do backups every day, every 30 days, every time you close LR, and whatever...

Do backups often... that will save your butt.. xD

Votes

Translate

Translate

Report

Report
LEGEND ,
Sep 13, 2012 Sep 13, 2012

Copy link to clipboard

Copied

Another guess is that the bug its related to the TYPE options in LR4.1... if you see the video, its happend just after I type down some text in the book..

LR4 has some problems too, with the TYPE options, like there is no "Acentos" in spanish options, and some times the page or the photo captions are aviable and they dont show... and there is another that the text selected its only highlighted when you are in the type function...

ETC...

Votes

Translate

Translate

Report

Report
Community Expert ,
Sep 13, 2012 Sep 13, 2012

Copy link to clipboard

Copied

Marko, could you answer my question? I watched your video and it looked to me like the problem happened at the moment when you quickly moved from Book to Develop and quickly back to Book.

It may be similar to what I think I've been doing when it's happened here - in my case switching to a different book while in Book. Following this theory, I usually change between books by going back to Library and I've not lost a book while using this (unacceptable) method.

So is it the quick module change that always causes the problem?

Votes

Translate

Translate

Report

Report
Community Beginner ,
Sep 13, 2012 Sep 13, 2012

Copy link to clipboard

Copied

FYI, through my Adobe back channel, I was able to get Marko’s youtube link to both the guy who runs the Lightroom team, as well as an engineer who is working on the issue. Hopefully they'll be able get this nasty bug resolved. I believe that any other observations from users that might help pinpoint when this bug occurs would be helpful.

If anyone from Adobe is monitoring his thread, it would be nice if you would acknowledge in this thread that Adobe is working on this problem. You have a group of users here that are interested in helping out to resolve this issue.

Votes

Translate

Translate

Report

Report
Community Expert ,
Sep 13, 2012 Sep 13, 2012

Copy link to clipboard

Copied

The thread is marked as "in progress"

Votes

Translate

Translate

Report

Report
LEGEND ,
Sep 13, 2012 Sep 13, 2012

Copy link to clipboard

Copied

It is so hard to believe that Adobe (Lightroom) has ignored this BOOK module problem for 8 months. It doesn't take 8 months to fix a bug in software. Why are they not taking this seriously? Mark

Votes

Translate

Translate

Report

Report
Community Expert ,
Sep 13, 2012 Sep 13, 2012

Copy link to clipboard

Copied

Look, we all want it resolved ASAP but it takes time if the bug only crops up infrequently and they can't replicate it. And they are taking it seriously - in fact there may be more than one bug with the same external symptoms, and one was apparently resolved in 4.1.

Votes

Translate

Translate

Report

Report
LEGEND ,
Sep 13, 2012 Sep 13, 2012

Copy link to clipboard

Copied

I am having the same problem that was described in the original post. I lost my book pasting in text for a page caption. In addition, the backed up catalog is EXTREMELY slow to load the imagaes (I would venture to guess this is a LR issue not a Computer issue since this only occurs when I'm in a backup catalog.)

Would love to find a fix for this. ASAP.

thanks!

Votes

Translate

Translate

Report

Report
LEGEND ,
Sep 17, 2012 Sep 17, 2012

Copy link to clipboard

Copied

Hi again!

I got the bug in a Step By Step procedure video!.. Hope this help the adobe lr4 team to put an end to this..

uploading the video to youtube right now...

Votes

Translate

Translate

Report

Report
LEGEND ,
Sep 17, 2012 Sep 17, 2012

Copy link to clipboard

Copied

Got the step by step video on this bug... I try this with the same book 5 times, and it work to recreate the problem..

Uploading the Video now...

Votes

Translate

Translate

Report

Report
LEGEND ,
Sep 17, 2012 Sep 17, 2012

Copy link to clipboard

Copied

There you go:

http://youtu.be/uXICvRYjEVM

Adobe Photoshop Lightroom 4.1 - Library Module - Vanishing Book Bug
In a step by Step video!

Good Luck Adobe!

Votes

Translate

Translate

Report

Report
LEGEND ,
Sep 17, 2012 Sep 17, 2012

Copy link to clipboard

Copied

Adobe Photoshop Lightroom 4.1 - Library Module - Vanishing Book Bug

https://www.youtube.com/watch?v=uXICvR...

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Sep 18, 2012 Sep 18, 2012

Copy link to clipboard

Copied

The problem hasn't been ignored, but as I explained before we can't go into the application code and make random changes to try to fix this. There is nothing in the code that says "Corrupt book = on".

In order to fix something, you have to test it. And in a test you say: does it work or does it not work. For us, without making any changes, we run a test and the result is: it works. Without being able to reproduce the issue on our side, we cannot proceed with any further testing. We know that it is happening for some people, but try as we might, even following the exact same steps as others running into this, the behavior doesn't happen on our side.

Obviously, something triggers the behavior, but if it is a certain set of steps within the application, we haven't found the formula yet. It could be something else entirely, like some attribute of the files used in the book, or settings on the book, or something entirely exterior to Lightroom altogether.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Sep 18, 2012 Sep 18, 2012

Copy link to clipboard

Copied

We'd love to find a fix for this as well. But right now we are still looking for the cause.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 03, 2012 Oct 03, 2012

Copy link to clipboard

Copied

Brett,
I have been working for the past 100 hours or so on a 200+ page book in the book module in LR4.
2 things to try:
I went to look at an alternate size for my "saved" book (been working on it for a few weeks now) Deleted the duplicate and went back to my original book which now showed a full filmstrip (including the usage numbers showing me that all of the images had been used including a tiny 2 for a cover image) and the 4 blank pages we all see upon starting a project. My entire book was gone. Poof!
I'm surprised you didn't hear my scream all the way in San Jose.
This couldn't be...I had officially saved the book several weeks ago when I first began it and had been working on it steadily ever since. (For the record, I am working on a Mac OS X v10.7.5 and updated LR to v4.2.)
I can't begin to tell you the sick feeling over losing this amount of work. I went to your LR forums to see if this was unique to me (Did I inadvertently hit a button I shouldn't have?) I have always felt very confidant in LR's "saving" and "backup" abilities. Now I am devastated and have lost total confidence. Do I try again in LR or move to another program?
When I opened my most recent backup of LR, all the text was missing and many of the images were in color (this is a book of monochrome imagery) Huh? When I went into my Time Capsule backups, same thing. No text and many images were reset to original RAW files as if no post-processing had been done. Huh? (Again)

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 09, 2012 Oct 09, 2012

Copy link to clipboard

Copied

Sharad, the product manager for Lightroom, has just posted an update as blog entry on this book issue. It includes specifics on what can cause it and how to avoid it. Thanks to the help of Marko and few other users the team has tracked down a reproducible case/steps that the team can use to nail down a more permanent fix in a future update to Lightroom 4:

http://blogs.adobe.com/lightroomjourn...

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 09, 2012 Oct 09, 2012

Copy link to clipboard

Copied

Jeffrey, I clicked on the link but it said page not found.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 09, 2012 Oct 09, 2012

Copy link to clipboard

Copied

You're right.

Jeff, can you edit your post, there is an extra character at the end of your link:
blogs.adobe.com/lightroomjournal/2012/10/help-with-disappearing-books-in-lightroom-4.html%EF%BB%BF. This is creating a square at the end of the URL.

If anyone wants to get to this link before we get this fixed, just click the link and go to your address bar and delete the last character and Go.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 09, 2012 Oct 09, 2012

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 09, 2012 Oct 09, 2012

Copy link to clipboard

Copied

Sharad, the product manager for Lightroom, has just posted an update as blog entry on this book issue. It includes specifics on what can cause it and how to avoid it. Thanks to the help of Marko and few other users the team has tracked down a reproducible case/steps that the team can use to nail down a more permanent fix in a future update to Lightroom 4:

http://blogs.adobe.com/lightroomjourn...

(With fixed link)

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 09, 2012 Oct 09, 2012

Copy link to clipboard

Copied

I have been creating a book in Lightroom 4.1. Spent fairly large chunks of time on it. Was getting fairly near the end, when I was doing a couple of things today. I noticed an image that I thought needed more developing, so I selected it on the filmstrip, went in the Develop module, made some changes and came back to the Book module. All pages gone. All 54 of them. Victoria Brampton on the Lightroom Forums site suggested that you were trying to track Boob to Develop to Book issues. I'll help any way I can

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 16, 2012 Oct 16, 2012

Copy link to clipboard

Copied

While using Lightroom 4.1 on Mac, I created a book with 240 pages - Std Landscape, which took several hours. I saved the book. I then attempted to edit one image from the book in the Develop Module, and then Lightroom would not go back to the book module.
I quit LR4 and when prompted to back up the book, I did so.
Upon relaunching LR4, all 240 book pages had dissaperared, but the filmstrip at the bottom was still present.
Please can you help as this has taken many hours and I need to get the book sent to Blurb as soon as possible. Many thanks.

Votes

Translate

Translate

Report

Report
New Here ,
Oct 16, 2012 Oct 16, 2012

Copy link to clipboard

Copied

Lightroom V4.1, I lost my book.
(Sorry for my bad English, I'm French)
I worked a full day making a professional book and suddenly, by switching from the development module to the book module all my book (a full day work) was gone! I used to duplicate it from time to time but even the duplicates books were lost.
For your information, in case if it helps, I use mixed files formats for the book photos: jpg, raw, dng and even tif because I use sometimes the Topaz Adjust plug-in.
And there is no way to save the book outside Lightroom while working, nether to print or save a double page layout to remember the layout in order to make the book again.
The book module is fantastic but thank you for resolving this very big issue as I use it for my work.
Best regards,
Philippe

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 16, 2012 Oct 16, 2012

Copy link to clipboard

Copied

I've been writing Blurb for weeks trying to get them to warn their users about this problem but they won't. Of course Adobe should warn people too...

Unfortunately, it seem these companies are more concerned with damage control than trying to do what is best for customers.

Sorry about the incident, happened to me too, it sucks.

Also check to see if you have a backup catalog, maybe that will have an old version of the book.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 16, 2012 Oct 16, 2012

Copy link to clipboard

Copied

There has been progress folks but just as a safeguard, export your book to PDF if only so you can have a copy to help should you need to recreate it.
Alternately, just take screenshots of enlarged thumbnails or spreads

Votes

Translate

Translate

Report

Report