• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
16

P: Flag not saved to XMP if XMP:Pick missing from file metadata

LEGEND ,
Mar 10, 2024 Mar 10, 2024

Copy link to clipboard

Copied

LR 13.2 won't save the current flag to XMP if the field XMP:Pick is missing from the file and no other metadata field has been changed in the catalog. To reproduce:

 

1. Download and open this tiny catalog:

https://www.dropbox.com/s/1yvu2uib5uup416/pick-bug.2024.03.10.zip?dl=0

 

2. Select the one photo and do Photo > Set Flag > Flagged. Observe that the pick flag now appears on the thumbnail but Metadata Status is still Up To Date (incorrect)

 

4. Do Metadata > Save Metadata To File.

 

5. Run "exiftool -xmp:pick 7.jpg" and observe there's no output (incorrect).

 

6. Change the caption to "Hello world!". Observe Metadata Status is now Has Been Changed.

 

7. Do Metadata > Save Metadata To File and observe Metadata Status is now Up To Date.

 

8. Run "exiftool -xmp:pick 7.jpg" and observe the correct output:

 

 

Pick                            : 1

 

 

 

9. Do Photo > Set Flag > Unflagged and observe Metadata Status is Has Been Changed.

 

10. Do Metadata > Save Metadata To File and observe Metadata Status is now Up To Date.

 

11. Run "exiftool -xmp:pick 7.jpg" and observe the correct output:

 

 

Pick                            : 0

 

 

 

 

Bug Acknowledged
TOPICS
macOS , Windows

Views

216

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , Mar 11, 2024 Mar 11, 2024

The team has a bug for this. I've linked your report to the bug.

Status Acknowledged

Votes

Translate

Translate
9 Comments
Advocate ,
Feb 21, 2024 Feb 21, 2024

Copy link to clipboard

Copied

The new update brings the following

 

  • Support to read and write flag states to XMP.

 

This is not retroactive.

 

Flag IS NOT automatically written for the photos that have ti already AND  it will be written the next time an edit is made OR by saving manually.

 

Problem: there is not an internal method to find photos that do not have the Flag written into XMP.

 

Solution: ????

 

 

.

 

 

Votes

Translate

Translate

Report

Report
Community Expert ,
Feb 21, 2024 Feb 21, 2024

Copy link to clipboard

Copied

Most of your flagged images will not have the flags in XMP yet, so simply select all flagged photos and write metadata to files manually.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Advocate ,
Feb 21, 2024 Feb 21, 2024

Copy link to clipboard

Copied

quote

So select all flagged photos and write metadata to files manually.

 


By @JohanElzenga

 

I already did that but I had to stop the saving process because it was taking hours and hours and was impossible to do any  editing as LrC was slowed to a cripple.

 

Now some photos have the flag in XMP and others don't.

 

How to find the photos that actually need flag to be saved into XMP?

 

.

Votes

Translate

Translate

Report

Report
Community Expert ,
Feb 21, 2024 Feb 21, 2024

Copy link to clipboard

Copied

I don't think you can, so do it overnight. Writing to XMP by itself is no big deal.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Advocate ,
Mar 09, 2024 Mar 09, 2024

Copy link to clipboard

Copied

@johnrellis Is there a way for "Any Filter" to find photos that do not have the Flag already written in the XMP ?

 

.

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 09, 2024 Mar 09, 2024

Copy link to clipboard

Copied

[This post contains formatting and embedded images that don't appear in email. View the post in your Web browser.]

 

You can use this Any Filter query:

 

johnrellis_0-1710051747389.png

 

Note there is a bug in Metadata > Save Metadata To File where the flag won't be saved to the file if XMP:Pick is currently missing from the file and no other metadata field has been changed in the catalog.  I'll file a bug report on this tomorrow (I'm on a United flight and Unitied Wifi won't let me access Dropbox, even to upload a small file.)

Votes

Translate

Translate

Report

Report
Advocate ,
Mar 10, 2024 Mar 10, 2024

Copy link to clipboard

Copied

Ok, you figured out the cause of a bug I encountered already.

 

In my case flag is properly written after saving metadata BUT there is a condition/conundrum to make that happen: "Auto Save into XMP" must be enabled and running.

 

After the user selects X images and perform a manual save the "Auto Save into XMP" will go over again all those same images (AND I think that is the moment when the flag is actually written)

 

Screenshot 2024-03-10 at 09.44.37.png

 

As you can see in the screenshot above auto save is re-saving all over again 1600+ images I just saved manually

 

I reported internally this "second save instance" time ago and I thought it was a bug BUT in reality the real bug is that "Save Metadata" is not writing the flag to begin with...the "Auto Save" is kinda fixing things for us.

 

 

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 10, 2024 Mar 10, 2024

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Mar 11, 2024 Mar 11, 2024

Copy link to clipboard

Copied

LATEST

The team has a bug for this. I've linked your report to the bug.

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Status Acknowledged

Votes

Translate

Translate

Report

Report